RuntimeWarning: couldn't determine platform's TOTAL_PHYMEM warnings.warn("couldn't determine platform's TOTAL_PHYMEM", RuntimeWarning) while run ./mach build for Ubuntu 12.04 64 bit os

Hello I android developer i just work to build Firefox android build by Ste=
p given in This Site :

https://wiki.mozilla.org/Mobile/Fennec/Android#Explained

Now let me give my system Info :
Ubuntu 12.04 64 Bit OS=20
4 GB RAM
Processor :Intel(R) Core(tm) i3-2120 CPU @ 3.30GHz =D7 4

I follow below step and which work fine with out any Error :

sudo apt-get update
sudo apt-get build-dep firefox
sudo apt-get install ant
wget http://dl.google.com/android/ndk/android-ndk-r8e-linux-x86_64.tar.bz2
tar -xjf android-ndk-r8e-linux-x86_64.tar.bz2
wget http://dl.google.com/android/adt/adt-bundle-linux-x86_64-20131030.zip
unzip adt-bundle-linux-x86_64-20131030.zip
apt-get install -y ia32-libs
sudo apt-get install mercurial ccache
sudo apt-get build-dep firefox

I have create .mozconfig by  below code :

# Add the correct paths here:
 ac_add_options --with-android-ndk=3D"$HOME/android-ndk-r8e"
 ac_add_options --with-android-sdk=3D"$HOME/adt-bundle-linux/sdk/platforms/=
android-16"

 # android options
 ac_add_options --enable-application=3Dmobile/android
 ac_add_options --target=3Darm-linux-androideabi

Now when i Run first time :

Mozilla/src$ ./mach build

It process and setup some file and at end it say me re run  same command .

Now when i re run it it give below Error :
Mozilla/src$ ./mach build
/home/ubbvand2/Himanshu/Mozilla/src/python/psutil/psutil/_pslinux.py:108: R=
untimeWarning: couldn't determine platform's TOTAL_PHYMEM
  warnings.warn("couldn't determine platform's TOTAL_PHYMEM", RuntimeWarnin=
g)
Error running mach:

    ['build']

The error occurred in code that was called by the mach command. This is eit=
her
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this err=
or
message.

The details of the failure are as follows:

AttributeError: 'module' object has no attribute 'get_sysinfo'

  File "/home/ubbvand2/Himanshu/Mozilla/src/python/mozbuild/mozbuild/mach_c=
ommands.py", line 287, in build
    monitor.init(warnings_path)
  File "/home/ubbvand2/Himanshu/Mozilla/src/python/mozbuild/mozbuild/contro=
ller/building.py", line 161, in init
    self.resources =3D SystemResourceMonitor(poll_interval=3D1.0)
  File "/home/ubbvand2/Himanshu/Mozilla/src/testing/mozbase/mozsystemmonito=
r/mozsystemmonitor/resourcemonitor.py", line 180, in __init__
    virt =3D psutil.virtual_memory()
  File "/home/ubbvand2/Himanshu/Mozilla/src/python/psutil/psutil/__init__.p=
y", line 1170, in virtual_memory
    return _psplatform.virtual_memory()
  File "/home/ubbvand2/Himanshu/Mozilla/src/python/psutil/psutil/_pslinux.p=
y", line 143, in virtual_memory
    total, free, buffers, shared, _, _ =3D _psutil_linux.get_sysinfo()

I found solution here :https://bugzilla.mozilla.org/show_bug.cgi?id=3D93080=
8#c5

But that seem does not work in my case .
My  python package for  python-psutil	1.2.1-1~ppa1 is installed.


Any help will be great to go further for me.



0
himanshu
4/14/2014 10:57:07 AM
mozilla.dev.platform 6647 articles. 0 followers. Post Follow

1 Replies
1825 Views

Similar Articles

[PageSpeed] 10

On Monday, April 14, 2014 4:27:07 PM UTC+5:30, himansh...@brainvire.com wro=
te:
> Hello I android developer i just work to build Firefox android build by S=
tep given in This Site :
>=20
>=20
>=20
> https://wiki.mozilla.org/Mobile/Fennec/Android#Explained
>=20
>=20
>=20
> Now let me give my system Info :
>=20
> Ubuntu 12.04 64 Bit OS=20
>=20
> 4 GB RAM
>=20
> Processor :Intel(R) Core(tm) i3-2120 CPU @ 3.30GHz =D7 4
>=20
>=20
>=20
> I follow below step and which work fine with out any Error :
>=20
>=20
>=20
> sudo apt-get update
>=20
> sudo apt-get build-dep firefox
>=20
> sudo apt-get install ant
>=20
> wget http://dl.google.com/android/ndk/android-ndk-r8e-linux-x86_64.tar.bz=
2
>=20
> tar -xjf android-ndk-r8e-linux-x86_64.tar.bz2
>=20
> wget http://dl.google.com/android/adt/adt-bundle-linux-x86_64-20131030.zi=
p
>=20
> unzip adt-bundle-linux-x86_64-20131030.zip
>=20
> apt-get install -y ia32-libs
>=20
> sudo apt-get install mercurial ccache
>=20
> sudo apt-get build-dep firefox
>=20
>=20
>=20
> I have create .mozconfig by  below code :
>=20
>=20
>=20
> # Add the correct paths here:
>=20
>  ac_add_options --with-android-ndk=3D"$HOME/android-ndk-r8e"
>=20
>  ac_add_options --with-android-sdk=3D"$HOME/adt-bundle-linux/sdk/platform=
s/android-16"
>=20
>=20
>=20
>  # android options
>=20
>  ac_add_options --enable-application=3Dmobile/android
>=20
>  ac_add_options --target=3Darm-linux-androideabi
>=20
>=20
>=20
> Now when i Run first time :
>=20
>=20
>=20
> Mozilla/src$ ./mach build
>=20
>=20
>=20
> It process and setup some file and at end it say me re run  same command =
..
>=20
>=20
>=20
> Now when i re run it it give below Error :
>=20
> Mozilla/src$ ./mach build
>=20
> /home/ubbvand2/Himanshu/Mozilla/src/python/psutil/psutil/_pslinux.py:108:=
 RuntimeWarning: couldn't determine platform's TOTAL_PHYMEM
>=20
>   warnings.warn("couldn't determine platform's TOTAL_PHYMEM", RuntimeWarn=
ing)
>=20
> Error running mach:
>=20
>=20
>=20
>     ['build']
>=20
>=20
>=20
> The error occurred in code that was called by the mach command. This is e=
ither
>=20
> a bug in the called code itself or in the way that mach is calling it.
>=20
>=20
>=20
> You should consider filing a bug for this issue.
>=20
>=20
>=20
> If filing a bug, please include the full output of mach, including this e=
rror
>=20
> message.
>=20
>=20
>=20
> The details of the failure are as follows:
>=20
>=20
>=20
> AttributeError: 'module' object has no attribute 'get_sysinfo'
>=20
>=20
>=20
>   File "/home/ubbvand2/Himanshu/Mozilla/src/python/mozbuild/mozbuild/mach=
_commands.py", line 287, in build
>=20
>     monitor.init(warnings_path)
>=20
>   File "/home/ubbvand2/Himanshu/Mozilla/src/python/mozbuild/mozbuild/cont=
roller/building.py", line 161, in init
>=20
>     self.resources =3D SystemResourceMonitor(poll_interval=3D1.0)
>=20
>   File "/home/ubbvand2/Himanshu/Mozilla/src/testing/mozbase/mozsystemmoni=
tor/mozsystemmonitor/resourcemonitor.py", line 180, in __init__
>=20
>     virt =3D psutil.virtual_memory()
>=20
>   File "/home/ubbvand2/Himanshu/Mozilla/src/python/psutil/psutil/__init__=
..py", line 1170, in virtual_memory
>=20
>     return _psplatform.virtual_memory()
>=20
>   File "/home/ubbvand2/Himanshu/Mozilla/src/python/psutil/psutil/_pslinux=
..py", line 143, in virtual_memory
>=20
>     total, free, buffers, shared, _, _ =3D _psutil_linux.get_sysinfo()
>=20
>=20
>=20
> I found solution here :https://bugzilla.mozilla.org/show_bug.cgi?id=3D930=
808#c5
>=20
>=20
>=20
> But that seem does not work in my case .
>=20
> My  python package for  python-psutil	1.2.1-1~ppa1 is installed.
>=20
>=20
>=20
>=20
>=20
> Any help will be great to go further for me.

If any one have same issue like me then they can follow step like below .

1)sudo apt-get --purge remove python-psutil

2)sudo apt-get --purge autoremove

3)sudo apt-get update

4)Follow step from this link to install psutil-1.0.1.tar.gz  https://bugzil=
la.mozilla.org/show_bug.cgi?id=3D908296

5) Unzip it and sudo -s

6)cd psutil
python setup.py install
python -c "import psutil; psutil.virtual_memory()"

make sure when you are running above two command you have root permission e=
lse it may be fail due to permission issue .

8) sudo -s

9)Mozilla /src/./mach build=20

it is now working for me.
0
himanshu
4/14/2014 1:01:01 AM
Reply:

Similar Artilces:

Can't build spidermonkey: "couldn't find exact-width integer types" / cannot lstat `conftest.exe': Permission denied
Hi, I am trying to build spidermonkey on Windows 7 / Visual Studio 2008 SP1 / Windows SDK 7.0 from the comm-central given the information in MDC (https://developer.mozilla.org/En/SpiderMonkey/ Build_Documentation), but it fails to compile. When I am trying something like: cd js/src make -f Makefile.ref I'll get this error: d:\mozilla\repo\js\src\jsinttypes.h(118) : fatal error C1189: #error : "couldn't find exact-width integer types" and if I am trying it another way, like: cd js/src autoconf-2.13 ../configure make Then I'll get another erro...

Shouldn't a "sub" panel be hidden if it's in a panel that isn't visible?
I have two panels on a page.  Panel A, and then within Panel A is Panel B.  If Panel A's visibility is False, shouldn't Panel B's visibility automatically be false because it's within Panel A?  Never make important decisions on a Monday! If you mean its property, then no it will be whatever you set it to.If you mean whether or not it is rendered to html, then if it's parent isn't rendered, then it isn't rendered.You can set the visibilty of nested panels independently of their parents, what if you have two nested and you want to hide one and not t...

"chdir 't' if -d 't'" is evil?
Hi, I'm working on a release of PathTools, including File::Spec and Cwd. I've been told (though I never quite grokked it) to put the following code in the test scripts: BEGIN { chdir 't' if -d 't'; if ($ENV{PERL_CORE}) { @INC = '../lib'; } } use Cwd; However, I've just realized that this messes up @INC, because the Cwd.pm we need to test is in blib/lib/, which is added to the path by -Mblib, but it won't be found if we chdir('t'). I would really like to remove that whole block and make Tes...

Can't open doc's across PO's in "live" mode over the web...
Using GWise 6.5, NetWare 6.0 The POA's are NAT'd through our firewall. In our production environment we have 4 POA's with approx. 30 libraries spread out among them. The libraries are created under the PO's. Each PO has it's own set of libraries and does both email & library processing. In our test environment, I have 1 PO for email only (no libraries) and another PO for documents only (no email) with a library created under it. The following error happens in both environments: When users are logged into GWise from outside the LAN in "live...

Steve Jobs: Google's 'Don't Be Evil' motto is "bullshit"
Keeping in tradition with what happened after the release of the original iPhone, Steve Jobs held a meeting at the Town Hall in Cupertino following the release of the iPad, in order for employees to ask questions about the company and the new device. There has been much debate over the lack of Flash on the iPad, so as you'd expect, that was a strong talking point during the meeting, in addition to some less positive words about Apple's current ally, Google . http://www.neowin.net/news/steve-jobs-google039s-039don039t-be-evil039-motto-is-quotbullshitquot -- "If U kn...

Can't turn off Gnome's "Laptop battery low" warning
I have Gnome v2.30.0 and Gnome displays the "laptop battery low" warning too frequently. It pops up many times. Laptop battery at 20%...battery at 19%....battery at 18%....battery at 17%...warning battery critically low...warning battery below critical... How do I turn off these messages? I've had this problem for a year now. I tried to turn it off, but it stays on regardless of how I change things in Gnome Configuration Editor (see image link below). Does anyone have an idea I could try, please? 'ImageShack® - Online Photo and Video Hosting' (...

superreview cancelled: [Bug 90906] Fix all "Unused variable '[...]'" 'Build Warnings'. : [Attachment 137382] (Hv1) "Unused variable `[...]'", with no function call.
Serge GAUTHERIE <gautheri@noos.fr> has cancelled Serge GAUTHERIE <gautheri@noos.fr>'s request for superreview: Bug 90906: Fix all "Unused variable '[...]'" 'Build Warnings'. http://bugzilla.mozilla.org/show_bug.cgi?id=90906 Attachment 137382: (Hv1) "Unused variable `[...]'", with no function call. http://bugzilla.mozilla.org/attachment.cgi?id=137382&action=edit ------- Additional Comments from Serge GAUTHERIE <gautheri@noos.fr> Re comment 22: I'll split this global patch back to individual "modules"...

Wired's Vista "Do's" Have Some Major "Don'ts"
Wired has an article up about how to speed up Vista. While they have a couple OK tips in there, there are a couple of suggestions that caught my attention as colossally BAD. I tried to edit the wiki page to reflect this, but I was rebuffed by the original author. So much for community contributions. http://www.windows-now.com/blogs/robert/archive/2008/02/27/wireds-vista-dos-have-some-major-donts.aspx -- "Never drive faster than your ANGEL can fly" In grc.techtalk, on Fri, 14 Nov 2008 17:32:04, paradoX wrote: >Wired has an article up about how to speed up Vist...

[urgent] "Couldn't map the user's DN to a GUID, rc=-601"
Hi, Some user access Samba share get following error, Feb 22 11:25:28 OESFHQFS3 smbd[30071]: '/media/nss/HOME' does not exist or per mission denied when connecting to [HOME] Error was Permission denied Feb 22 11:25:28 OESFHQFS3 kernel: **** Couldn't map the user's DN to a GUID, rc=-601 But he able access before, any idea? Many thanks.... -- lywwing ------------------------------------------------------------------------ I too have seen this error message, however not with Samba or CIFS, but NSS itself. In my case I had found that the nds...

'do' won't 'do' if '/'
Greetings to All from Au, Have a NetWare Perl 5.8.4 and wanted to tweak File\Spec\NW.pm to try and standardise on '/' separators. If I run a test script (t/uni/lower.t) with an unmodified NW.pm, it calls t/uni/case.pl, that, in case.pl, (when the path separators are '\'), the $file is '..\lib\unicore\To\Lower.pl' and the following code portion works, with $simple getting a returned table: sub casetest { my ($base, $spec, $func) = @_; my $file = File::Spec->catfile(File::Spec->catdir(File::Spec->updir, "lib", &qu...

superreview granted: [Bug 378544] General's Default Feed Viewer's " =?UTF-8?Q?Select=E2=80=A6?=" doesn't use real elipsis
Mike Pinkerton <mikepinkerton@mac.com> has granted Stuart Morgan <stuart.morgan@alumni.case.edu>'s request for superreview: Bug 378544: General's Default Feed Viewer's "Select=E2=80=A6" doesn't use r= eal elipsis https://bugzilla.mozilla.org/show_bug.cgi?id=3D378544 Attachment 264750: changed https://bugzilla.mozilla.org/attachment.cgi?id=3D264750&action=3Dedit ------- Additional Comments from Mike Pinkerton <mikepinkerton@mac.com> rs=3Dpink= ...

superreview requested: [Bug 378544] General's Default Feed Viewer's " =?UTF-8?Q?Select=E2=80=A6?=" doesn't use real elipsis
Stuart Morgan <stuart.morgan@alumni.case.edu> has asked Mike Pinkerton <mikepinkerton@mac.com> for superreview: Bug 378544: General's Default Feed Viewer's "Select=E2=80=A6" doesn't use r= eal elipsis https://bugzilla.mozilla.org/show_bug.cgi?id=3D378544 Attachment 264750: changed https://bugzilla.mozilla.org/attachment.cgi?id=3D264750&action=3Dedit= ...

Couldn't Send Mail from DNN "Could not access 'CDO.Message' object."
Hello, I've currently been dealing with a problem of DNN 3.1.1 (clean install) being unable to send/test smtp settings.  The test button gives the message  Could not access 'CDO.Message' object.  I've gotten this message on two completely different servers, both clean installs.  Both servers have IIS SMTP installed and configured.  I am able to send test messages via php and all works great, but from asp.net/DNN 3.1.1 I seem to be unable to send messages.  I've tried multiple SMTP servers, and all of them seem to show no connection attempt even being made to it....

superreview requested: [Bug 122238] input type="image" doesn't send x/y (image doesn't exist; width and height not set) : [Attachment 139545] Same as jkeiser's patch, really...
Boris Zbarsky <bz-vacation@mit.edu> has asked Johnny Stenback <jst@mozilla.jstenback.com> for superreview: Bug 122238: input type="image" doesn't send x/y (image doesn't exist; width and height not set) http://bugzilla.mozilla.org/show_bug.cgi?id=122238 Attachment 139545: Same as jkeiser's patch, really... http://bugzilla.mozilla.org/attachment.cgi?id=139545&action=edit ...

Web resources about - RuntimeWarning: couldn't determine platform's TOTAL_PHYMEM warnings.warn("couldn't determine platform's TOTAL_PHYMEM", RuntimeWarning) while run ./mach build for Ubuntu 12.04 64 bit os - mozilla.dev.platform

Resources last updated: 12/15/2015 4:10:43 AM