PSA: ESlint 4 upgrade & node_modules clobber

I have just landed an upgrade to ESLint 4 on autoland, this will make 
its way to mozilla-central later today.

One thing to note: on upgrading from ESLint 3 to 4, it will clobber your 
topsrcdir/node_modules directory - this is intentional to try and avoid 
issues we've seen previously with upgrades of npm modules (for npm 
version 5).

ESLint 4 has lots of new features, including glob based configuration 
options, and lots of improved rules. We'll be making more use of these 
over the next few cycles.

Please consider installing the lint commit/push hooks 
<https://firefox-source-docs.mozilla.org/tools/lint/usage.html#using-a-vcs-hook> 
if you haven't already.

Mark


0
Mark
11/14/2017 7:44:52 AM
mozilla.dev.platform 6064 articles. 0 followers. Post Follow

0 Replies
3 Views

Similar Articles

[PageSpeed] 8

Reply: