Problem with hg and git

Hi,
I am trying to install firefox on Centos 7 from source. It seems that I am not able to clone via git or hg as shown below

[root@compute-0-4 src]# python bootstrap.py --vcs=git

Note on Artifact Mode:

Artifact builds download prebuilt C++ components rather than building
them locally. Artifact builds are faster!

Artifact builds are recommended for people working on Firefox or
Firefox for Android frontends, or the GeckoView Java API. They are unsuitable
for those working on C++ code. For more information see:
https://developer.mozilla.org/en-US/docs/Artifact_builds.

Please choose the version of Firefox you want to build:
  1. Firefox for Desktop Artifact Mode
  2. Firefox for Desktop
  3. GeckoView/Firefox for Android Artifact Mode
  4. GeckoView/Firefox for Android
Your choice: 2
Executing as root: yum groupinstall "Development Tools"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Executing as root: yum install autoconf213 nodejs which curl-devel python2-devel redhat-rpm-config
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Package autoconf213-2.13-31.el7.noarch already installed and latest version
No package nodejs available.
Package which-2.20-7.el7.x86_64 already installed and latest version
Package libcurl-devel-7.29.0-42.el7_4.1.x86_64 already installed and latest version
Package python-devel-2.7.5-58.el7.x86_64 already installed and latest version
Package redhat-rpm-config-9.1.0-76.el7.centos.noarch already installed and latest version
Nothing to do
Executing as root: yum groupinstall "Development Tools"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Executing as root: yum install alsa-lib-devel dbus-glib-devel glibc-static gtk2-devel libstdc++-static libXt-devel nasm pulseaudio-libs-devel wireless-tools-devel yasm gcc-c++ gtk3-devel python-dbus
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Package alsa-lib-devel-1.1.3-3.el7.x86_64 already installed and latest version
Package dbus-glib-devel-0.100-7.el7.x86_64 already installed and latest version
Package glibc-static-2.17-196.el7.x86_64 already installed and latest version
Package gtk2-devel-2.24.31-1.el7.x86_64 already installed and latest version
Package libstdc++-static-4.8.5-16.el7.x86_64 already installed and latest version
Package libXt-devel-1.1.5-3.el7.x86_64 already installed and latest version
Package nasm-2.10.07-7.el7.x86_64 already installed and latest version
Package pulseaudio-libs-devel-10.0-3.el7.x86_64 already installed and latest version
No package wireless-tools-devel available.
Package yasm-1.1.0-1.el6.rf.x86_64 already installed and latest version
Package gcc-c++-4.8.5-16.el7.x86_64 already installed and latest version
Package gtk3-devel-3.22.10-4.el7.x86_64 already installed and latest version
Package dbus-python-1.1.1-9.el7.x86_64 already installed and latest version
Nothing to do
Your version of Mercurial (2.6.2) is not modern enough.
(Older versions of Mercurial have known security vulnerabilities. Unless you are running a patched Mercurial version, you may be vulnerable.
Executing as root: yum update mercurial
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
No packages marked for update

We attempted to upgrade Mercurial to a modern version (4.8 or newer).
However, you appear to have version 2.6.2 still.

It's possible your package manager doesn't support a modern version of
Mercurial. It's also possible Mercurial is not being installed in the search
path for this shell. Try creating a new shell and run this bootstrapper again.

If it continues to fail, consider installing Mercurial by following the
instructions at http://mercurial.selenic.com/.

Your version of Python (2.7.5) is new enough.
Your version of Rust (1.36.0) is new enough.
Rust supports x86_64-unknown-linux-gnu targets.

Mozilla recommends using git-cinnabar to work with mozilla-central.

Would you like to run a few configuration steps to ensure Git is
optimally configured? (Yn): n

If you would like to clone the mozilla-unified Git repository, please
enter the destination path below.

Destination directory for Git clone (leave empty to not clone): /root
Destination directory '/root' is not empty.

Would you like to clone to '/root/mozilla-unified' instead?
  1. Yes
  2. No, let me enter another path
  3. No, stop cloning
Your choice: 1
Cloning Firefox repository to /root/mozilla-unified
Cloning into '/root/mozilla-unified'...
fatal: Unable to find remote helper for 'hg'
Command '['/usr/bin/git', 'clone', '-b', 'bookmarks/central', 'hg::https://hg.mozilla.org/mozilla-unified', '/root/mozilla-unified']' returned non-zero exit status 128

Source code can be obtained by running

    hg clone https://hg.mozilla.org/mozilla-unified

Or, if you prefer Git, by following the instruction here to clone from the
Mercurial repository:

    https://github.com/glandium/git-cinnabar/wiki/Mozilla:-A-git-workflow-for-Gecko-development

Or, if you really prefer vanilla flavor Git:

    git clone https://github.com/mozilla/gecko-dev.git


Build system telemetry

Mozilla collects data about local builds in order to make builds faster and
improve developer tooling. To learn more about the data we intend to collect
read here:
https://firefox-source-docs.mozilla.org/build/buildsystem/telemetry.html.

If you have questions, please ask in #build in irc.mozilla.org. If you would
like to opt out of data collection, select (N) at the prompt.

Would you like to enable build system telemetry? (Yn): n

Installing Stylo and NodeJS packages requires a checkout of mozilla-central.
Once you have such a checkout, please re-run `./mach bootstrap` from the
checkout directory.

[root@compute-0-4 src]#
[root@compute-0-4 src]#
[root@compute-0-4 src]#
[root@compute-0-4 src]#
[root@compute-0-4 src]# python bootstrap.py

Note on Artifact Mode:

Artifact builds download prebuilt C++ components rather than building
them locally. Artifact builds are faster!

Artifact builds are recommended for people working on Firefox or
Firefox for Android frontends, or the GeckoView Java API. They are unsuitable
for those working on C++ code. For more information see:
https://developer.mozilla.org/en-US/docs/Artifact_builds.

Please choose the version of Firefox you want to build:
  1. Firefox for Desktop Artifact Mode
  2. Firefox for Desktop
  3. GeckoView/Firefox for Android Artifact Mode
  4. GeckoView/Firefox for Android
Your choice: 2
Executing as root: yum groupinstall "Development Tools"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Executing as root: yum install autoconf213 nodejs which curl-devel python2-devel redhat-rpm-config
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Package autoconf213-2.13-31.el7.noarch already installed and latest version
No package nodejs available.
Package which-2.20-7.el7.x86_64 already installed and latest version
Package libcurl-devel-7.29.0-42.el7_4.1.x86_64 already installed and latest version
Package python-devel-2.7.5-58.el7.x86_64 already installed and latest version
Package redhat-rpm-config-9.1.0-76.el7.centos.noarch already installed and latest version
Nothing to do
Executing as root: yum groupinstall "Development Tools"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Executing as root: yum install alsa-lib-devel dbus-glib-devel glibc-static gtk2-devel libstdc++-static libXt-devel nasm pulseaudio-libs-devel wireless-tools-devel yasm gcc-c++ gtk3-devel python-dbus
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Package alsa-lib-devel-1.1.3-3.el7.x86_64 already installed and latest version
Package dbus-glib-devel-0.100-7.el7.x86_64 already installed and latest version
Package glibc-static-2.17-196.el7.x86_64 already installed and latest version
Package gtk2-devel-2.24.31-1.el7.x86_64 already installed and latest version
Package libstdc++-static-4.8.5-16.el7.x86_64 already installed and latest version
Package libXt-devel-1.1.5-3.el7.x86_64 already installed and latest version
Package nasm-2.10.07-7.el7.x86_64 already installed and latest version
Package pulseaudio-libs-devel-10.0-3.el7.x86_64 already installed and latest version
No package wireless-tools-devel available.
Package yasm-1.1.0-1.el6.rf.x86_64 already installed and latest version
Package gcc-c++-4.8.5-16.el7.x86_64 already installed and latest version
Package gtk3-devel-3.22.10-4.el7.x86_64 already installed and latest version
Package dbus-python-1.1.1-9.el7.x86_64 already installed and latest version
Nothing to do
Your version of Mercurial (2.6.2) is not modern enough.
(Older versions of Mercurial have known security vulnerabilities. Unless you are running a patched Mercurial version, you may be vulnerable.
Executing as root: yum update mercurial
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
No packages marked for update

We attempted to upgrade Mercurial to a modern version (4.8 or newer).
However, you appear to have version 2.6.2 still.

It's possible your package manager doesn't support a modern version of
Mercurial. It's also possible Mercurial is not being installed in the search
path for this shell. Try creating a new shell and run this bootstrapper again.

If it continues to fail, consider installing Mercurial by following the
instructions at http://mercurial.selenic.com/.

Your version of Python (2.7.5) is new enough.
Your version of Rust (1.36.0) is new enough.
Rust supports x86_64-unknown-linux-gnu targets.

Mozilla recommends a number of changes to Mercurial to enhance your
experience with it.

Would you like to run a configuration wizard to ensure Mercurial is
optimally configured? (Yn): n

If you would like to clone the mozilla-unified Mercurial repository, please
enter the destination path below.

Destination directory for Mercurial clone (leave empty to not clone): /root
Destination directory '/root' is not empty.

Would you like to clone to '/root/mozilla-unified' instead?
  1. Yes
  2. No, let me enter another path
  3. No, stop cloning
Your choice: 1
Cloning Firefox Mercurial repository to /root/mozilla-unified
pulling from https://hg.mozilla.org/mozilla-unified
requesting all changes
abort: remote error:
incompatible Mercurial client; bundle2 required
(see https://www.mercurial-scm.org/wiki/IncompatibleClient)


Failed to pull from hg.mozilla.org.

This is most likely because of unstable network connection.
Try running `hg pull https://hg.mozilla.org/mozilla-unified` manually, or
download mercurial bundle and use it:
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Source_Code/Mercurial/Bundles

Source code can be obtained by running

    hg clone https://hg.mozilla.org/mozilla-unified

Or, if you prefer Git, by following the instruction here to clone from the
Mercurial repository:

    https://github.com/glandium/git-cinnabar/wiki/Mozilla:-A-git-workflow-for-Gecko-development

Or, if you really prefer vanilla flavor Git:

    git clone https://github.com/mozilla/gecko-dev.git


Build system telemetry

Mozilla collects data about local builds in order to make builds faster and
improve developer tooling. To learn more about the data we intend to collect
read here:
https://firefox-source-docs.mozilla.org/build/buildsystem/telemetry.html.

If you have questions, please ask in #build in irc.mozilla.org. If you would
like to opt out of data collection, select (N) at the prompt.

Would you like to enable build system telemetry? (Yn): n

Installing Stylo and NodeJS packages requires a checkout of mozilla-central.
Once you have such a checkout, please re-run `./mach bootstrap` from the
checkout directory.





But, I can ping to the hg server

[root@compute-0-4 src]# ping hg.mozilla.org
PING hg.public.mdc1.mozilla.com (63.245.208.203) 56(84) bytes of data.
64 bytes from hg.public.mdc1.mozilla.com (63.245.208.203): icmp_seq=1 ttl=41 time=264 ms
64 bytes from hg.public.mdc1.mozilla.com (63.245.208.203): icmp_seq=2 ttl=40 time=264 ms
^C
--- hg.public.mdc1.mozilla.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 264.687/264.703/264.719/0.016 ms



Any idea?
0
Mahmood
7/16/2019 3:24:32 PM
mozilla.dev.platform 6540 articles. 0 followers. Post Follow

3 Replies
15 Views

Similar Articles

[PageSpeed] 11

Given how old your installed Mercurial version is, I suspect the problem 
with git (fatal: Unable to find remote helper for 'hg') is similar. I 
recommend installing updated Mercurial and git packages and trying again.

On 7/16/19 11:24 AM, Mahmood Naderan wrote:
> We attempted to upgrade Mercurial to a modern version (4.8 or newer).
> However, you appear to have version 2.6.2 still.

0
Josh
7/16/2019 3:53:37 PM
On Tue, Jul 16, 2019 at 8:25 PM Josh Bowman-Matthews <josh@joshmatthews.net>
wrote:

> Given how old your installed Mercurial version is, I suspect the problem
> with git (fatal: Unable to find remote helper for 'hg') is similar. I
> recommend installing updated Mercurial and git packages and trying again.
>



So, I removed hg and installed the latest git via yum on centos 7.

yum install http://opensource.wandisco.com/centos/7/git/x86_64/wandisco-git-release-7-2.noarch.rpm


Still git is unable to fetch the repository. Is it mandatory to have hg?
>From the error, I think it is needed after all.



[root@compute-0-4 ~]# git --version
git version 2.22.0
[root@compute-0-4 src]# python bootstrap.py --vcs=git

Note on Artifact Mode:

Artifact builds download prebuilt C++ components rather than building
them locally. Artifact builds are faster!

Artifact builds are recommended for people working on Firefox or
Firefox for Android frontends, or the GeckoView Java API. They are
unsuitable
for those working on C++ code. For more information see:
https://developer.mozilla.org/en-US/docs/Artifact_builds.

Please choose the version of Firefox you want to build:
  1. Firefox for Desktop Artifact Mode
  2. Firefox for Desktop
  3. GeckoView/Firefox for Android Artifact Mode
  4. GeckoView/Firefox for Android
Your choice: 2
Executing as root: yum groupinstall "Development Tools"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Executing as root: yum install autoconf213 nodejs which curl-devel
python2-devel redhat-rpm-config
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Package autoconf213-2.13-31.el7.noarch already installed and latest version
No package nodejs available.
Package which-2.20-7.el7.x86_64 already installed and latest version
Package libcurl-devel-7.29.0-42.el7_4.1.x86_64 already installed and latest
version
Package python-devel-2.7.5-58.el7.x86_64 already installed and latest
version
Package redhat-rpm-config-9.1.0-76.el7.centos.noarch already installed and
latest version
Nothing to do
Executing as root: yum groupinstall "Development Tools"
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update
Executing as root: yum install alsa-lib-devel dbus-glib-devel glibc-static
gtk2-devel libstdc++-static libXt-devel nasm pulseaudio-libs-devel
wireless-tools-devel yasm gcc-c++ gtk3-devel python-dbus
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Package alsa-lib-devel-1.1.3-3.el7.x86_64 already installed and latest
version
Package dbus-glib-devel-0.100-7.el7.x86_64 already installed and latest
version
Package glibc-static-2.17-196.el7.x86_64 already installed and latest
version
Package gtk2-devel-2.24.31-1.el7.x86_64 already installed and latest version
Package libstdc++-static-4.8.5-16.el7.x86_64 already installed and latest
version
Package libXt-devel-1.1.5-3.el7.x86_64 already installed and latest version
Package nasm-2.10.07-7.el7.x86_64 already installed and latest version
Package pulseaudio-libs-devel-10.0-3.el7.x86_64 already installed and
latest version
No package wireless-tools-devel available.
Package yasm-1.1.0-1.el6.rf.x86_64 already installed and latest version
Package gcc-c++-4.8.5-16.el7.x86_64 already installed and latest version
Package gtk3-devel-3.22.10-4.el7.x86_64 already installed and latest version
Package dbus-python-1.1.1-9.el7.x86_64 already installed and latest version
Nothing to do

Could not find Mercurial (hg) in the current shell's path. Try starting a
new
shell and running the bootstrapper again.

You do not have Mercurial installed
Executing as root: yum update mercurial
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Package(s) mercurial available, but not installed.
No packages marked for update

Could not find Mercurial (hg) in the current shell's path. Try starting a
new
shell and running the bootstrapper again.

Your version of Python (2.7.5) is new enough.
Your version of Rust (1.36.0) is new enough.
Rust supports x86_64-unknown-linux-gnu targets.

Mozilla recommends using git-cinnabar to work with mozilla-central.

Would you like to run a few configuration steps to ensure Git is
optimally configured? (Yn): n

If you would like to clone the mozilla-unified Git repository, please
enter the destination path below.

Destination directory for Git clone (leave empty to not clone): /root
Destination directory '/root' is not empty.

Would you like to clone to '/root/mozilla-unified' instead?
  1. Yes
  2. No, let me enter another path
  3. No, stop cloning
Your choice: 1
Cloning Firefox repository to /root/mozilla-unified
Cloning into '/root/mozilla-unified'...
fatal: unable to find remote helper for 'hg'
Command '['/usr/bin/git', 'clone', '-b', 'bookmarks/central', 'hg::
https://hg.mozilla.org/mozilla-unified', '/root/mozilla-unified']' returned
non-zero exit status 128

Source code can be obtained by running

    hg clone https://hg.mozilla.org/mozilla-unified

Or, if you prefer Git, by following the instruction here to clone from the
Mercurial repository:


https://github.com/glandium/git-cinnabar/wiki/Mozilla:-A-git-workflow-for-Gecko-development

Or, if you really prefer vanilla flavor Git:

    git clone https://github.com/mozilla/gecko-dev.git


Build system telemetry

Mozilla collects data about local builds in order to make builds faster and
improve developer tooling. To learn more about the data we intend to collect
read here:
https://firefox-source-docs.mozilla.org/build/buildsystem/telemetry.html.

If you have questions, please ask in #build in irc.mozilla.org. If you would
like to opt out of data collection, select (N) at the prompt.

Would you like to enable build system telemetry? (Yn): n

Installing Stylo and NodeJS packages requires a checkout of mozilla-central.
Once you have such a checkout, please re-run `./mach bootstrap` from the
checkout directory.




Regards,
Mahmood
0
Mahmood
7/16/2019 7:03:34 PM
Le 16/07/2019 à 17:24, Mahmood Naderan a écrit :
> Would you like to run a few configuration steps to ensure Git is
> optimally configured? (Yn): n


Maybe you should answer Y here ;)

To use git you need to use git-cinnabar which is the "hg helper" that's 
looked for later (and that the error is about). I _think_ this is 
installed automatically if you answer Y here.

0
Julien
8/2/2019 11:50:14 AM
Reply: