Dev Builds of Java SE 7 Plug-ins Not Working In Firefox 3.6a1pre builds

Dev Builds of Java SE 7 Plug-ins have not been working for over a couple 
of weeks now. I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; 
rv:1.9.2a1pre) Gecko/20090630 Minefield/3.6a1pre on Windows XP SP3. I'm 
not sure if I should file a bug with Mozilla or Sun. I know that Mozilla 
has been making changes under the hood with regards to how Firefox deal 
with java plug-ins and what not. The plug-in's list in the add-on's 
window suggests that it is working fine, but when I try to play java 
games that use the plug-in, it doesn't recognize that I have java 
installed. This is even though  This same plug-in works great with 
Firefox 3.5. With whom should I file this bug: Mozilla or Sun?
0
Michael
7/1/2009 6:17:06 AM
mozilla.dev.platform 6443 articles. 0 followers. Post Follow

1 Replies
642 Views

Similar Articles

[PageSpeed] 4

On development builds of the next Firefox we have removed the "OJI" code
that formed a glue-layer between Firefox and the old Java plugins. More
recent versions of Java communicate with the browser like other plugins
rather than using a special java-only interface.

Java 6 update 10 was the first using the new mechanism, I believe.

I guess you could try the latest Java 6 and see if that's working on the
trunk. If not it's probably a Mozilla problem. If Java 6 Update 14 is
working then maybe Java 7 is still trying to use the old interface, in
which case it's a Sun problem. Is Java 7 being made by a different team
than Java 6?


Michael Burns wrote:
> Dev Builds of Java SE 7 Plug-ins have not been working for over a couple
> of weeks now. I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.2a1pre) Gecko/20090630 Minefield/3.6a1pre on Windows XP SP3. I'm
> not sure if I should file a bug with Mozilla or Sun. I know that Mozilla
> has been making changes under the hood with regards to how Firefox deal
> with java plug-ins and what not. The plug-in's list in the add-on's
> window suggests that it is working fine, but when I try to play java
> games that use the plug-in, it doesn't recognize that I have java
> installed. This is even though  This same plug-in works great with
> Firefox 3.5. With whom should I file this bug: Mozilla or Sun?
0
Daniel
7/11/2009 6:34:38 AM
Reply:

Similar Artilces:

Java applet not working in firefox 3.1b3 and firefox 3.0.7
Name: Germain Hebert Email: grhebertatb2b2cdotca Product: Firefox Release Candidate Summary: Java applet not working in firefox 3.1b3 and firefox 3.0.7 Comments: This site is not work, working well with explorer. http://www.swixschool.com/web/wizard.html?langInput=lang2&menuInput=subM2 Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729) From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you mus...

Firefox 3.1 Beta 1 Build
Name: Martin Kaeser Email: martindotkaeseratgmaildotcom Product: Firefox Summary: Firefox 3.1 Beta 1 Build - Windows Media Player Plug-in doesn't work Comments: see summary Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1 (.NET CLR 3.5.30729) From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to see it. ...

How can I build a static build for firefox 3
Hi, I am trying to build a static build for firefox 3 on ubuntu. I was able to build firefox 3 non-static build okay. But as I enable these options in my .mozconfig, ac_add_options --enable-static ac_add_options --disable-shared I get these errors: c++ -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith - Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual- dtor -Wcast-align -Wno-long-long -pedantic -fno-strict-aliasing - fshort-wchar -pthread -pipe -DDEBUG -D_DEBUG -DDEBUG_scheung - DTRACING -g -fno-inline -Os -freorder-blocks -fno-reorder-functi...

problem with "undefined suppress"?: failed MODPERL-2 build on MacOSX (Apache/2.0.36 mod_perl/1.99_02-dev Perl/v5.7.3)
--==========2147493761========== Content-Type: text/plain; charset=us-ascii; format=flowed Content-Transfer-Encoding: 7bit Content-Disposition: inline hi all, i'm working on getting modperl2 up/running on OSX Server 10.1.4 w/ Apache 2.0.36 & perl 5.7.3. apache & perl build threaded w/o any trouble; however, modperl seems to choke .... modperl2 configure works fine as: perl Makefile.PL MP_AP_PREFIX=/usr/local/apache2 MP_USE_DSO=1 MP_USE_STATIC=0 MP_STATIC_EXTS=0 but "make" dies at: cc -I/Volumes/ServerSystem/ports/modperl-2.0/src/modules/perl ...

Migrate from PB 7.0.2 Build 8046 to PB 7.0.3 Build 10009
Is it a good move ? I use PB 7.0.2 C3 Build 8047 on Windows NT 4 sp 6a, but I want to move to Windows 2000 soon. I read than only the version 7.0.3 and above are Windows 2000 compilant. Do I have to expect some problems if I move to the version 7.0.3 Build 10009 than I dwonloaded from the sybase web site. Thank for your answers... Franc. Hi, I don't know if there is a technical problem. But my app. and PB works on Winnt 4.0 and Win2K server very fine. And i've don't received any problem reports since a long time. (The versions i've tested are 7.0, 7.0.2 ...

VS Builds, and Builds, and Builds
Hello, Has anyone else had this problem?  After a while of developing, and I go to compile, VS takes forever to build and I have to end-task it.  It's definitely after I've been working for a while, then it finally has "had it" and just takes forever to build.  It's annoying as I know its not the machine (2.8 GHZ processor and 1GB RAM).  Has anyone else experienced this problem?  By the way, I do have SP1 installed. Also, after minimizing and switching around screens, when it does this, the building icon in the status bar doesn't show.  And, for more informati...

How to do dev builds
Prior to PB 8.0 I used a test.pbl to test changes before moving into production. It was placed on top of the library list for the app. Any objects were copied into this pbl and a build was completed for user testing. With 8.0, the app target needs to be checked out to modify the library list. The other developer had to copy the new test.pbl from my machine to see the changes. Any objects the other developer needs to test had to be copied to my pc where the builds are done. This is not the best way and I'm assuming someone else has come up wiht a better solution since 8....

what are the differences between java 7.25 build 16 and build 17?
Today I saw that there are at least two builds for java 7.25, build 16 and build 17. I tried to find information about differences, but I could not find any. Do You know what are the differences? Thank You and regards Rodolfo Giovanninetti "Rodolfo Giovanninetti" wrote in message news:kut3cs$1n6o$1@news.grc.com > Today I saw that there are at least two builds for java 7.25, build 16 and > build 17. > I tried to find information about differences, but I could not find any. > Do You know what are the differences? > > Thank You and regards &...

Latest PB 7.0.3 Build after C5 Build# 10047
I am searching for latest PB 7.0.3 Build after C5 Build #10047 . It still has a lot of error in IDE , i am looking for a better Build , can anyone tell me what and where i can find it ?. All i got after searching in Sybase's Site is C5 Build# 10047. Thanks Ravi Ravi, There are weekly PB builds done that are available through Tech Support with limited QA. The latest build I have seen is build 10089. You should be able to get it from Tech Support. However, I am not sure what IDE errors you are speaking about, but I have found 10047 to be a very stable build. If you ...

Redirect working on Firefox 3.5.7. does not wor on Firefox 3.6.
Name: Product: Firefox Summary: Redirect working on Firefox 3.5.7. does not wor on Firefox 3.6. Comments: Mail.ru Agent www.agent.mail.ru gives an alert reference at every mail coming. Clicking on it rendered to the letter through Firefox 3.5.7., but Firefox 3.6. starts with a startpage. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.1; ru; rv:1.9.1.7) Gecko/20091221 MRA 5.5 (build 02761) Firefox/3.5.7 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not ...

Migrating from 7.0.3 Build 10077 to 9.0.1 Build 7119
Hi, we are trying to migrate our application from PB 7.0.3 Build 10077 to 9.0.1 Build 7119. We have a problem with several windows. Every time we are saving them we get the message: "An internal error has occurred" pops up and the changes are not saved .All "standard procedures" failed (export/import, regenerate, optimize ....). Any ideas ???? Thanx in advance Cheers Klaus ---== Posted via the PFCGuide Web Newsreader ==--- http://www.pfcguide.com/_newsgroups/group_list.asp Is the problem during your migration - or is the problem after your migrati...

How to build libevent-dev 2.0.10 in ooder to build new version of transmission?
looking for LIBEVENT... configure: error: Package requirements (libevent >= 2.0.10) were not met: In order to build transmission 2.21.I need libeventnew version of transmission,I need to build libevent-dev >= 2.0.10 and installed first.But I can't get any information about building development files for libevent. Anyone help me solve this problem?Thanks in advance. -- axishero ------------------------------------------------------------------------ News:I've download a 2.0.10 deb pkg and extra than copy the folder to /usr.Problem solved. -- a...

Latest dev build of 'AJAX Control Toolkit'
Good morning,Following a previous post:http://forums.asp.net/thread/1444162.aspx rbuckton mentioned a new 'CalendarExtender' that's going to be included in the next release of the AJAX Extensions.  I'd like to take a look at the hard work that's been put into it so far, so I downloaded the latest development build (Oct 31 6:38pm) from:http://www.codeplex.com/SourceControl/ListDownloadableCommits.aspx?ProjectName=AtlasControlToolkitI have opened the solution in VS 2005 and removed the source control bindings and tried to build.  The SampleWebSite and ToolkitTests...

Dr Watson problem while building the .EXE in PowerBuilder 7.0.3 Build 10047 c5
Hi, System Configuration: Windows NT 4.0 SP 6a Oracle 8.1.7 Client Dr. Watson error pops up when building an Exe with the following options: Project Build Option: Full Build Code Generation Options: Machine Code Trace information Error Content information With Speed Optimization Dr. Watson error pops up when the process of building is in "Inspecting Application Objects" stage. But the exe is created and can be run. It would be good if we can get the solution as soon as possible. Thanks and Regards, SBaskar ...

Web resources about - Dev Builds of Java SE 7 Plug-ins Not Working In Firefox 3.6a1pre builds - mozilla.dev.platform

UAE electronics retailer Plug Ins launches e-commerce site
The region’s e-commerce offerings are firmly in second place to malls and physical establishments. Plug Ins, the UAE-based electronics retailer, ...

IE plays security catch-up, will block outdated Java plug-ins
Microsoft's Internet Explorer will begin blocking out-of-date ActiveX controls when the company updates the versions that run on Windows 7 and ...

Poor WordPress documentation trips developers, yields plug-ins with XSS flaw
Ambiguous WordPress documentation led many plug-in and theme developers to make an error that exposed websites to cross-site scripting (XSS) ...

Logic Pro X 10.1 arrives w/ tons of new sounds, AirDrop sharing, redesigned plug-ins, & editing improvements ...
... version 1.2 of its Logic Remote iPad app with a new plug-in view for remotely controlling parameters and adding or rearranging plug-ins. The ...

Apple - Aperture - Photo Book Plug-Ins
Now you can easily create and order photo albums from some of the finest book makers in the world, right in Aperture.

Using multiple guitar plug-ins for better sound
Rich Tozzoli breaks down how best to use multiple guitar amp plug-ins to achieve unlimited sounds. I love doing this. Using different sounds ...

Toyota Won't Make Plug-Ins Standard On Prius
Contrary to a report in the Japanese press on May 9, a Toyota spokesman says the company has no plans to make plug-in technology standard equipment ...

Electrification Coalition sees plug-ins making up 25 percent of market by 2020
A new Electrification Coalition was announced today with the backing of the CEOs from twelve companies. What's interesting about this group is ...

NUGEN Audio Announces VST3 Compatibility Across Entire Range of Plug-Ins - Broadcasting & Cable
With Latest Version of Visualizer Audio Analysis Suite, All Current Plug-Ins Now Available in Steinberg VST3 Format LEEDS, U.K. Oct. 9, 2014 ...

IE plays security catch-up, will block outdated Java plug-ins
Microsoft's Internet Explorer will begin blocking out-of-date ActiveX controls when the company updates the versions that run on Windows 7 and ...

Resources last updated: 12/11/2015 12:35:36 PM