Problem Building firefox 1.5.0.7 and 1.5.0.9

Hello!

I'm trying to compile both firefox 1.5.0.7 and 1.5.0.9 in a Fedora Core 
6 to build a new extension.

However, I'm getting the problem that I attach bellow....

My mozconfig file is:

mk_add_options MOZ_CO_PROJECT=browser

# add other common options here, such as making a static release build and
# disabling tests
ac_add_options --enable-optimize --disable-debug
ac_add_options --disable-tests

# Build Firefox
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-static
ac_add_options --enable-application=browser


and I compile using:

#!/bin/bash
export MOZCONFIG=~/devel/mozilla/mozconfig
make -f client.mk build MOZ_CURRENT_PROJECT=browser


the error is:


gcc -o gtk2xtbin.o -c -I../../../dist/include/system_wrappers -include 
/root/devel/mozilla/config/gcc_hidden.h -DMOZILLA_INTERNAL_API 
-DOSTYPE=\"Linux2.6.20-1.2925\" -DOSARCH=\"Linux\" -DBUILD_ID=0000000000 
-D_IMPL_GTKXTBIN_API -DUSE_XIM  -I../../../dist/include/xpcom 
-I../../../dist/include/gtkxtbin -I../../../dist/include 
-I../../../dist/include/nspr    -I../../../dist/sdk/include 
-I/root/devel/mozilla/widget/src/gtkxtbin     -fPIC  -Wall -W 
-Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pedantic 
-pthread -pipe  -DNDEBUG -DTRIMMED -O -I/usr/include/gtk-2.0 
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo 
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 
-I/usr/lib/glib-2.0/include -I/usr/include/freetype2 
-I/usr/include/libpng12     -include ../../../mozilla-config.h 
-DMOZILLA_CLIENT -Wp,-MD,.deps/gtk2xtbin.pp 
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.c
En el fichero inclu�do de 
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.h:44,
                  de /root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.c:46:
.../../../dist/include/system_wrappers/X11/Intrinsic.h:3:32: error: 
X11/Intrinsic.h: No existe el fichero o el directorio
In file included from 
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.c:46:
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.h:78: error: expected 
specifier-qualifier-list before �Widget�
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.h:104: error: expected 
declaration specifiers or �...� before �String�
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.h:113: error: expected 
specifier-qualifier-list before �XtTranslations�
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.h:117: aviso: struct 
no tiene miembros
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.h:120: error: expected 
specifier-qualifier-list before �Widget�
/root/devel/mozilla/widget/src/gtkxtbin/gtk2xtbin.h:149: aviso: struct 
no tiene miembros


Could you help me, please?
Best regards,
Antonio.
0
windows
4/2/2007 3:59:04 PM
mozilla.dev.builds 1735 articles. 0 followers. Post Follow

4 Replies
792 Views

Similar Articles

[PageSpeed] 28

Antonio Ruiz Mart�nez wrote:

> X11/Intrinsic.h: No existe el fichero o el directorio

Do you have the X11 devel package(s) installed?
   Peter.
0
Peter
4/2/2007 2:11:07 PM
Peter Weilbacher escribi�:
> Antonio Ruiz Mart�nez wrote:
> 
>> X11/Intrinsic.h: No existe el fichero o el directorio
> 
> Do you have the X11 devel package(s) installed?


Thanks for your answer. I hadn't it ... I have installed it. But now I'm 
getting the following error:

mozilla-xremote-client.cpp
c++ -o mozilla-xremote-client.o -c 
-I../../../dist/include/system_wrappers -include 
/root/devel/mozilla/config/gcc_hidden.h -DOSTYPE=\"Linux2.6.20-1.2925\" 
-DOSARCH=\"Linux\" -DBUILD_ID=0000000000  -I../../../dist/include/xpcom 
-I../../../dist/include/xremoteclient -I../../../dist/include 
-I../../../dist/include/nspr    -I../../../dist/sdk/include    -fPIC 
-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith 
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy 
-Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread 
-pipe  -DNDEBUG -DTRIMMED -O   -DMOZILLA_CLIENT -include 
.../../../mozilla-config.h -Wp,-MD,.deps/mozilla-xremote-client.pp 
/root/devel/mozilla/widget/src/xremoteclient/mozilla-xremote-client.cpp
c++ -o XRemoteClient_standalone.o -c 
-I../../../dist/include/system_wrappers -include 
/root/devel/mozilla/config/gcc_hidden.h -DOSTYPE=\"Linux2.6.20-1.2925\" 
-DOSARCH=\"Linux\" -DBUILD_ID=0000000000  -I../../../dist/include/xpcom 
-I../../../dist/include/xremoteclient -I../../../dist/include 
-I../../../dist/include/nspr    -I../../../dist/sdk/include    -fPIC 
-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith 
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy 
-Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread 
-pipe  -DNDEBUG -DTRIMMED -O   -DMOZILLA_CLIENT -include 
.../../../mozilla-config.h -Wp,-MD,.deps/XRemoteClient_standalone.pp 
/root/devel/mozilla/widget/src/xremoteclient/XRemoteClient.cpp
c++ -o mozilla-xremote-client  -fno-rtti -fno-exceptions -Wall 
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth 
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic 
-fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O 
mozilla-xremote-client.o XRemoteClient_standalone.o 
-L../../../dist/bin -L../../../dist/lib -L../../../dist/lib -lplds4 
-lplc4 -lnspr4 -lpthread -ldl   -ldl -lm
XRemoteClient_standalone.o: In function 
`XRemoteClient::WaitForResponse(unsigned long, char**, int*, unsigned 
long)':
XRemoteClient.cpp:(.text+0x54): undefined reference to `XNextEvent'
XRemoteClient.cpp:(.text+0x10d): undefined reference to `XGetWindowProperty'
XRemoteClient.cpp:(.text+0x269): undefined reference to `XFree'


Which library do I need now, please?

best regards,
Antonio.
0
ISO
4/2/2007 4:53:23 PM
Antonio Ruiz Mart�nez wrote:

> c++ -o XRemoteClient_standalone.o -c 
[...]
> -L../../../dist/bin -L../../../dist/lib -L../../../dist/lib -lplds4 
> -lplc4 -lnspr4 -lpthread -ldl   -ldl -lm
> XRemoteClient_standalone.o: In function 
> `XRemoteClient::WaitForResponse(unsigned long, char**, int*, unsigned 
> long)':
> XRemoteClient.cpp:(.text+0x54): undefined reference to `XNextEvent'
> XRemoteClient.cpp:(.text+0x10d): undefined reference to `XGetWindowProperty'
> XRemoteClient.cpp:(.text+0x269): undefined reference to `XFree'
> 
> 
> Which library do I need now, please?

On my system those are in /usr/lib/libX11.so / /usr/lib/libX11.a.

Did you (force a) rerun (of) the configure step after installing the
devel package? Because to me it looks like your X libraries are in a
location that is not included in one of the -L arguments above, and so
cannot be found. (Hmm, but then, why didn't configure complain when
you did not yet have the devel library installed?!)

   Peter.
0
Peter
4/2/2007 5:27:13 PM
Peter Weilbacher escribi�:
> Antonio Ruiz Mart�nez wrote:
> 
>> c++ -o XRemoteClient_standalone.o -c 
> [...]
>> -L../../../dist/bin -L../../../dist/lib -L../../../dist/lib -lplds4 
>> -lplc4 -lnspr4 -lpthread -ldl   -ldl -lm
>> XRemoteClient_standalone.o: In function 
>> `XRemoteClient::WaitForResponse(unsigned long, char**, int*, unsigned 
>> long)':
>> XRemoteClient.cpp:(.text+0x54): undefined reference to `XNextEvent'
>> XRemoteClient.cpp:(.text+0x10d): undefined reference to `XGetWindowProperty'
>> XRemoteClient.cpp:(.text+0x269): undefined reference to `XFree'
>>
>>
>> Which library do I need now, please?
> 
> On my system those are in /usr/lib/libX11.so / /usr/lib/libX11.a.
> 
> Did you (force a) rerun (of) the configure step after installing the
> devel package? Because to me it looks like your X libraries are in a
> location that is not included in one of the -L arguments above, and so
> cannot be found. (Hmm, but then, why didn't configure complain when
> you did not yet have the devel library installed?!)
> 

Ok. Thanks a lot. After reruning it works.

Antonio.

>    Peter.
0
ISO
4/2/2007 8:16:00 PM
Reply:

Similar Artilces:

Firefox 1.5.0.9, Firefox 2.0.0.1 and Thunderbird 1.5.0.9 Security & Stability Updates
As part of Mozilla Corporation�s ongoing stability and security update process, Firefox 1.5.0.9, Firefox 2.0.0.1 and Thunderbird 1.5.0.9 are now available for Windows, Mac, and Linux for free download from getfirefox.com (http://www.getfirefox.com) & getthunderbird.com (http://www.getthunderbird.com). We strongly recommend that all Firefox users upgrade to this latest release. This update is available immediately in 41 languages including Spanish, Japanese, Arabic, Hungarian and more. Note: Firefox 1.5.0.x will be maintained with security and stability updates until Apr...

Firefox 1.5.0.9, Firefox 2.0.0.1 and Thunderbird 1.5.0.9 Security & Stability Updates
As part of Mozilla Corporation�s ongoing stability and security update process, Firefox 1.5.0.9, Firefox 2.0.0.1 and Thunderbird 1.5.0.9 are now available for Windows, Mac, and Linux for free download from getfirefox.com (http://www.getfirefox.com) & getthunderbird.com (http://www.getthunderbird.com). We strongly recommend that all Firefox users upgrade to this latest release. This update is available immediately in 41 languages including Spanish, Japanese, Arabic, Hungarian and more. Note: Firefox 1.5.0.x will be maintained with security and stability updates until Apr...

Updates after 1.5.0.7 (1.5.0.9, 2.0.0.1)can't access the web.
Name: Jay Product: Firefox Summary: Updates after 1.5.0.7 (1.5.0.9, 2.0.0.1)can't access the web. Comments: see summary Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7 ...

Version beforeMozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Name: James Kiekow Email: jamesdotkiekowathotmaildotcom Product: Firefox Summary: Version beforeMozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729) Comments: Dear Excellent Developers, I share a passion for the same in IT and I wanted to mention that I have the previous version of Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729) installed and it was extremely slow surfing the web so I upgraded and my assumption was correct it was the install I believe of th...

Firefox 1.5.0.2 / 1.5.0.3 build errors
I've been trying all day to build Firefox 1.5.0.2 and 1.5.0.3 under Windows XP Pro, using a fresh install of cygwin, and MS Visual Studio 2003 (i.e., VC7.1). I've followed all the steps on the web site, I've set my environment variables appropriately, and no matter what I do, I end up with an error in c:\mozilla\dist\include\string\nsString.h(55): error C2006: '#include' : expected a filename, found 'identifier'. When I look at the line in question, it's "# include NEW_H"--which is obviously invalid. The only reference I've fo...

Is it just me or has the Fandango site stopped working with FF (1.5.0.7, 1.5.0.9, 2.0) on eComStation 1.2 ?
Hi all, I've possibly messed up my Firefox installations, but other pages still seem to work OK. Has anyone else had problems recently with http://www.fandango.com ? The home page comes up, and then completely hangs my system, and even if I ctrl-alt-delete and kill Firefox with TOP, I just get a black screen and have to re-boot. It used to work fine. If it's just me, does anyone have any advice for what might be happening or how to go about figuring it out ? Thanks in advance, Karen Roberts On Sat, 3 Mar 2007 19:13:13 UTC, Karen Roberts <kvroberts@comcast.net>...

Firefox 1.5.0.9 and 2.0.0.1 McAfee Firewall Problem
I just upgraded to Firefox 1.5.0.9 on one winXP system and 2.0.0.1 on a 2nd system. Both result in McAfee Firewall to display the following message several times, every time firefox accesses a web page. "This application has changed from when you were originally prompted for it. This could be the result of an upgrade in the application, or it could be a malicious application trying to gain network access." Clicking "OK" allows firefox to continue, but McAfee does not "learn", and subsequent web-page accesses produces the above error again. Is ther...

Firefox 2.0.0.19 beta (build 2) and 3.0.5 beta (build 1) now available
Hello, Candidate builds of Firefox 2.0.0.19 and 3.0.5 are now available for testing. You can get the builds at: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2.0.0.18-candid .... If you have previously downloaded a beta version of either Firefox 2.0 or 3.0 or have manually set your copy to be using the "beta" release channel for updates, you can update yourself to Firefox 2.0.0.19 / 3.0.5 by selecting "Help > Check for Updates". The status for Firefox 2.0.0.19 / 3.0.5 can be found here: http://wiki.mozilla.org/Releases/Firefox_2.0.0.19 ...

superreview granted: [Bug 341583] Bump Thunderbird version to 1.5.0.5 : [Attachment 225643] 1.5.0.4 -> 1.5.0.5
David Baron <dbaron@mozilla.com> has granted superreview: Bug 341583: Bump Thunderbird version to 1.5.0.5 https://bugzilla.mozilla.org/show_bug.cgi?id=341583 Attachment 225643: 1.5.0.4 -> 1.5.0.5 https://bugzilla.mozilla.org/attachment.cgi?id=225643&action=edit ...

STD FC Classes (1.5.0) for PPB 1.5.0 (build 360)
All; I have just added to CodeXChange the following .... Foundation Classes by Chris Pollach for PPB 1.5.0 GA. This is a newer version of my FC's that exclusively matches PPB 1.5.0 GA. Please download the sample "Order Entry" application as well from CodeXchange. This application demonstrates how to build an application using these FC's. Note: Look for my article on the FC's in the March 2004 issue of PBDJ. Regards ... Chris Pollach Great White North Technical Evangelist ...

superreview granted: [Bug 341582] bump version numbers for 1.5.0.5 release : [Attachment 225641] 1.5.0.4 -> 1.5.0.5
David Baron <dbaron@mozilla.com> has granted superreview: Bug 341582: bump version numbers for 1.5.0.5 release https://bugzilla.mozilla.org/show_bug.cgi?id=341582 Attachment 225641: 1.5.0.4 -> 1.5.0.5 https://bugzilla.mozilla.org/attachment.cgi?id=225641&action=edit ...

STD FC Classes (1.5.0)
All; I have just added to CodeXChange the following .... Example "Order Entry" application that uses the STD Foundation Classes and the ASA 9.0 sample database. This is a new version that matches PPB 1.5.0 GA. Please download the separate Foundation Class library that contains the "ReadMe.txt" file with installation, configuration and change/new features list. Note: Look for my article on the FC's in the March 2004 issue of PBDJ. Regards ... Chris Pollach Great White North Technical Evangelist ...

Firefox 0.9.1 / Thunderbird 0.7.1 Russian builds and language packs
Russian versions of Firefox 0.9.1 and Thunderbird 0.7.1 are now available from the following URLs. http://mozilla.ru/unghost/firefox/0.9.1/MozillaFirefox-0.9.1-win32-installer-ruRU.exe http://mozilla.ru/unghost/firefox/0.9.1/Firefox-0.9.1-ruRU-langpack.xpi http://mozilla.ru/unghost/thunderbird/0.7.1/Thunderbird-0.7.1-win32-installer-ruRU.exe http://mozilla.ru/unghost/thunderbird/0.7.1/thunderbird-0.7.1-ruRU-langpack.xpi MLP-Staff: Please upload to ftp. Also can you change please my email address on MZ Localizaton Projects? ( http://www.mozilla.org/projects/l10n/mlp_status.html...

Firefox/Thunderbird 1.5.0.9 and Firefox 2.0.0.1 release tomorrow (Tuesday 12/19)
We are on track for releasing Firefox/Thunderbird 1.5.0.9 and Firefox 2.0.0.1 tomorrow. The plan is: 1. Push the bits out to the mirrors Monday night 2. Make mozilla.com website changes and downloads live at 10am Tuesday morning 3. Updates will go live between 4 - 5pm Tuesday evening QA will be doing their live spot checks and update testing during that time... and hopefully everyone will start getting their updates as early Christmas presents by tomorrow night. - Jay Jay Patel wrote: > We are on track for releasing Firefox/Thunderbird 1.5.0.9 and Firefox ...

Web resources about - Problem Building firefox 1.5.0.7 and 1.5.0.9 - mozilla.dev.builds

Berlaymont building - Wikipedia, the free encyclopedia
...  / 50.84361; 4.38278 Coordinates : 50°50′37″N 4°22′58″E  /  50.84361°N 4.38278°E  / 50.84361; 4.38278 The Berlaymont is an office building ...

Islamic State is building network in Jakarta, Indonesia: Sidney Jones
INDONESIAN forces are mobilising for a manhunt in steamy jungles on the far-flung island of Sulawesi to flush the country’s most-wanted man from ...

Explosive device, model of government building found during terrorism raids
Indonesian police have seized a suicide bomb and a model of an Indonesian government building that terrorists were allegedly planning to target ...

Amazon will start building third Seattle skyscraper next fall
... slowing down its rapid expansion in Seattle. There was some uncertainty about that earlier in 2015, when Amazon not only didn't start building ...

Snowman Building Total Body Workout
... hoping it happens soon! If there isn't, pin this workout for later when there is and get the family outside for a fun and active snowman building ...

Now one smartphone maker is building in ad blocking as standard
Laptop and smartphone maker Asus has partnered with Adblock Plus to introduce ad blocking as a default option on its mobile devices, Motherboard ...

The artist who turned his dead cat into a drone is now building a helicopter out of a cow
Meet Bart Jansen. He's 36. He hails from the Netherlands. He fits solar panels on roofs for a living. He has kids. And in his spare time, he ...

Pompeii gets blast from past with six newly restored buildings
Thermal bathing areas, a merchant's luxuriously decorated home, and a business are among the restored structures tourists can visit

Crows Caught on Camera Building, Storing Tools
Scientists get an unprecedented look at how New Caledonian crows fashion hooked stick tools to hunt insects.

The Sagrada Familia: The Most Beautiful Building In The World
Started in 1882, and expected to be finished in 2026 at the earliest, Gaudi’s basilica masterpiece is as gorgeous as it is awe inspiring.

Resources last updated: 12/29/2015 10:10:38 AM