please run mach bootstrap; NodeJS/NPM security updates landed

Upgrades for NodeJS from 8.11.3 to 8.17.0 and for NPM from 5.6.0 to 6.13.4 =
have merged to mozilla-central.

Everyone is encouraged to run `mach bootstrap` to upgrade the toolchain on =
their machine.

The main security fix that we=E2=80=99re concerned with is in npm, so I=E2=
=80=99ve also set 6.13.4 as the minimum acceptable npm version that mach co=
mmands will allow.  This means that running `mach eslint =E2=80=94setup` wi=
ll abort until you upgrade your npm.

https://bugzilla.mozilla.org/show_bug.cgi?id=3D1604295 has more details.

Dan
0
Dan
12/19/2019 3:23:11 PM
mozilla.dev.builds 1757 articles. 0 followers. Post Follow

0 Replies
70 Views

Similar Articles

[PageSpeed] 59

Reply: