Intent to require Python 3 to build Firefox 59 and later

--001a113ed478890e14055da945aa
Content-Type: text/plain; charset="UTF-8"

For reasons outlined at
https://bugzilla.mozilla.org/show_bug.cgi?id=1388447#c7, we would like to
make Python 3 a requirement to build Firefox sometime in the Firefox 59
development cycle. (Firefox 59 will be an ESR release.)

The requirement will likely be Python 3.5+. Although I would love to make
that 3.6 if possible so we can fully harness modern features and
performance.

I would love to hear feedback - positive or negative - from downstream
packagers and users of various operating systems and distributions about
this proposal.

Please send comments to dev-builds@lists.mozilla.org or leave them on bug
1388447.

--001a113ed478890e14055da945aa
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div>For reasons outlined at <a href=3D"https://bugzilla.m=
ozilla.org/show_bug.cgi?id=3D1388447#c7">https://bugzilla.mozilla.org/show_=
bug.cgi?id=3D1388447#c7</a>, we would like to make Python 3 a requirement t=
o build Firefox sometime in the Firefox 59 development cycle. (Firefox 59 w=
ill be an ESR release.)<br></div><div><br></div><div>The requirement will l=
ikely be Python 3.5+. Although I would love to make that 3.6 if possible so=
 we can fully harness modern features and performance.<br></div><div><br></=
div><div>I would love to hear feedback - positive or negative - from downst=
ream packagers and users of various operating systems and distributions abo=
ut this proposal.</div><div><br></div><div>Please send comments to <a href=
=3D"mailto:dev-builds@lists.mozilla.org">dev-builds@lists.mozilla.org</a> o=
r leave them on bug 1388447.<br></div></div>

--001a113ed478890e14055da945aa--
0
Gregory
11/10/2017 11:27:20 PM
mozilla.dev.builds 1719 articles. 0 followers. Post Follow

0 Replies
85 Views

Similar Articles

[PageSpeed] 34

Reply: