running mochitests in emulator

Hi,

i've been trying to run a mochitest in the emulator (ARM) without much luck.

i got the emulator running on Ubuntu 12.04 finally (i couldn't get it to start on 12.10)

i built against a local Gecko with my patch including my test applied
and the emulator also seems to start up and 'work' normally building against that. 

i installed setuputils and ran python setup.py develop in my local Gecko's
testing/marionette/client directory. 

when i try to run my mochitest from ~/src/mozilla-central/objdir-gonk-dbg/_tests/testing/mochitest using:

python runtestsb2g.py --b2g-path ~/src/B2G --xre-path ~/src/mozilla-central/objdir-dbg/dist/bin/xpcshell 
  --emulator arm --console-level INFO --test-path content/base/test_CSP_inlinestyle.html 

i see :

marionette.errors.JavascriptException TypeError: currentAppFrame(...) is null at app://system.gaiamobile.org/js/wrapper.js line 120

and then the python script exits, killing the emulator. 

any ideas what might be going wrong here ? any help greatly appreciated.

thanks,
ian
0
Ian
4/2/2013 3:08:47 PM
mozilla.dev.b2g 4036 articles. 0 followers. Post Follow

1 Replies
286 Views

Similar Articles

[PageSpeed] 39

It looks like you're hitting the error that bz ran into in 
https://bugzilla.mozilla.org/show_bug.cgi?id=848133 which got fixed 
around March 6th. When did you build? Did you run ./repo sync since 
then? Is it possible you built a b2g18 version of gaia with a m-c 
version of gecko?

Andrew

On 04/02/2013 11:08 AM, Ian Melven wrote:
>
> Hi,
>
> i've been trying to run a mochitest in the emulator (ARM) without much luck.
>
> i got the emulator running on Ubuntu 12.04 finally (i couldn't get it to start on 12.10)
>
> i built against a local Gecko with my patch including my test applied
> and the emulator also seems to start up and 'work' normally building against that.
>
> i installed setuputils and ran python setup.py develop in my local Gecko's
> testing/marionette/client directory.
>
> when i try to run my mochitest from ~/src/mozilla-central/objdir-gonk-dbg/_tests/testing/mochitest using:
>
> python runtestsb2g.py --b2g-path ~/src/B2G --xre-path ~/src/mozilla-central/objdir-dbg/dist/bin/xpcshell
>    --emulator arm --console-level INFO --test-path content/base/test_CSP_inlinestyle.html
>
> i see :
>
> marionette.errors.JavascriptException TypeError: currentAppFrame(...) is null at app://system.gaiamobile.org/js/wrapper.js line 120
>
> and then the python script exits, killing the emulator.
>
> any ideas what might be going wrong here ? any help greatly appreciated.
>
> thanks,
> ian
>


0
Andrew
4/2/2013 3:38:20 PM
Reply: