Sending SOAP Attachments has stopped working

I have a mature SOAP app compiled in Delphi XE5. CGI server and Win32 client running under Windows 7. This app for years has (among other things) sent files to users as a TSoapAttachment parameter in a SOAP request (e.g. PDF files for viewing). Suddenly a few days ago this ceased to work, but only on my local machine. Production environment continues to work fine, but I always get a 3 minute timeout with error "The connection with the server was reset". (not a web service timeout) Nothing has changed in t
he code that I can see which could relate to this. I did apply Windows updates recently but did not test this function until a few days after. No changes to IIS set up or anything else on my side. Server log files show all works fine but client always get the above. All other SOAP functions work fine. The target file does get created in the right place and looks fine.

I examined the XML (which I don't really know much about) but seems to have a valid reference to the attached file, as <_exFile href="cid:E11165AF-616D-4E5E-976F-37030E2DE014"/>

Any suggestions much appreciated. 

- Doug
0
Doug
7/31/2015 9:27:41 PM
embarcadero.delphi.webservices 976 articles. 0 followers. Follow

0 Replies
781 Views

Similar Articles

[PageSpeed] 14

Reply:

Similar Artilces:

Counter display WebServices stops working when mails are getting send !
Hi, Task : I am developing a web application in ASP.NET 2005 (C#) for sending mails one by one (large number(mass mailing)).Wish to have a counter on page to show a counter which displays number of mails successfully send which will increment on each successful mail send.  Approach Implemented by me : Used a page level variable on the code behind of mailer page which got incremented after each successful mail send. Also created a local Webservice (inside the current project) which takes this page level variable along with current time and exposes to out side world. On the aspx page of ...

Sending Attachments by "Send To" Not Working
I used to be able to right click on a file and select "send to" and a Thunderbird window would open up allowing me to address the message. It seems that since I installed TB 3.0b2 this no longer happens. Is this a setting or a Windows XP problem? Thanks in advance. Richard The date and time was Tuesday, May 05, 2009 3:25:15 PM, and on a whim, Clunker pounded out on the keyboard: > I used to be able to right click on a file and select "send to" and a > Thunderbird window would open up allowing me to address the message. > > It seems that sin...

Agent stops working, Reboot and it works, Then it stops again...
--____DEGYPLFFFEADCDXTFEXF____ Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: base64 Content-Disposition: inline; modification-date="Thu, 14 Jan 2009 15:26:30 +0100" SGkuDQoNCkkgaGF2ZSBzb21lIHByb2JsZW0gd2l0aCB0aGUgYWdlbnQgKCAxMC4xLjIuYSkgd2hl biBpIGxvZyBpbiB0byB0aGUgZGV2aWNlICggb25seSBoYXZlIG9uZSwgZm9yIHRlc3RpbmcgKSB0 aGUgQWdlbnQgbG9hZHMgdGhlIFBvbGljeXMgYW5kIHRoZSBCdW5kbGVzLi4uDQpCdXQgdGhlbiBh ZnRlciBzb21lIG1pbnV0ZXMsIGl0IHN0b3BzIHdvcmtpbmcsIGFuZCB0aGUgQnVuZGxlcyBEaXNz YXBlcmVzIGZyb20gdGhlIGRldmljZS4gSWYgaSBSZWJvb3QgdGhlIGRldmljZSBpdCBjb21lcyBi YWNr...

Send To stopped working
The following scenario: Windows 7 x64, Office 2013, Thunderbird 38.5.1 Right click on any file Send To - Mail Recipient does not work. No message is issued. Even "Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client." Is not shown. Thunderbird is default mail client. Sometimes I use Outlook, but this configuration worked for several years with no side effects. What changed? Well, now I'm not sure. Some MS security updates were applied, I also up...

Send To stopped working
The following scenario: Windows 7 x64, Office 2013, Thunderbird 38.5.1 Right click on any file Send To - Mail Recipient does not work. No message is issued. Even "Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client." Is not shown. Thunderbird is default mail client. Sometimes I use Outlook, but this configuration worked for several years with no side effects. What changed? Well, now I'm not sure. Some MS security updates were applied, I also up...

How do i add multiple attachments to my email webservice so that users can consume to send multiple attachments using C#
 Im using the System.Net.mail namespace and am creating a webservice to send emails.i would like to add a webmethod where a collection of attachments could be added to the email. There are many examples with single attachement.Please suggest with code. Below is my class for sending the email which i call in the webservice. Hello , You could tru something like :MailAddress from = new MailAddress("some@domain.com"); MailAddress to = new MailAddress("other@domain.com");MailMessage mail = new MailMessage(from,to);    mail.Attachments.Add(new Attachme...

superreview granted: [Bug 320650] 'Send' does not work after Ctrl+E : [Attachment 206206] Patch (untested, but should work)
David Bienvenu <bienvenu@nventure.com> has granted Frank Wein <bugzilla@mcsmurf.de>'s request for superreview: Bug 320650: 'Send' does not work after Ctrl+E https://bugzilla.mozilla.org/show_bug.cgi?id=320650 Attachment 206206: Patch (untested, but should work) https://bugzilla.mozilla.org/attachment.cgi?id=206206&action=edit ...

superreview requested: [Bug 320650] 'Send' does not work after Ctrl+E : [Attachment 206206] Patch (untested, but should work)
Frank Wein <bugzilla@mcsmurf.de> has asked David Bienvenu <bienvenu@nventure.com> for superreview: Bug 320650: 'Send' does not work after Ctrl+E https://bugzilla.mozilla.org/show_bug.cgi?id=320650 Attachment 206206: Patch (untested, but should work) https://bugzilla.mozilla.org/attachment.cgi?id=206206&action=edit ------- Additional Comments from Frank Wein <bugzilla@mcsmurf.de> Easy regression fix ...

SOAP against .net webservice not working?
hallo, has anybody successfully called a MS .net(2) webservice using SOAP in the xforms extension? I have both the ws and the xform running on localhost so I can debug booth. I got to a point where my submission actually reaches the webservice method. but looking with a ebugger in the webservice I se that the actual parameter, <name>ansorg</name>, is missing. And I wonder why? In the xform I have <xforms:instance id="soapmessage"> <data xmlns=""> <soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-ins...

My WebService after some hour stops working
Hi,I have a strange problem.This is the situation. I have built a web radio using the media encoder. Everything is managed with a .net application.The user interface is a flash movie, that displays the name of the band and the name of the song on the air at the moment.The flash movie every ten second calls a web service to get the new data if they updated.Since there could be hundreds of listeners, I use some caching not to execute the same query many times every second.Which is the problem? It works wonderfully, but after some hour the web service stops working and my display too.If I ...

Delphi XE3 stopped working
I have been using Delphi XE3 since it was released and I have never had a problem. For the past two weeks I have had Delphi XE3 stop working while I was making changes. I get the following error message: Embarcadero RAD Studio for Windows has stopped working. I have reinstalled Delphi XE3 which did not resolve the problem. What is the problem and what is the solution? Have you tried the manual uninstallation instructions? http://support.embarcadero.com/es/article/43023 I would also try to launch the IDE with Windows under Diagnostic mode (using msconfig) so that you can check if a 3rd party product is interfering > {quote:title=Mervin Norton wrote:}{quote} > I have been using Delphi XE3 since it was released and I have never had a problem. For the past two weeks I have had Delphi XE3 stop working while I was making changes. I get the following error message: > Embarcadero RAD Studio for Windows has stopped working. > I have reinstalled Delphi XE3 which did not resolve the problem. > What is the problem and what is the solution? -- Borja Serrano Embarcadero Technical Support Engineer Edited by: Borja Serrano on Jan 27, 2015 6:45 AM ...

sending emails with attachement delphi 2009
Hi, I have a problem, I'm using delphi 2009, I made a small application that uses TIdsmtp to send mails, for attachments I'm using TIDAttachmentFile class, like with TIdAttachmentFile.Create(IdMessage1, 'c:\image1.jpg') do begin ContentType := 'image/jpeg'; FileName := 'image1.jpg'; end; SMPT.send(IdMessage1); If I dont use attachment it works fine, but with attachemtns I'm getting email with some dummy name for attachemnt like ATI1284765.dat (if I change file extension to jpg it's ok then, it's that pictu...

SOAP webservice in Delphi. Best option?
Hello all, I need to implement a SOAP web service in Delphi (it will be an ISAPI) that will be under heavy load (=many concurrent calls). I'd like to know which would be the best ISAPI/SOAP framework available. My web service must do some very "expensive" initialization (load some huge XML files that cannot be shared between threads) and it would be nice if I could re-use those resources again in the next call, so it would be very nice if the framework could do thread pooling. Also, is the Delphi soap server wizard still "current", or is it deprecated? Kin...

Send to from Office 2007 stopped working
Hello, When a user with Office 2007 tried to send from the "file menu" he got an pop-up dialog box with the message "Mail error!". Any ideas? /Spencer Uninstall the GroupWise client, then uninstall the Windows Messaging system and then reinstall the client, which will reinstall the messaging system and most probably fix the problem. Shivaji Samanta Wytheville Community College "Spencer" <Do.Not@email.me> wrote in message news:HqgOk.5623$Fg1.3069@kovat.provo.novell.com... > Hello, > > When a user with Office 2007 tried to s...

Delphi send null string to webservice
Hi, I'm using my WebService from Delphi application, but, in my webservice, the parameter's value always get null [WebMethod]int ExecSQL(string ASQL){  // here, ASQL is null....hoooowww????  //do my query  return(AffectedRows);} I've been tried to use [SoapRpcMethod] but, with him, I cannot can load from Delphi my wsdl...I'm using RemObjects 3.0.3 Version thanks...

SOAP
Hi all, I would like to send one soap request, this request conatin a body xml and attachments file. I send only xml.. str:='<?xml version="1.0" encoding="UTF-8"?>'+ '<Envelope xmlns="http://schemas.xmlsoap.org/soap/envelope/">'+ ' <Header>'+ '</Header>'+ ' <Body>'+ '<Kerdes xmlns="http://www.popi.com/2004">'+ ' <KerdesFejlec>'+ ' <UzenetIdopont>2009-11-19T17:58:26.571Z<...

Stop Clients Sending Certain Attachments
I think this is the right place to post but here goes Im in a school enviroment and we have an issue were students are sending games to one another in zip form, rar form, exe form, is there a way to stop certain attachments? other wise could you please point me in the right direction to prehaps combat this issue. cheers in advance Troy Troy, you'll need a third party app. GWAVA (www.gwava.com) can do this, AFAIK, at least between POs. Not sure if it can handle mail inside a PO. Uwe -- Novell Support Connection Volunteer SysOp Please don't send me suppor...

Sending email attachments through Outlook from Delphi programmatically
Is there some option that has to be set to allow this? I'm using ICS and it works fine for the email, but the attachment doesn't arrive. If I send to Outlook Express client, the attachment arrives. I'm sending through the same Exchange server to both clients. TIA -- -----Jon----- Am 29.01.2010 20:46, schrieb Jon Springs: > Is there some option that has to be set to allow this? > > > I'm using ICS and it works fine for the email, but the attachment doesn't > arrive. If I send to Outlook Express client, the attachment arrives. >...

- How do I tell Thunderbird to stop attaching images when sending?
Sometimes, HTML emails have code pointing to images located on public servers. Most email clients will attach images to the email rather than continue the image to be pulled from the server. If you wanted the client to stop doing this, and leave the urls as urls : In Outlook, you would go to Tools > Options > Mail Format > Internet Format and uncheck "When an HTML message contains pictures located on the Internet, send a copy of the pictures instead of the reference to their location" In Outlook Express, you'd go to Tools > Options > Send > Mail...

Sending email w/ attachments with Delphi 2?
Does anyone know if there is a version of Indy or any other component that would enable an application written with Delphi 2 to send email with attachments? The references I've come up with just report problems and limitations with it so I'm wondering if anyone knows of something more likely to work. I'm afraid you have to look here: http://gohistoric.com/places/318695 Maybe you take a higher Delphi version and create a DLL with the functionality you want. Use the DLL in your Delphi 2 application. > {quote:title=Philip Caracena wrote:}{quote} > Does anyone know if t...

Rule working once and then it stops working...
I have a user with Windows XP and GroupWise 6.0 We tried to create a simple rule that replies to any message received stating the user is on vacation. The rule may work once and then it stops working. When I look at the rule and try to "run" it, the message says "Rule Execution Failed." Any idea what could be wrong? That's what it is supposed to, work once and then stop. If you untick/retick the rule, then it should get reset and work again - once per incoming address. Cheers Dave -- Dave Parkes [NSCS] Occasionally resident at http://s...

help for SOAP client and attachment with delphi 7
Hi, I'm very newbie with SOAP and I hope you can help me for a probably very easy question that I cannot resolve. I have to send an attachment (JPG, PDF or PNG) to a SOAP server (that I cannot modify because it's created from another organization). I only have istructions for an XML like this: <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:data="http://www.xxxxxx.it/Data"> <soapenv:Header /> <soapenv:Body> <data:uploadImage> <header> <data:username></data:username> <data:pas...

How to recover a SOAP Header in a Delphi Win32 WebService?
I'm trying to implement authentication across of SOAP header in my webservice. The WebService is developed in Delphi XE (Win32) and is accessed by application an .NET (C #). I could not find documentation and working examples of a webservice with this type of authentication.The other option would be to create parameters in all functions of the webservice passing the username and password, but would not want to do this. Declared in the interface (INTF) a class of type "TSoapHeader" with the properties you need in this case, username and password! {code} THeader = class(...

Delphi SOAP (WebServices) demos are back on CodeCentral!
Anybody doing WebServices/SOAP programming on delphi who remembers the Delphi 2007 era demos, might be happy to know that I've fixed them up and posted them on CodeCentral. Since that code belongs to Embarcadero, I'd like to thank Embarcadero for giving permission to me to post this code on CodeCentral: http://cc.embarcadero.com/item/28789 Anybody who has bug reports for this code can email me at warren dot postma at gmail dot com. It is possible that I might set up a version control system (bitbucket) if that's needed, and if Embarcadero has no problem with that. I w...

Web resources about - Sending SOAP Attachments has stopped working - embarcadero.delphi.webservices

Attachment in adults - Wikipedia, the free encyclopedia
Attachment in adults deals with the theory of attachment in adult romantic relationships. Attachment theory was extended to adult romantic relationships ...

Facebook Allowing Page Admins To ‘Refresh Share Attachment?’
Facebook appears to have given page administrators the option of refreshing links that they share in posts on their pages . continued... New ...

Chronik-Fotos - Mama Bean - Unconditional Attachment - Facebook
Graphic design students at the University of North Texas asked this inspiring mama, Monica, to be the face of their ad campaign. The campaign ...

New Facebook Messages Only Provides an Online Attachment Viewing Feature for Microsoft Docs
In another move highlighting Facebook’s strategic relationship with investor Microsoft, the company has given the established office software ...

Documents.me - Documents from remote PC, MAC, Gmail attachments, Google Drive & Dropbox Docsync for iPad ...
Get Documents.me - Documents from remote PC, MAC, Gmail attachments, Google Drive & Dropbox Docsync on the App Store. See screenshots and ratings, ...

A bullet attachment that could save lives? - YouTube
It looks like a toy attachment for a gun, but this new device is intended to give suspects a chance to live if shot. CNN's Sara Sidner reports. ...

Invention of the Day: New ‘Alternative’ Gun Attachment May Prevent Shooting Deaths
The Ferguson Police Department is testing out a new device which they think might help prevent unnecessary shooting deaths. “The Alternative” ...

100th anniversary of Anzac landings brings home strong attachments
The commemoration of the 100th anniversary of the Anzac landings draws our attention to events that so many of us have a strong attachment to. ...

iPhones - Is Our Attachment To Smartphones A Bad Thing?
They cater to our basic human hunger for connection, so is our attachment to mobiles such a bad thing?

Apple not encrypting email attachments in iOS 7, security researcher claims
Apple's Mail app in iOS 7 is failing to encrypt email attachments, leaving user data vulnerable to hackers, a security researcher claims.

Resources last updated: 3/30/2016 7:18:27 PM