advStringGrid 2.6 need help!

Hello,

I am using an old (old) version of the TMS AdvStringGrid, which has one 
feature I can't sort out. Its a component I don't use very often so I'm 
never sure I'm using it correctly.

I'm using an edComboList control in each of 2 columns with a different 
selection list for each. 

I can't figure out how to get the completion of fieldnames to work 
properly. For example, if I have 3 items in the list 'DLat,DLon,Online' and 
I want to type in DLon, I can't. As soon as I hit the O it switches to 
online, no matter how fast anyone types. It means that you always have to 
use a mouse (or the up/down arrows) to select a field, which sucks.

I'm hoping that someone can tell me what combination of settings will do it 
for me, or confirm that it doesn't work in that version and an upgrade 
would help matters. I'm including all of the settings from the dfm below.

Cheers,

Marc Pelletier
Goldak Airborne Surveys
0
Marc
9/26/2008 3:40:28 PM
embarcadero.delphi.tools 5366 articles. 1 followers. Follow

3 Replies
414 Views

Similar Articles

[PageSpeed] 0

Marc Pelletier wrote:
> Hello,
>
> I am using an old (old) version of the TMS AdvStringGrid, which has
> one feature I can't sort out. Its a component I don't use very often
> so I'm never sure I'm using it correctly.
>
> I'm using an edComboList control in each of 2 columns with a 
> different
> selection list for each.
>
> I can't figure out how to get the completion of fieldnames to work
> properly. For example, if I have 3 items in the list
> 'DLat,DLon,Online' and I want to type in DLon, I can't. As soon as I
> hit the O it switches to online, no matter how fast anyone types. It
> means that you always have to use a mouse (or the up/down arrows) to
> select a field, which sucks.
>

Marc,

I don't know if this helps you, I don't know about a edComboList 
component.
But refering to a TComboBox, check if your component has a Style 
property.
If it is set to csDropDownList try to change it to csDropDown.

HTH
Tom
0
Tom
9/26/2008 4:19:39 PM
Tom Brunberg <nospam@to.me> wrote in news:21606@forums.codegear.com:

> If it is set to csDropDownList try to change it to csDropDown.
> 

Tom, 

Thanks, but the default value of that property is already set to 
csDropDown. It has occurred to me that if may just be easier to inject a 
regular combobox in there, but I'm not sure how to do that either!

cheers

Marc
0
Marc
9/26/2008 5:07:57 PM
Marc Pelletier wrote:
> Tom Brunberg <nospam@to.me> wrote in news:21606@forums.codegear.com:
>> If it is set to csDropDownList try to change it to csDropDown.
>
> Thanks, but the default value of that property is already set to
> csDropDown.

Marc,

Sorry to hear, I was quite sure this would be the reason. Guess there 
must be some other settings then, if it is supposed to work with 
autocompletion. As I said, I'm not familiar with AdvStringGrid and the 
edComboList, so I can not help you further in this case, Sorry for 
that too.

> It has occurred to me that if may just be easier to
> inject a regular combobox in there, but I'm not sure how to do that
> either!
>

The following links may give you some hints:
http://www.delphi32.com/info_facts/faq/faq_552.asp
http://www.delphi3000.com/articles/article_3324.asp
http://www.swissdelphicenter.ch/en/showcode.php?id=406

HTH
Tom
0
Tom
9/26/2008 6:44:34 PM
Reply:

Similar Artilces:

Need help updating 6.2 Agents to 6.3 agents.
We've run into a bit of a pickle when trying to get our Patch Management server up and running and deployed properly to all workstations. In our attempt to upgrade from version 6.2 to 6.2 we wound up having to blow away the entire PM install because we had multiple applications running on the same machine and 6.3 restriction on what can/can not be on the server caused us pain. We created a new machine where we installed PM 6.3 on it. We currently have 6.2 agents on the machines that point to the old server. I attempted to update the registry for the agent to tell it ...

Help needed with Identity Manager 3 plugins for iManager 2.5/2.6
This is a clean install of iManager on a clean install of OES Linux, SP2. I've tried this with both iManager 2.5 and 2.6, and have both versions of iManager patched to the latest maintenance level. None of the DirXML/Identity Manager 3 tasks are available. The troubleshooting page shows a "The version of the DirXMLCommon plug-in that is installed is not compatible with the..." message for each plugin. DirXMLCommon is version 10.0.20060302, and all of the other DirXML plugins are version 10.0.20051122. However, I've also tried it with the 10.0.20051122 versio...

Need help on Bugzilla version 2.6
HI Team We have one of our users using Bugzilla version 2.6 which = was installed around 14 years back and untouched till date. Now they want t= o either migrate it to JIRA or upgrade to a higher version of Bugzilla may = be 4.4.6. The challenge is that the Bugzilla installation directory structu= re of version 2.6 Bugzilla instance looks totally different from that of a = latest version. Cannot locate major configuration files like localconfig, i= nstall-config etc. Also on googling I cannot find a downloadable version of= Bugzilla 2.6 or any kind of documentation ...

Need help with bmp files in 2 apps with common pbls need help displaying in both apps
I have 2 PB applications. App1 and App2. They have pbls that are common to both. These pbls contain objects with bitmaps on them. App1 is in the App1 directory and App2 is in the App2 directory. EACH DIRECTORY HAS THE SAME PBLS IN IT. The shared objects were developed in App1. When specifying the bitmaps there, it seems only the name was needed and not the full path. However when App2 uses the same window as App1, the bitmaps do not appear! What can I do to get the objects that are common to both apps to display a bitmap in either app? Thanks Jerry OBrien Ra...

Need help/tools to convert Math formula in Delphi
I would appreciate any help, resource or tools/components to be able to convert the following Math formulas in Delphi. Delta E (CIE 1976): http://www.brucelindbloom.com/index.html?Eqn_DeltaE_CIE76.html Delta E (CIE 1994): http://www.brucelindbloom.com/index.html?Eqn_DeltaE_CIE94.html Delta E (CIE 2000): http://www.brucelindbloom.com/index.html?Eqn_DeltaE_CIE2000.html Delta E (CMC): http://www.brucelindbloom.com/index.html?Eqn_DeltaE_CMC.html Thank you in advance. Andy ...

help needed installing bugzilla 2.16.6
Hello All, I followed the step-by-step installation guide to install bugzilla 2.16.6 on my server (runs apache 2.0). Everything seemed to install and I am able to see the bugzilla main page and step through the query and enter phases very nicely. However, the ant.jpg file shows up as a broken link and when I click on the 'help' link I get the server 500 error. The file ant.jpg does exist in my /bugzilla directory on unix. Do I need to add something about images to my apache server rules? Any idea why help gives me the 500 error message? thanks in advance, Chee Charl...

Need help in using ocx in PB 6.5 #2
Hi all, I'm new in using OCX in PB, so I need someone to help me. I need to do an interface to allow my PB app to call into a VB app. I created an OCX using VB. I've added a OLE object (with my OCX) to my PB app. How do I call the function inside the OCX, can someone help me? Thanks. ...

Need to move a file from Win98 to Redhat 6.2 partition-help
I have just installed the latest build of Mozilla 1.1 on both my WIN98SE Partition and My Linux Partition (Gentus 3.0, modified version of Redhat 6.2). I need to copy my bookmarks.html from my Mozilla WIN98SE location to my Mozilla Linux location. I can not remember how to move files across different OS, can someone give me some clues and maybe show me a man page or such with the info and examples of commands to use from terminal window, TIA, Kruppt. Kruppt <Krupptus@myrealbox.com> wrote in news:akj1o5$1oc7$1@news.grc.com: > I have just installed the latest build of...

Need help installing Digital Airlines demo (6.5) #2
Oops, hit the enter key instead of the tab key. Sorry about that. Anyway, I'm trying to install the Digital Airlines demo (Netware 6.5) in a Microsoft Virtual PC environment. I get stuck trying to load the network card. The computer has an Intel Pro/100+ adapter, which is onfigured in the Virtual PC as Adapter 1. It's installed in PCI slot 3. When hdetect says it can't find a network card, I manually load the Intel 8255x PCI Adapter driver, which lists Intel Pro/100+ as a supported adapter, and set it to slot 3 but it won't load. It also says that 10007 and 100...

Need help to findout certificate Server version in edir 8.6.2
Hi Everybody I need help to find out the certificate server version in eDir 8.6.2 for Linux. It's because my client need to export the public key and certificate, but keep got hit with problem. I noticed that for certifate server version under 2.2 will have problem. I have no clue on how to lookup the version in eDir for Linux. Thanks in advance. Best Regards Tommy Hi Tommy, I'm not sure about 862, but I think "rpm -qa | grep pki" should give back the version of PKI. Cheers, Akos tommysun@asiantat.com wrote: > Hi Everybody > > I ...

Need help repro'ing bug 509560 for Firefox 3.6! #2
We need help reproducing a bug from anyone with a few moments. The bug is 509560. It involves the crash reporter having a problem sending the crash report to the server. We need to find additional flash crash test cases and see if the crashes get reported. Looks like we can also use crashme on certain flash pages and maybe see the problem. This is a major concern related to the 3.6 release. Any hep would be greatly appreciated! ...

Delphi 2005 help system needs help
I recently installed Delphi 2005 for the first time (OK, so I'm a tad bit behind the times). When I drop a component on a VCL form (like TEdit), then highlight that component and press F1, up pops a quasi-help-browser window with a URL: ms-help://borland.bds3/bds3start/html/intro.htm and the message "Cannot find server". What happened to the good old days old HLP and CHM files, which display relavent help for the active component item? So what does a person have to do to get good help these days in Delphi 2005? Philip >So what does a person have to do to ge...

Cannot install 2.0.0.6. Using 1.5 Tried Everything, need help
I have a Vista machine. I've been using Thunderbird 1.5.0.12 for a long time, but have never been able to install 2.0.0.6. Keep getting errors when it tries to install. I've tried exiting my Logitech Web Cam and Windows Messenger which I read can cause problems. Also temporarily suspended Norton 360. Nothing nelps, any help would be appreciated. jtodd@iquest.net John Todd wrote: > I have a Vista machine. I've been using Thunderbird 1.5.0.12 for a long > time, but have never been able to install 2.0.0.6. Keep getting errors > when it tries to insta...

Help Help Help #2
I have created two transaction objects, one source and one destination, I have also created a pipeline object between the source and destination databases. Some of the fields in the source database contain blank spaces for values; after a successful pipeline the destination database fields that should contain spaces are now NULL. My PowerBuilder version is 7.0.3, my Sybase version is 6.0.4. Is this a simple setting change? Thank you in advance... I'm not sure if this is related or not, but, I've discovered what I think is a major bug in PB in that when a dw retrieves ...