Printing Problems - RaveReports 5.0.1 - Delphi 7.0 Build 4.453 [Edit]

I've created a template in rave reports and am able to print it, however, im unable to select which printer i want to print to

I've tried forcing the default printer to change at runtime

I've tried the printdialog component that comes with dephi, but no matter how long i struggle, i dont get it right,

it simply keeps printing to whichever printer was set to default at the time the program started.

I've tried lookin at winspool and a few of the sdk commands, but there really isn't much help out there.

If anyone know's about this problem please help me out..

Currently its set to 

procedure Tform1.rvSystem1BeforePrint(Sender: TObject);
begin
  printdialog1.execute;
end;

Edited by: RegalTech RegalTech on Mar 30, 2009 11:39 PM
0
RegalTech
3/31/2009 6:40:11 AM
embarcadero.delphi.reporting 487 articles. 0 followers. Follow

4 Replies
1384 Views

Similar Articles

[PageSpeed] 40

> I've created a template in rave reports and am able to print it, however, im 
> unable to select which printer i want to print to


You did not give your full version for Rave Reports. If you have not updated 
to Rave 5.0.8, then you need to do that. You can get that update from CodeGear 
at: http://www.codegear.com/downloads/regusers/delphi This update will fix 
several items. Several files (including documentation) were left out of the 
initial release.

For your information there is a RaveReports group at 
embarcadero.public.delphi.thirdpartytools.ravereports .
-- 
Tech Support
Nevrona Designs
support@nevrona.com
0
Support
3/31/2009 1:22:45 AM
I've tried downloading the specified update, unfortunately im not authorized?
Dont understand why a free update is only available to specific users.

I've tried googling it, but to no avail, not even your own page hosts updates.
0
RegalTech
3/31/2009 6:37:23 AM
It's an update from CodeGear not from Nevrona ... 

you must have an DN-account because you've registered Delphi 7 a long time 
ago. 
there is no other location of the update (http://rave-notes.blogspot.com/2007/10/delphi-7-and-rave-5-be-patch.html)

:-) Thomas Pfister

________________________________________
This mail was sent using 100% recycled electrons

> I've tried downloading the specified update, unfortunately im not
> authorized? Dont understand why a free update is only available to
> specific users.
> 
> I've tried googling it, but to no avail, not even your own page hosts
> updates.
>
0
Thomas
4/2/2009 6:45:48 PM
Hi Thomas,

I see you have some link with Nevrona? If so, can you please find out 
when (if?) Rave 8 will be released. I have posted messages in their NG 
and sent an email, but no replies. As a BEX user, can't move to D2009 
until I get it.

Regards...Andrew
0
Andrew
4/3/2009 8:45:00 AM
Reply:

Similar Artilces:

Problem Building firefox 1.5.0.7 and 1.5.0.9
Hello! I'm trying to compile both firefox 1.5.0.7 and 1.5.0.9 in a Fedora Core 6 to build a new extension. However, I'm getting the problem that I attach bellow.... My mozconfig file is: mk_add_options MOZ_CO_PROJECT=browser # add other common options here, such as making a static release build and # disabling tests ac_add_options --enable-optimize --disable-debug ac_add_options --disable-tests # Build Firefox mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-static ac_add_options --enable-application=browser and I compile using: #!/bin/bash export MOZCONF...

1.5.0.0.3 vs 1.5.0.0.4
I have had numerous difficulties with FF 1.5.0.0.4, in particular, some sites often just hang when I click on links. A particularly bad site is Dell http://www.dell.com/, which - when I try to configure a computer - gets all kinds of "waiting for dell" status bar messages. I tried it with a clean profile, to no avail. It works flawlessly with IE. I downloaded fresh copies of 1.5.0.3 and 1.5.0.4 with the intent of uninstalling the latter and then trying the former. *The uninstall process hung*. So I installed 1.5.0.3 on top of 1.5.0.4. The Dell site now works fl...

superreview granted: [Bug 341583] Bump Thunderbird version to 1.5.0.5 : [Attachment 225643] 1.5.0.4 -> 1.5.0.5
David Baron <dbaron@mozilla.com> has granted superreview: Bug 341583: Bump Thunderbird version to 1.5.0.5 https://bugzilla.mozilla.org/show_bug.cgi?id=341583 Attachment 225643: 1.5.0.4 -> 1.5.0.5 https://bugzilla.mozilla.org/attachment.cgi?id=225643&action=edit ...

Updates after 1.5.0.7 (1.5.0.9, 2.0.0.1)can't access the web.
Name: Jay Product: Firefox Summary: Updates after 1.5.0.7 (1.5.0.9, 2.0.0.1)can't access the web. Comments: see summary Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7 ...

superreview granted: [Bug 341582] bump version numbers for 1.5.0.5 release : [Attachment 225641] 1.5.0.4 -> 1.5.0.5
David Baron <dbaron@mozilla.com> has granted superreview: Bug 341582: bump version numbers for 1.5.0.5 release https://bugzilla.mozilla.org/show_bug.cgi?id=341582 Attachment 225641: 1.5.0.4 -> 1.5.0.5 https://bugzilla.mozilla.org/attachment.cgi?id=225641&action=edit ...

stalled or no download: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3
I experience stalled or no download of all (not only specific web-sites) using firefox while another browser "Konquereor" is working normally. Firefox is looking up.. connecting... transfering and then stalled sometimes I get the message "I cant find the server", suprisingly because the status shows transfering, or a login window for the router shows up what has not been seen with the other web browser. A second Linux PC in the network is working as supposed, the router is wide open... connection settings are alredy checked. May be anybody has a hint? Ber...

stalled transfer Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3
I experience stalled or no download of all (not only specific web-sites) using firefox while another browser "Konquereor" is working normally. Firefox is looking up.. connecting... transferring and then stalled sometimes I get the message "I cant find the server", surprisingly because the status shows transferring, or a login window for the router shows up what has not been seen with the other web browser. A second Linux PC in the network is working as supposed, the router is wide open... connection settings are already checked. May be anybody has a hint? ...

Kaspersky 4.0 (build 7.0) (a.k.a. 4.0.5.15), posted 6 13 02
ftp.kaspersky.com/products/release/4.0/english/homeuser/kavpersonalpro Here is what they indicated fixed; though they changed virtually every executable/dll/ocx in the new dist. I don't yet know if it is faster, but the last noted change to the monitor is very interesting. KasperskyT Anti-Virus Scanner Version 4.0.5.15 Released 31.05.2002 Fixes : 1.. The problem with ZIP-files scanning launched from the command line under WinXP. In the previous build, when launching Kaspersky AV Scanner to scan .ZIP files, via the command line or contextual menu in Microsoft Wi...

Testday - Friday, May18th: Firefox 1.5.0.12
Hi Mozilla Community Testers!, Please join the Mozilla QA community for Testday on Friday, May 18th, 2007! This week, we will be looking at the Firefox 1.5.0.12 and 2.0.0.4 and Thunderbird 1.5.0.12 Release Candidates The event will run Friday, May 18th, 2007, from 7am - 5pm PDT Please visit http://wiki.mozilla.org/Mozilla_QA_Community:Firefox_2004rc3/15012_Community_Test_Day for all the info regarding the event. Jump into the #testday channel on irc.mozilla.org on Friday to participate. We hope to see you there! Thanks. Carsten Mozilla QA ...

Oracle 8.0/Oracle 7.1.4 & PB 5.0 connection problem
I am using native database interfaces 7.2 to connect with the Oracle database 7.1.4 (UNIX) from PB 5.0(windows 95), it works well. But after I installled Personal Oracle8 on my desktop, everytime it goes to the local oracle 8 database(oracle8 database autobatically starts ) with the same profile, not the remote 7.1.4. I tried to use Oracle Home Selector to switch the oracle home to 7.1.4, nothing happened, Oracle home stayed at Oracle 8. Is there any way that can let me specify the database? Thanks What are you using as your servername string? Is your tnsnames.ora file still corr...

Problem with migration of application from version 5.0.0.1 to version 7.0
Hello, I am trying to migrate an application from version 5.0.0.1 to version 7.0. Although my application is succesfully regenerated and it runs fine on the PB 7.0 application environment when I try to compile the application I get illegal operation fault: PB70 caused an invalid page fault in module <unknown> at 0000:00373537. Registers: EAX=00000002 CS=015f EIP=00373537 EFLGS=00010216 EBX=00000000 SS=0167 ESP=0068f028 EBP=00000001 ECX=cd75ec00 DS=0167 ESI=01da5690 FS=29cf EDX=bffc9490 ES=0167 EDI=01dac788 GS=0000 Bytes at CS:EIP: Any ideas? I have also noticed that...

SM2.5 crash
I got those traps when trying to 'Edit as new'(?) a previous sent mail and wanted to change the language via right click in subject line. Was reproduce able a few times but now it works. Maybe I tried to fast switching spell checker? ------------------------------------------------------------ 12-06-2011 21:37:47 SYS3171 PID 006e TID 0001 Slot 0077 P:\SEAMONKEY2\SEA!LRQ.EXE c0000005 14dd6ac8 P1=00000002 P2=0002fffc P3=XXXXXXXX P4=XXXXXXXX EAX=00030064 EBX=00030180 ECX=00030180 EDX=27a22940 ESI=24c5ee88 EDI=24c5ee88 DS=0053 DSACC=f0f3 DSLIM=ffffffff ES=0053...

Is it just me or has the Fandango site stopped working with FF (1.5.0.7, 1.5.0.9, 2.0) on eComStation 1.2 ?
Hi all, I've possibly messed up my Firefox installations, but other pages still seem to work OK. Has anyone else had problems recently with http://www.fandango.com ? The home page comes up, and then completely hangs my system, and even if I ctrl-alt-delete and kill Firefox with TOP, I just get a black screen and have to re-boot. It used to work fine. If it's just me, does anyone have any advice for what might be happening or how to go about figuring it out ? Thanks in advance, Karen Roberts On Sat, 3 Mar 2007 19:13:13 UTC, Karen Roberts <kvroberts@comcast.net>...

Problem during installation of dnn 4.0.0 and 4.0.1
Hi guys, I've been trying to install dotnetnuke 4.0.0 and from today 4.0.1, using a MS SQL 2005 database. I keep getting the following error: 00:00:24.312 -   Error: Could not find stored procedure 'dbo.aspnet_CheckSchemaVersion'. Any clues why this happens? Here is the Installation Status Report. 00:00:00.093 - Installing Version: 3.1.000:00:00.125 - Installing Script: DotNetNuke.SetUp.SqlDataProvider00:00:00.234 - Installing Script: DotNetNuke.Schema.SqlDataProvider00:00:05.015 - Installing Script: DotNetNuke.Data.SqlDataProvider00:00:09.562 -&...

Problem with some links since upgrade Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Name: Nick Product: Firefox Summary: Problem with some links since upgrade Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 Comments: Hi, I encountered some problem to click links that i used to be able to click with the previous Firefox, i paste a link to let you experience it too http://shop33455054.taobao.com/?catId=39839020&queryType=cat&categoryName=%C8%AB%B3%A1175%D4%AA+C1RCA&browseType=#pagebar as you can see the sub-categories can't be browsed (talking about the menu on the left side) i tried again with the pr...

Web resources about - Printing Problems - RaveReports 5.0.1 - Delphi 7.0 Build 4.453 [Edit] - embarcadero.delphi.reporting

Resources last updated: 12/6/2015 1:50:30 AM