Delphi XE5 DCC Error E2597

I can compile and run a FireMonkey app when I select the iOS Simulator.
However when I try to compile it for iPhoneOS5.0 as the target platform 
I get the following error:
[DCC Error] E2597 ld: warning: directory not found for option 
'-FC:\Users\Glen\Documents\RAD 
Studio\SDKs\iPhoneOS5.0.sdk\System\Library\PrivateFrameworks'
   ld: file not found: /usr/lib/system/libnotify.dylib for architecture 
armv7

Could someone please advise me on what I am doing wrong.

This also happens when I try one of the sample apps that installed with 
delphi as well.

Thanks
0
Glen
1/3/2014 4:34:27 AM
embarcadero.delphi.ios 412 articles. 0 followers. Follow

2 Replies
2240 Views

Similar Articles

[PageSpeed] 17

Glen Welch wrote:

> However when I try to compile it for iPhoneOS5.0 as the target
> platform I get the following error:
> [DCC Error] E2597 ld: warning: directory not found for option 
> '-FC:\Users\Glen\Documents\RAD 
> Studio\SDKs\iPhoneOS5.0.sdk\System\Library\PrivateFrameworks'
>    ld: file not found: /usr/lib/system/libnotify.dylib for
> architecture armv7

You can't (or at least shouldn't be able to) target iOS 5.0 with XE5.
Make sure iOS 6.1 or iOS 7 is selected in the SDK manager.

-- 
Dave Nottage [TeamB]
Find tips and code samples at Delphi Worlds: 
http://delphi.radsoft.com.au/blog
0
Dave
1/3/2014 5:29:09 AM
On 3/01/2014 6:29 p.m., Dave Nottage wrote:
> Glen Welch wrote:
>
>> However when I try to compile it for iPhoneOS5.0 as the target
>> platform I get the following error:
>> [DCC Error] E2597 ld: warning: directory not found for option
>> '-FC:\Users\Glen\Documents\RAD
>> Studio\SDKs\iPhoneOS5.0.sdk\System\Library\PrivateFrameworks'
>>     ld: file not found: /usr/lib/system/libnotify.dylib for
>> architecture armv7
>
> You can't (or at least shouldn't be able to) target iOS 5.0 with XE5.
> Make sure iOS 6.1 or iOS 7 is selected in the SDK manager.
>
Thanks for that - should have clicked about the iOS 5, guess I was 
seeing the iPhone 5 and just didnt think enough about it.

How do I select iOS 6.1 or 7 in the SDK manager - is that on XCode. I am 
not in front of of the Mac at the moment.

Thanks
0
Glen
1/3/2014 7:07:03 PM
Reply: