Windows 7 Access Error

Delphi 7 / IW 9.0.42 / Advantage Database Server 9.10

I have an older application that we would like to run under Windows 7.
It is compiled under Windows XP and works perfectly there. The
application has been built with the same manifest that works properly
in other programs accessing the same ADS database. The IW application
has the same database connection path as other programs that function
properly under Windows 7.

UAC has been turned off, the application runs as Administrator with
full access rights, and all restrictions to the database folder have
been removed.

The IW Server appears when the application is started. When the browser
is started, the application fails with a database connection error
which says the database can't be found or there are insufficient
rights. The OnCreate event handler includes statements connecting to
the database.

What have I missed and what can I do to get this application
functioning?


--
0
Thomas
5/29/2012 2:59:22 AM
embarcadero.delphi.intraweb 3901 articles. 1 followers. Follow

8 Replies
635 Views

Similar Articles

[PageSpeed] 20

> What have I missed and what can I do to get this application
> functioning?

i suggest you to create a log in your application to register what is happening and trace the source of the problem as it seems a DB connection problem... maybe if you ask on the ADS forum you will get more help than here...
0
Jackson
5/29/2012 5:45:51 AM
Hi Thomas,
i have been using ADS 10.x with IW10,IW11 and IW12 with clients ranging from XP through W7 32/64 and  Server on XP,W2003,W2008 (32/64bit),W7 32/64  and have not had to make any code changes for the ADS

You say the connection is established in the oncreate

i am presuming that that is usersession.oncreate 

The only ADS issue i have encountered is when running under Apache. I had to pre-load the application DLL to ensure that the ADS dlls were in memory before the first application call


> {quote:title=Thomas Hahn wrote:}{quote}
> Delphi 7 / IW 9.0.42 / Advantage Database Server 9.10
> 
> I have an older application that we would like to run under Windows 7.
> It is compiled under Windows XP and works perfectly there. The
> application has been built with the same manifest that works properly
> in other programs accessing the same ADS database. The IW application
> has the same database connection path as other programs that function
> properly under Windows 7.
> 
> UAC has been turned off, the application runs as Administrator with
> full access rights, and all restrictions to the database folder have
> been removed.
> 
> The IW Server appears when the application is started. When the browser
> is started, the application fails with a database connection error
> which says the database can't be found or there are insufficient
> rights. The OnCreate event handler includes statements connecting to
> the database.
> 
> What have I missed and what can I do to get this application
> functioning?
> 
> 
> --
0
sean
5/29/2012 6:28:17 AM
sean webb wrote:

> Hi Thomas,
> i have been using ADS 10.x with IW10,IW11 and IW12 with clients
> ranging from XP through W7 32/64 and  Server on XP,W2003,W2008
> (32/64bit),W7 32/64  and have not had to make any code changes for
> the ADS
> 
> You say the connection is established in the oncreate
> 
> i am presuming that that is usersession.oncreate 
> 
> The only ADS issue i have encountered is when running under Apache. I
> had to pre-load the application DLL to ensure that the ADS dlls were
> in memory before the first application call
> 
> 
> > {quote:title=Thomas Hahn wrote:}{quote}
> > Delphi 7 / IW 9.0.42 / Advantage Database Server 9.10
> > 
> > I have an older application that we would like to run under Windows
> > 7.  It is compiled under Windows XP and works perfectly there. The
> > application has been built with the same manifest that works
> > properly in other programs accessing the same ADS database. The IW
> > application has the same database connection path as other programs
> > that function properly under Windows 7.
> > 
> > UAC has been turned off, the application runs as Administrator with
> > full access rights, and all restrictions to the database folder have
> > been removed.
> > 
> > The IW Server appears when the application is started. When the
> > browser is started, the application fails with a database
> > connection error which says the database can't be found or there
> > are insufficient rights. The OnCreate event handler includes
> > statements connecting to the database.
> > 
> > What have I missed and what can I do to get this application
> > functioning?
> > 
> > 
> > --

Hi Sean,

Thanks for responding with meaningful information. The error that I
thought was coming from ADS was actually coming from Windows.
Unfortunately, the same error is displayed when a file can't be
accessed or there is a rights problem so my original thought was that
the database couldn't be opened.

Just now, after trying everything I can think of, I discovered that IW
is raising an error about the Chrome browser I was using to start the
application. On a hunch, I switched to Internet Explorer and everything
worked perfectly.

--
0
Thomas
5/29/2012 3:48:28 PM
Jackson Gomes wrote:

> > What have I missed and what can I do to get this application
> > functioning?
> 
> i suggest you to create a log in your application to register what is
> happening and trace the source of the problem as it seems a DB
> connection problem... maybe if you ask on the ADS forum you will get
> more help than here...

I had already done that. See reply below.

--
0
Thomas
5/29/2012 3:49:20 PM
Odd,
never had a problem with Chrome

> Just now, after trying everything I can think of, I discovered that IW
> is raising an error about the Chrome browser I was using to start the
> application. On a hunch, I switched to Internet Explorer and everything
> worked perfectly.
> 
> --
0
sean
5/29/2012 4:13:43 PM
sean webb wrote:

> Odd,
> never had a problem with Chrome
> 
> > Just now, after trying everything I can think of, I discovered that
> > IW is raising an error about the Chrome browser I was using to
> > start the application. On a hunch, I switched to Internet Explorer
> > and everything worked perfectly.
> > 
> > --

I think it's because it came out after IW 9.0.42. It's only a problem
when starting the application from the server; Chrome works fine
accessing the application. It may be that I haven't configured the
ServerController properly for an unknown browser.

--
0
Thomas
5/30/2012 1:18:54 AM
> I think it's because it came out after IW 9.0.42. It's only a problem
> when starting the application from the server; Chrome works fine
> accessing the application. It may be that I haven't configured the
> ServerController properly for an unknown browser.

as you are using IW 9, I dont believe (IIRC) this version will generate any unsupported browser.
0
Jackson
5/30/2012 5:57:23 AM
On 5/29/2012 9:18 PM, Thomas Hahn wrote:
> I think it's because it came out after IW 9.0.42. It's only a problem
> when starting the application from the server; Chrome works fine
> accessing the application. It may be that I haven't configured the
> ServerController properly for an unknown browser.

You might be interested in our recently announced IntraWeb x.


-- 
"Programming is an art form that fights back"
IntraWeb IRC and Web Chat:
http://www.atozed.com/intraweb/Support/IRC.aspx
0
Chad
5/30/2012 10:11:30 PM
Reply:

Similar Artilces:

Delphi 7 and Windows 7
Hi, I installed Delphi7 on Windows 7 - 64 bit. I have disable UAC and I was setting rights for Delphi direcotires in Program Files. I run Delphi in Administrator mode. When I can change my desktop from debug to normal I get Error "A call to an OS function failed." with button OK. When I press OK, the Error is display again. I must shutdown Delphi. Thank you for any idea to solve this problem Petr On Fri, 20 Aug 2010 07:09:11 -0700, Registered User <> wrote: >Hi, >I installed Delphi7 on Windows 7 - 64 bit. I have disable UAC and I was setting rights for Delph...

Occasional errors with 32-bit Delphi 7 application on Windows 7 64-bit
Hi, I have a 32-bit Delphi 7 application which was deployed on some machines with Windows 7 64-bit. The application occasionally displays errors such as: "Error reading ppDBText37.Border.Color: Invalid property value" or "Error reading Label24.Font.Ch: Property Ch does not exist" (here the name "Charset" was apparently truncated to "Ch") I checked how those properties are declared on the form where the errors occurred, and all seems ok: - First form (where "Error reading ppDBText37.Border.Color: Invalid property value" occurs): ...

Windows 7 ... Delphi 7
The new Windows 7 reminds me very strong of Delphi 7 ... a good feeling! > {quote:title=Ralf Stocker wrote:}{quote} > The new Windows 7 reminds me very strong of Delphi 7 ... a good feeling! Me too, from what I've heard so far. They are releasing it as a public beta tommorrow (the first 2.5 million in line only): Windows 7 page http://www.microsoft.com/windows/windows-7/ Information on Downloading and Installing Windows 7 Beta http://windowsteamblog.com/blogs/windows7/archive/2009/01/07/information-on-downloading-and-installing-windows-7-beta.aspx How to Get in on th...

Problem with viewing Windows SDK help files from Delphi 7 under Windows 7
Hi, I recently installed Delphi 7 on a Windows 8 machine putting it into a non-system folder. When I found that it wasn't displaying (Delphi) help files I downloaded and installed WinHlp32.exe from the MS website http://www.microsoft.com/en-us/download/details.aspx?id=91 and this solved the problem. But when I try to view the Windows SDK by selecting the appropriate menu item under the IDE Help menu I get the Winhelp runtime error message "Microsoft Help has stopped working". Can anyone suggest what needs to be done to be able to view the Windows SDK files that sh...

Access violation on delphi XE6 (Windows 7)
Hello, After compiling my project i'm trying to run the program on DELPHI XE6 (windows 7) and get this error : First chance exception at $7620C42D. Exception class EAccessViolation with message 'Access violation at address 6FDD19D5 in module 'gdiplus.dll'. Read of address 40140603'. Process Pentagon.exe (6760) Can you please let me know how to fix this error ? Thanks, Shay. El 26/01/2015 a las 15:06, Shay Gibly escribió: > Hello, > > After compiling my project i'm trying to run the program on DELPHI XE6 (windows 7) and get this error : ...

Debug error in Delphi 2010 and Windows 7
I am biuilding a new application and I want to do it with Runtime packeges. I am using indows 7 and Delphi 2010. I have come over a problem i can't solve. I have built the form structure of the application separated in different packages and it all works fine. Starting to add compnents it continued to work as aexpected, but when I added a standard splitter component, or a AdvSplitter component from TMS Software as an exampel problems arise. When I compile and run the application i get a debugger error saing: Project D:\Dev10\E11\Bin\E11.exe faulted with message 'access violati...

Access violation on delphi XE6 (Windows 7) [Edit]
Hello, After compiling my project i'm trying to run the program on DELPHI XE6 (windows 7) and get this error : First chance exception at $7620C42D. Exception class EAccessViolation with message 'Access violation at address 6FDD19D5 in module 'gdiplus.dll'. Read of address 40140603'. (6760) Can you please let me know how to fix this error ? Thanks, Shay. Edited by: Shay Gibly on Jan 26, 2015 11:41 PM > {quote:title=Antonio Estevez wrote:}{quote} > El 26/01/2015 a las 15:06, Shay Gibly escribió: > > Hello, > > > > After com...

Delphi 7 + Windows 7 = No Help
Okay, so has anyone figured a solution to this problem yet? Delphi 7 uses winhelp for it's help system and Windows 7 does not include winhelp. The problem: Although Vista has a winhelp download, Windows 7 does not, and the Vista winhelp download will not install on Windows 7. The solution: Waiting to find out. Anthony Walter wrote: > The solution: Waiting to find out. It was released about a half an hour ago for download... :-) http://tinyurl.com/yz6s397 Mark > {quote:title=Anthony Walter wrote:}{quote} > Okay, so has anyone figured a solution to this pro...

Reinstall Delphi 7 on Windows 7?
My projects work fine in Delphi 7 on my old XP machine so the problems I am now experiencing under Windows 7 must be due to the Delphi set-up in Windows 7. I have attempted to reinstall this - after entering my serial number and authorization code the installer bombs out with the error "1311 file not found C:\Program Files\Borland\DELPHI~1.cab ...." certainly this file does not exist but nor does it exist on the XP machine. I downloaded the original Delphi from the old Borland site which is now not avai lable. Does anyone know what this *.cab file is all about or how I can get new...

Using Delphi 7 in Windows 7
I have recently upgraded my system to Windows 7. I have Delphi 7 working to some extent - it will open my projects and display my units and allow me to edit the code then compiles the *.exe file - BUT it will not display my forms. View/Forms - shows the list of forms and will open the associated unit but neither this nor F12 will display the form itself. Consequently I am unable to edit the form itself or its properties. Any ideas about what might be preventing these from displaying? > {quote:title=Ian BASIRE wrote:}{quote} > I have recently upgraded my system to Windows 7. I h...

Delphi 7 won't start up anymore on Windows 7 (except in Windows safe mode) [Edit]
I'm using Delphi 7 PE under Windows 7 Home Edition. Since four days Delphi will not start anymore. When I start, I see an entry "delph32.exe" in the Windows Task Manager (process tab, not application tab) but this will disappear sillently after some seconds. No error or warning message is given. I tried several things already, after searching the internet for a solution: - start delphi in comptability mode - start delphi as administrator - give full right on the installation directory of delphi - disable UAC - restore windows to the previous restore point None of ...

Delphi 7, Windows 8.1 and Runtime error 216
Hello everybody First of all - Happy New Year ;-) I have installed Delphi 7 in Windows 8.1 recently. All third party components I use and their sources, were taken from working D7 installation in Windows 7 and most of them were installed from bpls copied from Win 7 machine. I'm able to compile projects, applications run fine. The problem I have is that when I close the application (while debugging) EAccessViolation exception raises. It doesn't take place when I compile same project on Win 7 machine. Since the call stack window is empty, I'm 'lost in the dark' a bit. ...

Delphi 7, Windows 8.1 and Runtime error 216
Hello everybody First of all - Happy New Year ;-) I have installed Delphi 7 in Windows 8.1 recently. All third party components I use and their sources, were taken from working D7 installation in Windows 7 and most of them were installed from bpls copied from Win 7 machine. I'm able to compile projects, applications run fine. The problem I have is that when I close the application (while debugging) EAccessViolation exception raises. It doesn't take place when I compile same project on Win 7 machine. Since the call stack window is empty, I'm 'lost in the dark' a bit. ...

Delphi 7 and Windows 7 x64
I have a number of applications that cannot be migrated from Delphi 7 because of third party components. Is it possible to run Delphi 7 on Winows 7 or is it necessary to use VMWare? Will programs compiled with Delphi 7 run on Windows 7? Tom Thomas Hahn wrote: > I have a number of applications that cannot be migrated from Delphi 7 > because of third party components. Is it possible to run Delphi 7 on > Winows 7 or is it necessary to use VMWare? Will programs compiled > with Delphi 7 run on Windows 7? It run OK, you must have admin rights to install Cesar Rom...

Web resources about - Windows 7 Access Error - embarcadero.delphi.intraweb

Window - Wikipedia, the free encyclopedia
This article is about the part of a building. For the Microsoft operating system, see Microsoft Windows . For other uses, see Window (disambiguation) ...

Microsoft Windows Information, Solutions, Tools - Windows IT Pro
Microsoft Windows information and solutions for IT pros. Topics include cloud computing, Windows Server, Exchange, Outlook, PowerShell, virtualization, ...

The Windows Blog
The Windows Blog is Microsoft's Official Blog for the Windows Operating System.

Windows 10 now on more than 200 million devices, and people are using the Store
Windows 10 is now in use on more than 200 million active device after about five months on the market, according to figures released by Microsoft ...

Why is Microsoft monitoring how long you use Windows 10?
The various privacy concerns surrounding Windows 10 have received a lot of coverage in the media, but it seems that there are ever more secrets ...

Windows 10 now on 200 million devices worldwide
Despite some concerns about bugs and even privacy, Windows 10 is proving a huge hit. The company has announced that 200 million monthly active ...

As PCs continue to decline, Microsoft looks to the cloud, pushes Windows 10
Six months after Microsoft released its first-ever free operating system, Windows 10 is now running on more than 200 million devices monthly. ...

The guy who wrote Windows Solitaire did it as an intern and never made any royalties on it
One of the most popular computer games of all time, the 25-year-old Windows Solitaire, was written by an intern named Wes Cherry who was never ...

Microsoft's new tally for Windows 10: 200M
Microsoft today updated its Windows 10 claim, saying that the new operating system is on more than 200 million devices that have been used at ...

Microsoft excited to almost reach iPad levels of success with Windows 10
Microsoft is excited, as it’s almost got as many installs of Windows 10 as there are iPads. Of course, the Redmond-based tech company didn’t ...

Resources last updated: 1/5/2016 10:28:36 AM