XE8 GetIt not loading anything.

After installing XE8 i like to use the GetIt module but it doesn't work. It's loading but it doesn't find anything.
Maybe the connection is not valid on my company network but I can't find any configuration of GetIt.
0
Robert
6/3/2015 1:55:55 PM
embarcadero.delphi.install 1244 articles. 0 followers. Follow

19 Replies
894 Views

Similar Articles

[PageSpeed] 54

Let's make sure we have a clear definition of what "it doesn't work" 
means. As I understand it, what you are observing is you select Tools | 
Get it and the list is completely blank. Is this a correct description 
of your observation?

I've not seen any reports on Get it not working, so I've not thought 
about it much. However, it makes sense to me the cause to be some sort 
of communication between you and us is not working. I would guess a 
local security policy like a proxy or firewall to be the issue.

Robert Triest wrote:
> After installing XE8 i like to use the GetIt module but it doesn't work. It's loading but it doesn't find anything.
> Maybe the connection is not valid on my company network but I can't find any configuration of GetIt.
>
0
quinn
6/3/2015 3:31:16 PM
> Is this a correct description of your observation?
Yes. 
> I would guess a local security policy like a proxy or firewall to be the issue.
Yes, what can I do about it?
Thanks.
0
Robert
6/3/2015 8:27:09 PM
Robert Triest wrote:
> Yes, what can I do about it?

Configure the local security policy. It might be turn off the Firewall. 
It might mean allow the Firewall to connect to embarcadero.com. It might 
mean do something to your proxy. I know next to nothing about these 
things as they do not come from us.
0
quinn
6/3/2015 10:29:50 PM
> {quote:title=quinn wildman wrote:}{quote}
> Robert Triest wrote:
> > Yes, what can I do about it?
> 
> Configure the local security policy

I don't think it's just or only a firewall issue. After installing XE8u1 (subscription version, Enterprise level), GetIt shows me four tiles for UNinstalling Essentials, Lockbox,SysTools, and VirtualTreeView, but nothing to install. This is on my home machine--no proxy or setting changes. GetIt showed more before the .1 update.

If you want us to persue a permissions/filewall issue and attempt to nail it sown, then how did GetIt's requirements change? NOthing changed this end.

 bobD
0
Robert
6/20/2015 1:32:40 PM
> {quote:title=Robert Dawson wrote:}{quote}
> > {quote:title=quinn wildman wrote:}{quote}
> > Robert Triest wrote:
> > > Yes, what can I do about it?
> > 
> > Configure the local security policy
> 
> I don't think it's just or only a firewall issue. After installing XE8u1 (subscription version, Enterprise level), GetIt shows me four tiles for UNinstalling Essentials, Lockbox,SysTools, and VirtualTreeView, but nothing to install. This is on my home machine--no proxy or setting changes. GetIt showed more before the .1 update.
> 
> If you want us to persue a permissions/filewall issue and attempt to nail it sown, then how did GetIt's requirements change? NOthing changed this end.
> 
>  bobD

Same here - after install all I can see is what I'd already installed (Omni thread in my case)

Tim
0
Tim
6/20/2015 5:21:33 PM
Tim Winstanley wrote:

> > {quote:title=Robert Dawson wrote:}{quote}
> > > {quote:title=quinn wildman wrote:}{quote}
> > > Robert Triest wrote:
> > > > Yes, what can I do about it?
> > > 
> > > Configure the local security policy
> > 
> > I don't think it's just or only a firewall issue. After installing
> > XE8u1 (subscription version, Enterprise level), GetIt shows me four
> > tiles for UNinstalling Essentials, Lockbox,SysTools, and
> > VirtualTreeView, but nothing to install. This is on my home
> > machine--no proxy or setting changes. GetIt showed more before the
> > .1 update.
> > 
> > If you want us to persue a permissions/filewall issue and attempt
> > to nail it sown, then how did GetIt's requirements change? NOthing
> > changed this end.
> > 
> >  bobD
> 
> Same here - after install all I can see is what I'd already installed
> (Omni thread in my case)
> 
> Tim

Same here as well.  I don't have anything installed from GetIt, and it
comes up with a blank window with the word "Loading...." at the bottom,
but nothing ever shows up.  It worked totally fine yesterday morning
before installing update 1, and there have been no changes to my system
in terms of security permissions, etc.

-- 
Cheers,
Van

"Good judgment comes from experience, and a lot of that comes from bad
judgment." - Will Rogers
0
Van
6/20/2015 5:51:49 PM
Tim Winstanley wrote:

> > {quote:title=Robert Dawson wrote:}{quote}
> > > {quote:title=quinn wildman wrote:}{quote}
> > > Robert Triest wrote:
> > > > Yes, what can I do about it?
> > > 
> > > Configure the local security policy
> > 
> > I don't think it's just or only a firewall issue. After installing
> > XE8u1 (subscription version, Enterprise level), GetIt shows me four
> > tiles for UNinstalling Essentials, Lockbox,SysTools, and
> > VirtualTreeView, but nothing to install. This is on my home
> > machine--no proxy or setting changes. GetIt showed more before the
> > .1 update.
> > 
> > If you want us to persue a permissions/filewall issue and attempt
> > to nail it sown, then how did GetIt's requirements change? NOthing
> > changed this end.
> > 
> >  bobD
> 
> Same here - after install all I can see is what I'd already installed
> (Omni thread in my case)
> 
> Tim

Same here as well.  I don't have anything installed from GetIt, and it
comes up with a blank window with the word "Loading...." at the bottom,
but nothing ever shows up.  It worked totally fine yesterday morning
before installing update 1, and there have been no changes to my system
in terms of security permissions, etc.

-- 
Cheers,
Van

"Good judgment comes from experience, and a lot of that comes from bad
judgment." - Will Rogers
0
Van
6/20/2015 5:52:07 PM
Robert wrote:

> I don't think it's just or only a firewall issue. After installing
> XE8u1 (subscription version, Enterprise level), GetIt shows me
> four tiles for UNinstalling Essentials, Lockbox,SysTools, and
> VirtualTreeView, but nothing to install. This is on my home
> machine--no proxy or setting changes. GetIt showed more
> before the .1 update.

I'm no expert in GetIt (in fact, I haven't even looked at it yet), but based 
on the paperwork needed to get a library added to GetIt in the first place, 
libraries have to support specific IDE versions and possibly even specific 
Updates, so my guess is that the existing entries have simply not been updated 
to include Update 1 yet.

-- 
Remy Lebeau (TeamB)
0
Remy
6/21/2015 5:52:32 AM
Same issue.  Posted in the 'ide NG before I saw this.

Note the various comments.

Eagerly await a resolution.

Ian
0
Ian
6/21/2015 6:42:03 AM
> {quote:title=Robert Dawson wrote:}{quote}
> I don't think it's just or only a firewall issue. After installing XE8u1 (subscription version, Enterprise level), GetIt shows me four tiles for UNinstalling Essentials, Lockbox,SysTools, and VirtualTreeView, but nothing to install. This is on my home machine--no proxy or setting changes. GetIt showed more before the .1 update.

It's not a user configuration issue. If anything it's a *server* config issue :)

I have reported this in quality.embarcadero.com as issue RSP-11350

Bob Evans
0
Robert
6/21/2015 5:55:43 PM
Hi,
Same here as well. Before installing XE8 u1, Getit works fine but now it comes with an empty window and loading... and nothing shows, this is a home machine, without any proxy and I tried turn off firewall and nothing shows.

Regards
Bahry
0
Bahry
6/21/2015 10:04:29 PM
+1
0
Nigel
6/21/2015 11:24:31 PM
+1
GetIt shows only already installed packages.

Peter
0
Peter
6/22/2015 9:38:58 AM
+1
GetIt shows only already installed packages.

Peter
0
Peter
6/22/2015 9:39:59 AM
Tim Winstanley wrote:

> > {quote:title=Robert Dawson wrote:}{quote}
> > > {quote:title=quinn wildman wrote:}{quote}
> > > Robert Triest wrote:
> > > > Yes, what can I do about it?
> > > 
> > > Configure the local security policy
> > 
> > I don't think it's just or only a firewall issue. After installing
> > XE8u1 (subscription version, Enterprise level), GetIt shows me four
> > tiles for UNinstalling Essentials, Lockbox,SysTools, and
> > VirtualTreeView, but nothing to install. This is on my home
> > machine--no proxy or setting changes. GetIt showed more before the
> > .1 update.
> > 
> > If you want us to persue a permissions/filewall issue and attempt
> > to nail it sown, then how did GetIt's requirements change? NOthing
> > changed this end.
> > 
> >  bobD
> 
> Same here - after install all I can see is what I'd already installed
> (Omni thread in my case)
> 
> Tim

Same here as well.  I don't have anything installed from GetIt, and it
comes up with a blank window with the word "Loading...." at the bottom,
but nothing ever shows up.  It worked totally fine yesterday morning
before installing update 1, and there have been no changes to my system
in terms of security permissions, etc.

-- 
Cheers,
Van

"Good judgment comes from experience, and a lot of that comes from bad
judgment." - Will Rogers
0
Van
6/22/2015 1:54:51 PM
In article <726960@forums.embarcadero.com>, Peter Eckweiler 
<peter.eckweiler@ehs-online.net> wrote
>+1
>GetIt shows only already installed packages.

As previously noted, this was a server config issue and has now been 
resolved by Embarcadero.

Regards,
-- 
Bob Evans
0
Robert
6/22/2015 3:54:13 PM
Robert Evans wrote:

> As previously noted, this was a server config issue and has now been 
> resolved by Embarcadero.

Not only resolved, but improved.  Previously, it showed both C++ and
Delphi packages.  Now, since I only have the Delphi personality, it
only shows the Delphi packages.  And, it includes a package for Object
Pascal interfaces to WinRT on Windows 10!

-- 
Cheers,
Van

"Good judgment comes from experience, and a lot of that comes from bad
judgment." - Will Rogers
0
Van
6/22/2015 6:04:51 PM
Robert wrote:

> I don't think it's just or only a firewall issue. After installing
> XE8u1 (subscription version, Enterprise level), GetIt shows me
> four tiles for UNinstalling Essentials, Lockbox,SysTools, and
> VirtualTreeView, but nothing to install. This is on my home
> machine--no proxy or setting changes. GetIt showed more
> before the .1 update.

I'm no expert in GetIt (in fact, I haven't even looked at it yet), but based 
on the paperwork needed to get a library added to GetIt in the first place, 
libraries have to support specific IDE versions and possibly even specific 
Updates, so my guess is that the existing entries have simply not been updated 
to include Update 1 yet.

-- 
Remy Lebeau (TeamB)
0
Remy
6/24/2015 6:55:13 AM
Although it had never worked in the start release XE8 for me it has been solved in XE8 update 1 without any firewall or proxy change.
0
Robert
6/26/2015 10:09:23 AM
Reply: