Package issue after installing XE8 update 1 [Edit]

After installing XE8 u1 (subscription), I'm now getting a message on Startup that reads
"[Window Title]
Error

[Content]
Package c:\program files (x86)\embarcadero\studio\16.0\bin\DUnitXRuntime220.bpl can't be installed because it is not a design time package.
Do you want to attempt to load this package the next time a project is loaded?

[Yes] [No]

====
This is new behavior--I did have DUnitX installed in XE8 before the update.

Please advise--misnamed package or manifest error? How do I fix?

bobD

Edited by: Robert Dawson on Jun 20, 2015 5:35 PM
0
Robert
6/21/2015 12:36:50 AM
embarcadero.delphi.install 1244 articles. 0 followers. Follow

3 Replies
1583 Views

Similar Articles

[PageSpeed] 44

DUnitXRuntime220.bpl was incorrect marked as a Design time package for 
RTM. Fixed for Update 1. However, if you uninstall using all the 
defaults, your IDE settings (aka the registry) will still have it listed 
as a design time package.

Long story short, tell the IDE not to load it the next time and all will 
be well.

I just wrote this for our knowledgebase as well: 
http://support.embarcadero.com/article/44491

Robert Dawson wrote:
> After installing XE8 u1 (subscription), I'm now getting a message on Startup that reads
> "[Window Title]
> Error
>
> [Content]
> Package c:\program files (x86)\embarcadero\studio\16.0\bin\DUnitXRuntime220.bpl can't be installed because it is not a design time package.
> Do you want to attempt to load this package the next time a project is loaded?
>
> [Yes] [No]
>
> ====
> This is new behavior--I did have DUnitX installed in XE8 before the update.
>
> Please advise--misnamed package or manifest error? How do I fix?
>
> bobD
>
> Edited by: Robert Dawson on Jun 20, 2015 5:35 PM
>
0
quinn
6/22/2015 6:43:23 PM
> {quote:title=quinn wildman wrote:}{quote}
> DUnitXRuntime220.bpl was incorrect marked as a Design time package for 
> RTM. Fixed for Update 1. However, if you uninstall using all the 
> defaults, your IDE settings (aka the registry) will still have it listed 
> as a design time package.
> 
> Long story short, tell the IDE not to load it the next time and all will 
> be well.
> 
> I just wrote this for our knowledgebase as well: 
> http://support.embarcadero.com/article/44491

Thanks for confirmation.

Is Embc strictly observant about the convention that design time install packages are always prefixed with 'dcl'? IOW,could I have safely assumed the answer based on the package name?

bobD
0
Robert
6/23/2015 11:36:35 AM
Robert Dawson wrote:
>> {quote:title=quinn wildman wrote:}{quote}
>> DUnitXRuntime220.bpl was incorrect marked as a Design time package for 
>> RTM. Fixed for Update 1. However, if you uninstall using all the 
>> defaults, your IDE settings (aka the registry) will still have it listed 
>> as a design time package.
>>
>> Long story short, tell the IDE not to load it the next time and all will 
>> be well.
>>
>> I just wrote this for our knowledgebase as well: 
>> http://support.embarcadero.com/article/44491
> 
> Thanks for confirmation.
> 
> Is Embc strictly observant about the convention that design time install packages are always prefixed with 'dcl'? IOW,could I have safely assumed the answer based on the package name?
> 
> bobD

For component packages yes, for IDE packages no (for instance coreide220.bpl).

-- 
Jeff Overcash (TeamB)
       (Please do not email me directly unless  asked. Thank You)
And so I patrol in the valley of the shadow of the tricolor
I must fear evil. For I am but mortal and mortals can only die.
Asking questions, pleading answers from the nameless
faceless watchers that stalk the carpeted  corridors of Whitehall.
              (Fish)
0
Jeff
6/23/2015 4:52:54 PM
Reply:

Similar Artilces:

Installed Delphi 2010 update 4, but About box shows update 1. Did I update? [Edit]
I ran the Delphi 2010 Update 4 from the start menu's Embarcadero RAD Studio 10 > Check for Updates. It seemed to go fine. Afterward, my copy of Delphi 2010 is still showing it has Update 1 in the About window. I tried rebooting, but it still shows Update 1. I'm running Windows Vista, with a Standard User account. How can I tell if the update really occurred? When I go to Embarcadero RAD Studio 10 > Check for Updates now, it doesn't show Update 4 as an option any more. Edited by: Chris Irwin on Dec 15, 2009 9:00 AM > {quote:title=Chris Irwin wrote:}{quot...

Psckage issue after installing XE8 update 1
After installing XE8 u1 (subscription), I'm now getting a message on Startup that reads "[Window Title] Error [Content] Package c:\program files (x86)\embarcadero\studio\16.0\bin\DUnitXRuntime220.bpl can't be installed because it is not a design time package. Do you want to attempt to load this package the next time a project is loaded? [Yes] [No] ==== This is new behavior--I did have DUnitX installed in XE8 before the update. Please advise--misnamed package or manifest error? How do I fix? bobD Robert Dawson wrote: > This is new behavior--I did have DU...

Installed VS.NET 2002. That installed 1.0, but I HAD 1.1 installed. How to remove 1.0?
I haven't seen this anywhere, so I figured I would add it here. First of all, it is incorrect to recommend to anyone that who has VS.NET 2002 to do ANYTHING but first install VS.NET 2002. The installl order for VS.NET 2002 and .Net Framwork 1.1 SHOULD BE: 0. Install ALL windows updates for your pc EXCEPT FOR .NET Framwork 1.1 1. Install VS.NET 2002 2. Install MSDE that comes w/VS.NET 2002 (USE A NAMED INSTANCE! Never usee the default instance) 2. Install MDAC 2.8 3. Install .Net Framework 1.1 4. SOMEHOW GET RID OF .NET Framework and get VS.NET and IIS 5.x to work w...

Software update 898461 installs a permanent copy of the Package Installer for Windows version 6.1.22.4
Software update 898461 installs a permanent copy of the Package Installer for Windows version 6.1.22.4 http://support.microsoft.com/kb/KB898461 ----------------------------------------------------------- Quote ----------------------------------------------------------- Article ID : 898461 Last Review : June 28, 2005 Revision : 1.0 APPLIES TO * Microsoft Windows XP Home Edition SP1 * Microsoft Windows XP Home Edition SP2 * Microsoft Windows XP Professional SP1 * Microsoft Windows XP Professional SP2 * Microsoft Wi...

[XE] I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing.
This message is in MIME format. Since your mail reader does not understand this format, some or all of this message may not be legible. --JivePart=_4a211.zeB8CwDOH5aMJzMl Content-Type: text/plain; charset="Utf-8" ?I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing. --JivePart=_4a211.zeB8CwDOH5aMJzMl Content-Type: image/png; name="Update 1 Boost Install.PNG" Content-Transfer-Encoding: base64 Content-Disposition: attachment; filename="Update 1 Boost Install.PNG" iVBORw0KGgoAAAANSUhEUgA...

[XE] I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing.
?[XE] I did not Install the Boost Libraries when I installed XE but it did not stop Update 1 Boost from Installing. Should I report this as a problem in QC? ( See public.attachements ) Larry ...

App works in IOS simulator with Delphi XE4 and fails after Update 1 install [Edit]
Hi! When I install update 1 and installing new update 1 PAserver and run my application (very simple Firemonkey Mobile Application) I get: "Project xxx raised exception class SIGSEGV (11)". When I reinstall Delphi XE (without update 1) everything works fine again, I have tried to remove all code in FormCreate and OnActivate without luck. What can this be? I have also tried with the old PAserver but this doesnt work either. It Works when running to physical devices like Iphone4 and Ipad mini. But when I select to run from the simulator this errormessage comes back ag...

I have already Help update 1 but the Updater tries to install it. [Edit]
Hello! I have installed all updates for Delphi 2010 (Professional) and my "About" window shows these installed updates: Delphi and C++Builder Update 4 *Delphi and C++Builder Help Update 1* Delphi and C++ Builder Update 5 (Database Pack). http://savepic.org/161268.png But when I launch the updater (All Programs - Embarcadero Rad Studio 2010 - Check for Updates), I see this in the window of available updates: *Delphi and C++Builder Help Update 1* http://savepic.org/151028.png Can I fix it somehow, maybe somewhere in registry? And how does it come that the updater does no...

12.1 Installation Issue
I have tried to install 12.1 multiple times on my workstation, but to no avail. Instead of upgrading my previous installed system, I put in new, larger hard drives and going for a clean, fresh install. I get through the first part of the installation okay. I set up the disks, select packages, etc. After it installs the packages, it goes to start up a session, and all I get is a white screen where I can see the cursor symbol, but nothing happens. I've even let it go four hours to see if something was just being slow, and nothing. Any ideas? (System is an older system...

Cannot install Delphi Update 1
Hello, When trying to install Delphi Update 1 I am receiving a pop up asking "Please locate your original setup resources to continue operation". How do I solve this problem please? Kind Regards, Asaf Asaf Goldman wrote: > Hello, > > When trying to install Delphi Update 1 I am receiving a pop up asking "Please locate your original setup resources to continue operation". > How do I solve this problem please? > > Kind Regards, > Asaf > I'll find out more later, but my guess is your install cache cannot be found. It located at ...

Installation Issues With 1.0
My Config:  Windows XP Pro SP2, VS2005 Standard SP1, Framework 2.0.50727, Logged in as Computer administrator My Problem:  Unable to install Ajax 1.0 - Installation proceeds until rolling back and giving me the "ended prematurely" window. My Diagnosis:  Ran "msiexec /i c:\ajaxSetup.msi /log c:\ajax.log" with the following results: 1: InstallVSTemplate 2: 0 Action 17:25:31: RollbackCleanup. Removing backup filesExecNetFx:  Microsoft (R) CLR Native Image Generator - Version 2.0.50727.42ExecNetFx:  Copyright (C) Microsoft Corporation 1998-2002. All rights reserved.Ex...

XE7 Update 1, Iphone 5 iOS 8.1.2 Unable to Install Package
Using XCODE 6.1.1, I am unable to deploy my application to a "new" Iphone 5 with iOS 8.1.2. I'm using the SDK for Iphone 8.1 which can be the problem, but I'm not sure if i can update it? I get the error Unable To Install Package. On my Ipad AIR iOS 8.0.2, it works fine! Anybody have any clues what to upgrade? I figured out it was the provisioning profile which didn't contain the "developer device". You need to add it to the Development provisioning profile, too! ...

If somebody could tell me what should be the problem. I installed Mozilla 1.7 under Mandrake Linux 9.1. But there are no icons installed into my KDE automaticly. Mozulla 1.7 installation problem
If somebody could tell me what should be the problem. I installed Mozilla 1.7 under Mandrake Linux 9.1. But there are no icons installed into my KDE automaticly. What should be the problem? ...

Package Error after installing Update 1
Hi, After installing XE8 Update 1, I'm getting the following package error "Package c:\program files(x86)\embcarcadero\studio\16.0...\DUnitXRuntime220.bpl can't be installed because it is not a design time package...." Is someone else getting this? Thanks in advance, Omar Zelaya Yes. I decided to ignore this. So far no problems. Peter ...

Web resources about - Package issue after installing XE8 update 1 [Edit] - embarcadero.delphi.install

Help:Installing Japanese character sets - Wikipedia, the free encyclopedia
This help page will help you install Japanese character sets so that your computer will display them properly on the internet in your web browser ...

Earn Free Facebook Credits For Installing Apps — Of Course, There’s A Catch
This looks pretty cool at first: Earn free Facebook Credits for installing applications on your iPhone or Android device. AppDog offers this ...

Installing solar panels - Flickr - Photo Sharing!
Solar panels are lifted into place.

Installing Afterglow AX.1 Wired XBOX 360 Controller on Lion/Mountain Lion 10.7.3+ - YouTube
I finally managed to install an Afterglow AX.1 (Wired XBOX Controller) and make it work on Lion 10.7.3 with TattiBogle 0.08. This tutorial works ...

Fatal unit fire: Builder Ray Finianos reduced height of building to avoid installing fire sprinklers ...
The builder of a south-west Sydney unit block where a young woman plunged to her death during a ferocious fire told a certifier to reduce ...

Ballarat man accused of installing spy cameras in ex-wife's house
A man accused of concealing surveillance cameras in skirting boards at his ex-wife's home also allegedly attached a GPS tracker to her car, a ...

Iran installing new nuclear equipment
Sky News is Australia's leader in 24-hour news. Iran has begun installing next-generation equipment at one of its main nuclear plants, a new ...

Rentasaur Installing 'Spyware' On Rental Laptops
An Australian business that rents out computers is installing software that in the US has been used to spy on users, including taking webcam ...

Gillard defends installing Slipper
BBC News Gillard defends installing Slipper Sydney Morning Herald Prime Minister Julia Gillard has defended her decision to install Peter ...

CSIRO says installing solar panels on roofs of businesses could take pressure off the electricity grid ...
Installing more solar panels on the roofs of businesses would help Australia's energy grid cope with increased demand.

Resources last updated: 1/16/2016 11:24:24 PM