Installing Update 3 on Delphi 2009 giving "insufficient privileges" error

I just applying Update 3 on Delphi2009 but received this error by the installer "insufficient privileges" on updating quite a few of files. 
The IDE will then throw hundred of exceptions during load-up!
0
ahmoy
5/29/2009 5:51:44 PM
embarcadero.delphi.install 1244 articles. 0 followers. Follow

8 Replies
774 Views

Similar Articles

[PageSpeed] 57

> {quote:title=b t wrote:}{quote}
> I just applying Update 3 on Delphi2009 but received this error by the installer "insufficient privileges" on updating quite a few of files. 
> The IDE will then throw hundred of exceptions during load-up!

At least make an effort to provide enough information for people to help you.

Are you running on Vista? If so, you can't just run the update; you have to right-click on it and choose "Run As Administrator". Any installer (not just RAD Studio Update 3) needs administrative access under Vista. Note that being logged in as Administrator is *not* the same as running it as Administrator.

If you're not running on Vista, what OS are you running on? Are you an administrator on that OS? Where is Delphi 2009 installed on your system?
0
Ken
5/29/2009 6:02:42 PM
> {quote:title=b t wrote:}{quote}
> I just applying Update 3 on Delphi2009 but received this error by the installer "insufficient privileges" on updating quite a few of files. 
> The IDE will then throw hundred of exceptions during load-up!

Sorry for lack of information and here are the details:
- XP sp 2
- installation path at a custom path "c:\languages\Delphi 2009"
- intallation type is for "all user"
- login as power user with admin right
0
ahmoy
5/29/2009 6:23:09 PM
> {quote:title=b t wrote:}{quote}
> > {quote:title=b t wrote:}{quote}
> > I just applying Update 3 on Delphi2009 but received this error by the installer "insufficient privileges" on updating quite a few of files. 
> > The IDE will then throw hundred of exceptions during load-up!
> 
> Sorry for lack of information and here are the details:
> - XP sp 2
> - installation path at a custom path "c:\languages\Delphi 2009"
> - intallation type is for "all user"
> - login as power user with admin right

That should work (things work fine on my office machine that way, and we're not allowed to do anything but run with admin rights).

You can try running the update with the parameters /l=c:\D2009UpdateLog.txt, and see if examining that log file gives you any useable information to help figure the problem out. Other than that, I'd open an installation case with CG Support; installation related cases are free and don't require any kind of support contract.
0
Ken
5/29/2009 6:43:13 PM
Ken White wrote:

> Are you running on Vista? If so, you can't just run the update; you
> have to right-click on it and choose "Run As Administrator".

Funny I don't have to do that for normal setup programs. Just double
click and let UAC do its job.

If I'm really installing stuff, I start Total Commander using "Run as
Administrator" and do everything from there, just to prevent a couple
of these UAC boxes to become annoying.

-- 
Pieter

"Most people would sooner die than think; in fact, they do so."
 -- Bertrand Russell (1872-1970)
0
Pieter
5/29/2009 8:43:27 PM
"Pieter Zijlstra" <p.zylstra.notthis@hccnet.nl> wrote in message 
news:122688@forums.codegear.com...

> Funny I don't have to do that for normal setup programs. Just double
> click and let UAC do its job.

I have not downloaded the update yet.  What is its executable's filename? 
Vista performs various checks - one of them being a filename comparison - 
when trying to figure out whether an executable is an installer so UAC can 
elevate it automatically.  Perhaps the update is not matching Vista's 
checks, thus requiring manual elevation?

-- 
Remy Lebeau (TeamB)
0
Remy
5/31/2009 6:01:40 AM
"Remy Lebeau (TeamB)" <no.spam@no.spam.com> skrev i meddelelsen 
news:122949@forums.codegear.com...
> "Pieter Zijlstra" <p.zylstra.notthis@hccnet.nl> wrote in message 
> news:122688@forums.codegear.com...
>
>> Funny I don't have to do that for normal setup programs. Just double
>> click and let UAC do its job.
>
> I have not downloaded the update yet.  What is its executable's filename? 
> Vista performs various checks - one of them being a filename comparison - 
> when trying to figure out whether an executable is an installer so UAC can 
> elevate it automatically.  Perhaps the update is not matching Vista's 
> checks, thus requiring manual elevation?

I just downloaded it.
Update 3 is called setup.exe and Vista displays the UAC-shield on the exe's 
icon, and when I ran it Vista gave me the UAC-prompt.
-- 
Finn Tolderlund
0
Finn
5/31/2009 8:17:05 AM
Remy Lebeau (TeamB) wrote:

> "Pieter Zijlstra" <p.zylstra.notthis@hccnet.nl> wrote in message
> news:122688@forums.codegear.com...
> 
> > Funny I don't have to do that for normal setup programs. Just double
> > click and let UAC do its job.
> 
> I have not downloaded the update yet.  What is its executable's
> filename?

Besides the one already mentioned by Finn the other two updates have
also 'setup' in their name which seems to be enough to trigger UAC.

Update 3: Run 'Setup.exe'.
Update 4: Run 'dbpack_setup /upgrade'.
Boost Update: Run 'boost_setup /upgrade'.

> Vista performs various checks - one of them being a
> filename comparison - when trying to figure out whether an executable
> is an installer so UAC can elevate it automatically.  Perhaps the
> update is not matching Vista's checks, thus requiring manual
> elevation?

On Vista Ultimate 64 SP1 there is no need for manual elevation of the
above mentioned files.

-- 
Pieter

"It is better to be feared than loved, if you cannot be both."
 -- Niccolo Machiavelli (1469-1527), "The Prince"
0
Pieter
5/31/2009 9:17:47 PM
b t wrote:
> I just applying Update 3 on Delphi2009 but received this error by the installer "insufficient privileges" on updating quite a few of files. 
> The IDE will then throw hundred of exceptions during load-up!

I have exactly the same problem (WinXP SP 3), hundreds of errors of the 
kind "The installer has insufficient privileges to modify this file:". 
Once you click "retry", it continues. This error doesn't appear for all 
files though, but for over a hundred of them. It concerns both file in 
Windows directories such as c:\windows\system32 and also the Delphi 
installation directories.

Of course I ran it under an account with admin privileges.

Any idea what's going on???

Stephan
0
Stephan
7/16/2009 7:29:47 AM
Reply:

Similar Artilces:

installation package error: "The installer was interrupted before [program] could be installed"
Hi,     I encountered one problem with my web application installation package. Before, it works well. While after some minor changes to code, I rebuild the setup file, when I tried to run it, I got such error.     I searched on web to find similar problems due to file <VS Install>\Common 7\tools\deployment\dpca.dll     My symptom is the same as described, I used the tool Qwerty.Msi to check errors, when debug, at sequence WEBCA_GatherWebSites 12:30:12 PM  Action start 12:30:12: WEBCA_GatherWebSites.12:30:15 PM  Action ended 12...

I get "The stored procedure 'dbo.AddDesktopModule' doesn't exist" Error installing 3.012 and 3.013. Version 2.12 installs fine.
I keep getting the following "The stored procedure 'dbo.AddDesktopModule' doesn't exist" Error installing 3.012 and 3.013. Version 2.12 installs fine.  I get the same error if I try to upgrade to version 3.013 after installing version 2.12.  Any ideas. I had a similar problem a while back. My problem was that the Sql Server was setup to be case sensitive. It can  not be this way for Dnn. Maybe something to look at....

"Validating install" for ages on Delphi 2009 update3 on Win7-RC
I am trying to install Delphi2009 update3/update4 on my Win7 RC test machine and it has been on the "validating install" part of update 3 for about an hour and a bit, and from the little green bar it looks like it's about 35% done. WHAT on earth is this crazy installer doing? W Warren Postma wrote: > WHAT on earth is this crazy installer doing? It might be wondering if you are installing as an Administrator....? -- Nick Hodges RAD Studio R&D Manager - Embarcadero http://blogs.codegear.com/nickhodges > {quote:title=Warren Postma wrote:}{q...

eDirectory 8.7.3 install error "Installation can only be run on a NetWare 5.1 Server..."
I have a server with eDirectory 8.7.1 running on Netware 6.5 SP 5 that I am trying to upgrade to eDirectory 8.7.3. When I start the install through NWCONFIG I get the following error message: -=-=- Error: This Installation can only be run on a NetWare 5.1 Server (with Support Pack Version 5.1.6) or a NetWare 6 Server (with Support Pack Version 6.0.3). -=-=- But the server is Netware 6.5. Novell Open Enterprise Server, NetWare 6.5 Support Pack Revision 05 (C) Copyright 1983-2005 Novell Inc. All Righ...

[XE2 Update 3] BDE components are installed even when "Entire feature will be unavailble" is set during install.
[XE2 Update 3] BDE components are installed even when "Entire feature will be unavailble" is set during install. Would anybody confirm this? (Sigh) ...

Cannot install updates: "Installation Aborted by User"
Hey all, I just recently installed openSUSE 12.1 "Asparagus" on my laptop, an ASUS A53E. I should probably also mention that the main drive in this system is an SSD I have to say I really like openSUSE, considering it's the first fedora-based distro I've set my hands on. That being said, I am having problems with updating certain packages.. When I try to use the regular software update through the notification, I get an error on certain packages that simply says "Installation aborted by user". This persists after reboots, after rpm --rebuilddb, try...

Installation Guide is weak. Has a "no Worry FYI" but not "how to install"
Name: Ari V Email: defygravity79atyahoodotcom Product: Thunderbird Summary: Installation Guide is weak. Has a "no Worry FYI" but not "how to install" Comments: read / review it for yourself. Browser Details: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (gutsy) Firefox/2.0.0.11 ...

GWTSA 6.5.1 causing "Insufficient privilege" errors after SP1 agent install
Hi, We applied SP1 to GroupWise 6.5 yesterday. Since, we have encountered problems when performing backups using the GWTSA (yes, it is updated as well to SP1). The errors seem to be related to rights. The most immediate indication is that the NDPSM and the Broker have insufficient right to write to the queues. The backup logs will show "Insufficient privilege for \OFUSER\USERXXX.DB - SKIPPED." These files were NOT open at the time of backup. And no streams were open either. We can cancel the backup job, but the Broker and NDPSM need to be unloaded/reloaded in o...

"Error" Installing Help Update
The June CodeGear Help update gets part way thru installing and I get a highly uninformative "Error"...then it goes to finish...I'm running Vista and changed the HKEY INstaller values as suggested in the install HTML...Now it just bombs immediately....what's up???? Is 'RAD Studio 2009 Help' included in your machine ? If it included in your machine, you uninstall it. Then you update '2007 help'. And you reinstall '2009 help'. > {quote:title=charles leggette wrote:}{quote} > The June CodeGear Help update gets part way thru installing...

Installation Guide is weak. Has a "no Worry FYI" but not "how to install" #2
Name: Ari V Email: defygravity79atyahoodotcom Product: Thunderbird Summary: Installation Guide is weak. Has a "no Worry FYI" but not "how to install" Comments: read / review it for yourself: Installing Thunderbird 2 Please note that installing Thunderbird 2 will overwrite your existing installation of Thunderbird. You won't lose any of your mail, but some of your extensions and other add-ons might not work until updates for them are made available. Browser Details: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071204 Ubuntu/7.10 (...

Cannot use persona add-on in 3.6 Beta i. I get this error message:"Personas 1.3.1 could not be installed because it is not compatible with Firefox 3.6b1".
Name: Jonathan Sprague Email: sprag80atgmaildotcom Product: Firefox Release Candidate Summary: Cannot use persona add-on in 3.6 Beta i. I get this error message:"Personas 1.3.1 could not be installed because it is not compatible with Firefox 3.6b1". Comments: I have Windows 7. Personas 1.3.1.does not add-on to my system. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1 (.NET CLR 3.5.30729) From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback bu...

"error occurred during installation -Navigator:5 " message during install
unable to install seamonkey need to retrieve an important email from prev un-installed version of seamonkey...i cannot even install it now. ...

I couldn't install Visual Studio.Net 2003, while installing an error message "Internal Error is comming"
[DMW: deleted due to the length of the log, and what follows is what's important][09/29/05,14:28:23] Visual Studio .NET Enterprise Architect 2003 - English: ***ERRORLOG EVENT*** : ACTION FAILURE: Action ended 14:28:23: CADpc.D0DF3458_A845_11D3_8D0A_0050046416B9. Return value 3. See MSI log for details.[09/29/05,14:28:23] Visual Studio .NET Enterprise Architect 2003 - English: ***ERRORLOG EVENT*** : ACTION FAILURE: Action ended 14:28:23: INSTALL. Return value 3. See MSI log for details.[09/29/05,14:28:30] Visual Studio .NET Enterprise Architect 2003 - English: MsiInstallProduct return cod...

Delphi 2009 "Check for updates" not working
Hi All, I have just got a new laptop and have only just installed Delphi 2009 onto my machine and have registered it. Now I know there are updates available, however when I run the "Check for updates" tool it says there is nothing to do. The about screen lists no updates as being installed. Any ideas as to what is happening? I am running Windows 7 64bit. Cheers > {quote:title=Tristan Leask wrote:}{quote} > I have just got a new laptop and have only just installed Delphi 2009 onto my machine and have registered it. Now I know there are updates available, however ...

Web resources about - Installing Update 3 on Delphi 2009 giving "insufficient privileges" error - embarcadero.delphi.install

Resources last updated: 1/14/2016 3:15:10 AM