Delphi XE - Programfile is locked after IDE-Run

Hi,

with Delphi XE every time i run a program in the IDE (with oder without 
Debugger) the executable is locked for a few minutes. In this time i 
can't recompile my project. I get the error F2039 - cannot open outputfile.

The installation is on the same machine as my Delphi 2010 - here it 
works without any problem (Win 7 Ultimate).
No VirusScanner is active and every service who can lock the file is 
stopped.

Has Somebody the same problem or an idea?

Thanks

Robert
0
Robert
9/9/2010 7:55:38 PM
embarcadero.delphi.ide 3925 articles. 0 followers. Follow

2 Replies
1288 Views

Similar Articles

[PageSpeed] 57

I have this on D2010.  Each time I run a program I have to build or compile 
twice because it always fails on the first go around.
There is a delay before the file is unlocked.  I thought this was because 
I'm using a shared VM folder for my sources but I don't see any other 
complaints about VM doing this.

The reason I think it's my VM is one, I do not remember this ever occurring 
before I installed VM Workstation, plus, if I execute a file then close it, 
then try to rename or delete it in File Explorer I get access denied.
I can wait a minute or two, or retry to modify the file, or right click and 
make the file Not Read Only.

I'm not sure how other VMware users are getting around this becuase it is a 
royal pain !!!

Richard

"Robert J" <rob@aol.com> wrote in message 
news:284459@forums.embarcadero.com...
> Hi,
>
> with Delphi XE every time i run a program in the IDE (with oder without
> Debugger) the executable is locked for a few minutes. In this time i
> can't recompile my project. I get the error F2039 - cannot open 
> outputfile.
>
> The installation is on the same machine as my Delphi 2010 - here it
> works without any problem (Win 7 Ultimate).
> No VirusScanner is active and every service who can lock the file is
> stopped.
>
> Has Somebody the same problem or an idea?
>
> Thanks
>
> Robert
0
richard
9/10/2010 12:33:34 PM
Robert,
Did you figure anything out?  Are you running in a VM?

Richard
0
richard
9/12/2010 10:04:01 PM
Reply: