virtual keyboard doesn't show in web pages in Android TWebBrowser

A simple FireMonkey mobile app in RAD Studio XE5 Update 2 (Delphi). 
Just a TWebBrowser with a TButton on the same form with this code attached to onClick: WebBrowser1.navigate('http://..<website address>...');

App compiles and runs fine when deployed to iOS device (iPhone 4S). More specifically, when the focus is on an edit field on the web page (e.g. search field), the virtual keyboard shows up to let you type.
App complies and runs fine when deployed to Android device (Motorola G phone Android v4.3). However, when the focus is on an edit field on the web page (e.g. search field), the virtual keyboard does NOT show up.

Any ideas?

thanks.
0
Nasir
12/26/2013 5:41:29 AM
embarcadero.delphi.firemonkey 4901 articles. 4 followers. Follow

5 Replies
1374 Views

Similar Articles

[PageSpeed] 26

> {quote:title=Nasir Noor wrote:}{quote}
> A simple FireMonkey mobile app in RAD Studio XE5 Update 2 (Delphi). 
> Just a TWebBrowser with a TButton on the same form with this code attached to onClick: WebBrowser1.navigate('http://..<website address>...');
> 
> App compiles and runs fine when deployed to iOS device (iPhone 4S). More specifically, when the focus is on an edit field on the web page (e.g. search field), the virtual keyboard shows up to let you type.
> App complies and runs fine when deployed to Android device (Motorola G phone Android v4.3). However, when the focus is on an edit field on the web page (e.g. search field), the virtual keyboard does NOT show up.
> 
> Any ideas?
> 
> thanks.

You can check if the VirtualKeyboardServices is on...

Check also if other control e.g. TEdit or TMemo doesn't display VK as well, check if the component is HitTest := True and if the component has set KeyboardType.

Edited by: Sebastian Kozub on Dec 27, 2013 12:42 AM
0
Sebastian
12/27/2013 8:43:21 AM
> {quote:title=Nasir Noor wrote:}{quote}
> A simple FireMonkey mobile app in RAD Studio XE5 Update 2 (Delphi). 
> Just a TWebBrowser with a TButton on the same form with this code attached to onClick: WebBrowser1.navigate('http://..<website address>...');
> 
> App compiles and runs fine when deployed to iOS device (iPhone 4S). More specifically, when the focus is on an edit field on the web page (e.g. search field), the virtual keyboard shows up to let you type.
> App complies and runs fine when deployed to Android device (Motorola G phone Android v4.3). However, when the focus is on an edit field on the web page (e.g. search field), the virtual keyboard does NOT show up.
> 
> Any ideas?
> 
> thanks.

http://docwiki.embarcadero.com/RADStudio/XE5/en/Release_Notes_for_XE5#WebBrowser_Does_Not_Accept_Keyboard_Input_on_Android
0
Michael
12/27/2013 4:11:41 PM
Hey guys, for the help!

> {quote:title=Michael McFarland wrote:}{quote}
> 
> http://docwiki.embarcadero.com/RADStudio/XE5/en/Release_Notes_for_XE5#WebBrowser_Does_Not_Accept_Keyboard_Input_on_Android
>

This could be the key. Here is what the above linked text says: +On Android devices, the on-screen keyboard is not available in a TWebBrowser control. This means that a user cannot complete a web form, for example. The TWebBrowser control should be used for displaying information or documents. User interaction should be performed with FireMonkey controls.+

So that leads to another question: what is a FireMonkey web browser control then? This link implies that the TWebBrowser is a FireMonkey control: http://docwiki.embarcadero.com/RADStudio/XE5/en/Mobile_Tutorial:_Using_the_Web_Browser_Component_(iOS_and_Android)

What they are really saying in release notes is that only display information using TWebBrowser control and do any user interaction using other FireMonkey controls. OK....how am I supposed to do that if the "user interaction control" (for example: a search box) is embedded in the web page displayed by the TWebBrowser? Does it really mean that TWebBrowser is all be useless for Android development?
0
Nasir
12/28/2013 3:29:24 AM
A TWebBrowser control is actually a native iOS or Android control that floats over the FireMonkey form. On Android it is probably a WebView ( https://developer.android.com/reference/android/webkit/WebView.html ). Adobe AIR has a similar object.

You could put the virtual keyboard inside the TWebBrowser using Javascript like this library:
http://www.greywyvern.com/code/javascript/keyboard

This project may have an expanded web browser control or a native virtual keyboard for Android at some point soon:
http://sourceforge.net/projects/dpfdelphiandroid/

And TMS Software has a component pack that displays some limited HTML tags:
http://www.tmssoftware.com/site/tmsfmxpack.asp
0
Eli
12/29/2013 8:47:24 AM
just seen this tip elsewhere:
webbrowser1.canfocus:=true;
webbrowser1.Navigate(http://www.google.com');
webbrowser1.setfocus;

(note that you will need to set false the canfocus on any tedit on the form
and also the form keyup will not working and the softkey back button does not work
(so you will need to put a close button on the form or at least know when user input into form input in the browser has finished so can unset focus on browser
or similar)
0
Brian
12/31/2013 1:26:46 AM
Reply:

Similar Artilces:

Web page doesn't show master page's contents
 Hi All!I've designed a master page and after that I added a webpage in my project and mentioned its master page at adding time of the web page mean while adding the web page, I checked the "Select master page" check box and then added the web page after specifying the web page but the web page doesn't show any content of the master page. Here is the code of the web page:Start of code________________________________________________________________________<%@ Page Language="VB" MasterPageFile="~/MasterPage.master" AutoEventWireup="false"...

New tabs show the about:newtab page, and doesn't accept the "Don't show this page again" order.
Name: RV Email: riveravaldezatysinembargodotcom Product: Firefox Summary: New tabs show the about:newtab page, and doesn't accept the "Don't show this page again" order. Comments: That. Once and again, of course. Thanks Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.9.1b3) Gecko/20090305 Firefox/3.0.3;MEGAUPLOAD 1.0 (.NET CLR 3.5.30729) From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to se...

superreview granted: [Bug 239535] [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") : [Attachment 15469
Robert O'Callahan <roc@ocallahan.org> has granted Constantine A. Murenin <cnst+bmo@bugmail.mojo.ru>'s request for superreview: Bug 239535: [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") http://bugzilla.mozilla.org/show_bug.cgi?id=239535 Attachment 154694: patch http://bugzilla.mozilla.org/attachment.cgi?id=154694&action=edit ...

superreview requested: [Bug 239535] [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") : [Attachment 154
Constantine A. Murenin <cnst+bmo@bugmail.mojo.ru> has asked Robert O'Callahan <roc@ocallahan.org> for superreview: Bug 239535: [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") http://bugzilla.mozilla.org/show_bug.cgi?id=239535 Attachment 154694: patch http://bugzilla.mozilla.org/attachment.cgi?id=154694&action=edit ...

Can't run local web pages and IIS doesn't not open
If I start my computer without a connection to the Internet,I can't open any pages like "http://localhost/DBMJ/anypage.html"and,I can't open IIS, .. I click on the icon and nothing happens.I ran "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i"but that didn't fix it (it runs forever just showing the  . . . . . . . . . . . . . on the screen).This only happens when there is no Internet connection when I start the computer up.If there is an Internet connection, it works.Anyone know why this is happening?  thanks   check o...

when i go to a page, it doesn't show correctly. i need to reload the page to make it show correctly.
Name: Product: Firefox Release Candidate Summary: when i go to a page, it doesn't show correctly. i need to reload the page to make it show correctly. Comments: sometimes, when i go to a page, at first, it doesn't show correctly. at 1 or more reloads, it shows correctly. please fix it! Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-CL; rv:1.9.2) Gecko/20100105 Firefox/3.6 FBSMTWB From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the se...

my page doesn't show in iis, but fine in web-matrix
Hi just starting out with asp.net. Downloaded webmatrix and followed the gettingstarted guide. When hitting run in webmatrix the page appear just fine. but when trying to do the same in iis nothing is shown accept for the label. no button, no textfield. I've been searching the forum and read som information about running aspnet_regiis so I did. nothing happend. help? XP pro IIS 5.1 downloaded and installed the SDK and the 1.1 framework What was the result of running aspnet_regiis? Was there an error? Did you use the -i option?Stanley Tan theSpoke Blog Had this pro...

background color doesn't show on my web pages in Firefox
Name: Frances Pritchett Email: fp7atcolumbiadotedu Product: Firefox Summary: background color doesn't show on my web pages in Firefox Comments: Dear Firefox, Here's one of my web pages: http://www.columbia.edu/itc/mealac/pritchett/00urdu/hali/majalis/index.html? I have given the page an olive green background color. I know the color is there because it shows up in Internet Explorer. But it doesn't show up in Firefox! thanks for any help you can offer, Fran Pritchett (a non-techie type) Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;...

When exiting a video playing with .wmv, you click the upper right "x" and you don't get back to the web homepage, you get stuck with a white, empty page. Explorer doesn't do that. It's an irritant f
Name: David Morgan Email: Dave_at_NewsCarsonCity.com Product: Firefox Summary: When exiting a video playing with .wmv, you click the upper right "x" and you don't get back to the web homepage, you get stuck with a white, empty page. Explorer doesn't do that. It's an irritant for those of us who want to use Mozilla, period. Comments: See summary. Browser Details: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ...

Custom error page specified in web.config doesn't show up to unauthorized users
Hi There, I am using Windows Authentication and role based authorization for my asp.net website(internal). I have this configured in the web.config <customErrors mode="On" defaultRedirect="Error.aspx" > <error statusCode="403" redirect="Accessdenied.aspx" />   </customErrors> Both Error.aspx and Accessdenied.aspx are at the root level. If a user is not authorized to access a page, the browser(IE and Firefox) keeps on popping up user credentials window and if credentials (which don't have access to a page) are given, the window pops up once again. If I hit cancel...

I don't care if 'The document has moved here', and CAPTCHA doesn't show up
Name: Charles Green Email: CharlesWGreenJrataimdotcom Product: Minefield Summary: I don't care if 'The document has moved here', and CAPTCHA doesn't show up Comments: I've suddenly started to get a lot of screens saying 'The document has moved here' and so forth. I do NOT have 'Warn me when web sites try to redirect or reload the page' checked. Also, the CAPTCHA "Humanness Check" is not shown on the Hendrix page, so I had to use Internet Explorer (gak!) to enter this feedback... Mozilla/5.0 (Windows NT 5.1; rv:2.0b4pre) ...

Simple web parts web page
Hi, I am trying to write a simple web parts web page - I added WebPartManager and a webPartZone to the page. Inside the webpart I  added 3 hyperlinks (that for some reason - the hyperlink are shown in the top part only and not the bottom...??) I chaged the .CS code so at the end I will be able to get into design mode (inside the drop down list item), But it doest work... I keep getting only "browse" in the drop down list.. can someone tell me why? Thank you!!! Here is the code: ======= default.aspx ===================<%@ Page Language="C#" AutoEventWireup=...

Web page which Firefox doesn't recognise as a login page
Name: Stephen Kennedy Email: steveatsdk-softwaredotcom Product: Firefox Summary: Web page which Firefox doesn't recognise as a login page Comments: Firefox 3 RC 1.0 doesn't recognise https://adsl24.co.uk/myaccount.php as a login page, i.e. it doesn't offer to save the username and password for this site. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0 From URL: http://hendrix.mozilla.org/ ...

SeaMonkey's Save Page As. . . doesn't show up.
Name: Aaron Aardvark Product: Firefox Summary: SeaMonkey's Save Page As. . . doesn't show up. Comments: SeaMonkey 1.0.2 for Mac File menu's Save Page As. . . becomes Save Page, so there are no choices, when the Preferences' Download action is changed to Automatically download files to specified download folder. Either of the other two options reverts the File menu's Save Page to Save Page As. . . This is repeatable. This may be, and probably is, a known bug, but the Bugzilla site is impossibly complicated. After searching for two hours, a page dem...

Web resources about - virtual keyboard doesn't show in web pages in Android TWebBrowser - embarcadero.delphi.firemonkey

Resources last updated: 1/2/2016 1:02:15 PM