Use Firemonkey with iOS 6.0.1

My iPad was accidentally updated to iOS 6.0.1.

So, Is it possible to use the latest xcode/iOS 6.0.1  with Firemonkey?

My Mac is 10.7.5 Lion.

Thanks

Jose Carlos.
0
Jose
11/16/2012 2:52:59 PM
embarcadero.delphi.firemonkey 4901 articles. 4 followers. Follow

7 Replies
546 Views

Similar Articles

[PageSpeed] 58

Hi Jose,

I had the same "problem", see http://www.bobswart.nl/Weblog/Blog.aspx?RootId=5:5536

Cheers!
0
Michiel
11/16/2012 3:48:41 PM
> {quote:title=Michiel van Ingen wrote:}{quote}
> Hi Jose,
> 
> I had the same "problem", see http://www.bobswart.nl/Weblog/Blog.aspx?RootId=5:5536
> 
> Cheers!

Hi Michiel,

I followed this blog, and now iOS 6.0 is available on Xcode but I have two issues:

 When I run the application on the simulator 6.0 I got this:
"2012-11-16 16:31:53.672 AbsolutIPad[16580:11303] Application windows are expected to have a root view controller at the end of application launch"

 When I try to run on device, it don't show my iPad as before and I got this:
"No provisioned iOS devices are available with a compatible iOS version. Connect an iOS device with a recent enough version of iOS to run your application or choose an iOS simulator as the destination."

On the Xcode it shows iOS 6.0 SDK as target, my iPad is iOS 6.0.1 (10A523), the iOS SDK from the Xcode 4.5 is 6.0 (10A403).

Thanks,

Jose Carlos.
0
jose
11/16/2012 6:44:14 PM
> {quote:title=Michiel van Ingen wrote:}{quote}
> Hi Jose,
> 
> I had the same "problem", see http://www.bobswart.nl/Weblog/Blog.aspx?RootId=5:5536
> 
> Cheers!

 It is working, I did two more things, I copied the version.plist to the Xcode and I update my iPad on the Organizer.

I am using Xcode 4.3.2 because I prefer this version, it is easier create an adhoc.

 Everything working ( Xcode 4.3.2, iOS 6.0 and FMX ).

 Thank you so much Michiel

 Jose Carlos.
0
jose
11/16/2012 9:18:43 PM
> {quote:title=jose carlos cunhajr wrote:}{quote}
> > {quote:title=Michiel van Ingen wrote:}{quote}
> > Hi Jose,
> > 
> > I had the same "problem", see http://www.bobswart.nl/Weblog/Blog.aspx?RootId=5:5536
> > 
> > Cheers!
> 
>  It is working, I did two more things, I copied the version.plist to the Xcode and I update my iPad on the Organizer.
> 
> I am using Xcode 4.3.2 because I prefer this version, it is easier create an adhoc.
> 
>  Everything working ( Xcode 4.3.2, iOS 6.0 and FMX ).
> 
>  Thank you so much Michiel
> 
>  Jose Carlos.

Hi Jose,

Glad to be able to help!

The problem with the root view controller is solved by modifying FMX_iOS_Platform.pas:

procedure ApplicationDelegate.applicationDidFinishLaunching(notification: UIApplication);
begin
  { create window }
  mainWindow := TUIWindow.alloc.initWithFrame(UIScreen.mainScreen.bounds);
  mainWindow.setAutoresizesSubviews(True);
  //mainWindow.makeKeyAndVisible;
  
  { }
  
  mainWindow.mainView := UIView.alloc.initWithFrame(CGRectMake(0, 20, mainWindow.bounds.size.Width, mainWindow.bounds.size.Height - 20));
  mainWindow.mainView.setAutoresizesSubviews(True);
  mainWindow.mainView.setOpaque(True);
  
  mainWindow.mainController := TUIViewController.alloc.initWithNibName_bundle(nil, nil);
  mainWindow.mainController.setView(mainWindow.mainView);
  mainWindow.AddSubView(mainWindow.mainView);
  
  // Solve problem with message of not having a root view controller
  mainWindow.setRootViewController(mainWindow.MainController);

  { }
  
  mainWindow.makeKeyAndVisible;

  Application.RealCreateForms;
  UIDevice.currentDevice.beginGeneratingDeviceOrientationNotifications;
end;

Cheers,
Michiel
0
Michiel
11/16/2012 10:03:28 PM
Hello

At this moment I have XCode 4.2 installed in my OSX Lion, but that version can´t deploy in a device with iOS higher than 5.0. What I read in the web is that FMX for iOS won´t run with XCode higher that 4.2, but it seems you got it to work. Is there any particular care that I have to take, besides what was discussed in this thread?

I plan to upgrade XCode 4.2 to 4.3 ou 4.5. What could you advise me about that?

Thanks in advance!!!
0
Utf
11/19/2012 7:29:53 PM
> {quote:title=Alex Constâncio wrote:}{quote}
> Hello
> 
> At this moment I have XCode 4.2 installed in my OSX Lion, but that version can´t deploy in a device with iOS higher than 5.0. What I read in the web is that FMX for iOS won´t run with XCode higher that 4.2, but it seems you got it to work. Is there any particular care that I have to take, besides what was discussed in this thread?
> 
> I plan to upgrade XCode 4.2 to 4.3 ou 4.5. What could you advise me about that?
> 
> Thanks in advance!!!

Hi,

If you applied the latest Firemonkey hotfix (4), you should be running fpc version 2.6.0 (check your build script in Xcode, somthing like .../fpc/2.6.0/), FMX _does not install_ on Xcode higher then 4.2, but if you already have it installed,
you can also install higher versions of Xcode, just say no when Xcode asks you to uninstall the old version when you install the new version, I actually have 3 versions of Xcode running. If you have a developer account at Apple, you can
download any version of Xcode you want, newer version don't really install, they are images you can mount. I mounted the image, and then copied the Xcode file (Xcode.app) to the applications directory on my Mac (new folder, named it to
Xcode4.5.1). You then start Xcode and open your project, with Xcode 4.5.1 you can even deploy to a iphone/ipad running ios6 (apps build against ios 5.1 sdk run fine on ios6). In fact the way your project is compiled and linked doesn't really
change by different versions of Xcode, fpc is used for that, newer versions of Xcode (for us) are just needed because older versions of Xcode do not recognize devices running a newer ios. This is one way to do it, you can also follow the instructions
by Bob Swart that I have posted in my first reply, but it is basically the same, just a matter of what version of Xcode your happy with.

Cheers,
Michiel
0
Michiel
11/20/2012 8:48:54 AM
Hello Michiel

Thank you so much, for you very detailed explanation! It will really help me!

Best regards,

Alex
0
Utf
11/20/2012 10:52:57 AM
Reply:

Similar Artilces:

SOS: Sync with Oracle 8.1.6.1.0 using 8.1.6.1.0 ODBC Driver
Help! If any customer has successfully replicated bi-directionally from ASA7 to Oracle 8i (8.1.6) using the Oracle 8.1.6 Oracle ODBC Driver, we would appreciate any insight you may have concerning the small number of steps involved in implementing replication. I may be contacted directly at (206) 933-4956. Martin Douglas Senior Data Architect e-Commerce Group Food Services of America Please always specify the version and MORE importantly the BUILD number of ASA you are using with each post. If you are having problems with this Oracle driver, some of our customers hav...

ANN: TMS iCL: 100% native iOS components for FireMonkey applications, v2.1.0.0 released
A significant update for TMS iCL has been released with a powerful new native PDF generation functionality! Set of native iOS components for FireMonkey applications for iPhone, iPad, iPod. No compromises: 100% iOS performance, 100% iOS look & feel! What's new in v2.1: ------------------------- - New : Rich text processing lib - New : Non-visual PDF rendering lib component - New : Graphics rendering lib - Improved : TTMSFMXNativeUIRichTextView updated to use separate rich text processing lib You can download the fully functional trial version for Delphi XE4, XE5 from...

superreview requested: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Chase Phillips <chase@mozilla.org> has asked David Baron <dbaron@mozillafoundation.org> for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

superreview granted: [Bug 300819] Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 : [Attachment 189342] Bump Fx version to 1.0.6, GRE to 1.7.10
Brian Ryner <bryner@brianryner.com> has granted Chase Phillips <chase@mozilla.org>'s request for superreview: Bug 300819: Bump Firefox version on aviary1.0.1 branch to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/show_bug.cgi?id=300819 Attachment 189342: Bump Fx version to 1.0.6, GRE to 1.7.10 https://bugzilla.mozilla.org/attachment.cgi?id=189342&action=edit ...

[ID 20000315.010] OK: perl v5.6.0 +v5.6.0-RC2 on cygwin 1.1.0(0.1832)
This is a success report for perl from fifere@SIL2036, generated with the help of perlbug 1.27 running under perl v5.6.0. Perl reported to build OK on this system. --- This perlbug was built using Perl v5.6.0 - Wed Mar 15 10:13:08 GMT 2000 It is being executed now by Perl v5.6.0 - Wed Mar 15 13:04:46 GMT 2000. Site configuration information for perl v5.6.0: Configured by FiferE at Wed Mar 15 13:04:46 GMT 2000. Summary of my perl5 (revision 5.0 version 6 subversion 0) configuration: Platform: osname=cygwin, osvers=1.1.0(0.1832), archname=cygwin uname='cygwin_...

[ID 20000321.022] OK: perl v5.6.0 +v5.6.0-RC3 on cygwin 1.1.0(0.1832)
This is a success report for perl from fifere@SIL2036, generated with the help of perlbug 1.28 running under perl v5.6.0. Perl reported to build OK on this system. --- Flags: category=core severity=low --- Site configuration information for perl v5.6.0: Configured by FiferE at Tue Mar 21 14:50:41 GMT 2000. Summary of my perl5 (revision 5.0 version 6 subversion 0) configuration: Platform: osname=cygwin, osvers=1.1.0(0.1832), archname=cygwin uname='cygwin_nt-4.0 sil2036 1.1.0(0.1832) 2000-03-20 15:32:58 i686 unknown ' config_args='-d' ...

superreview requested: [Bug 300820] Bump Thunderbird version on aviary1.0.1 branch to 1.0.6 : [Attachment 189343] Bump Tb version to 1.0.6
Chase Phillips <chase@mozilla.org> has asked David Baron <dbaron@mozillafoundation.org> for superreview: Bug 300820: Bump Thunderbird version on aviary1.0.1 branch to 1.0.6 https://bugzilla.mozilla.org/show_bug.cgi?id=300820 Attachment 189343: Bump Tb version to 1.0.6 https://bugzilla.mozilla.org/attachment.cgi?id=189343&action=edit ...

superreview granted: [Bug 300820] Bump Thunderbird version on aviary1.0.1 branch to 1.0.6 : [Attachment 189343] Bump Tb version to 1.0.6
Brian Ryner <bryner@brianryner.com> has granted Chase Phillips <chase@mozilla.org>'s request for superreview: Bug 300820: Bump Thunderbird version on aviary1.0.1 branch to 1.0.6 https://bugzilla.mozilla.org/show_bug.cgi?id=300820 Attachment 189343: Bump Tb version to 1.0.6 https://bugzilla.mozilla.org/attachment.cgi?id=189343&action=edit ...

Install 1.0 and 1.1 side-by-side and use the 1.1 csc to compile a 1.0
Hi, I have the following (tricky) questions: 1. Can I install the 1.0 and 1.1 .NET Framework side-by-side with NO drawbacks on MY PC where I develop the .NET applications? (I do NOT use VS.NET) 2. After installing the 1.1 version, am I STILL ABLE to compile a 1.0 version, since our production web-server still runs on 1.0 (our development web-server was upgraded to 1.1) ?? thx Eau .... as long as you compile DLLs with the right csc.exe/vbc.exe from 1.0 or 1.1 Free ASP.NET Version Switcher may interest you.DNN skins ForumTressleworks modulesDNN & webhostingIEWCtrls...

kdesvn 1.0.5 or 1.0.6 for KDE 3.5 subversion 1.6.3?
Installed: Code: -------------------- Subversion 1.6.3-1.1 KDE 3.5.10 -------------------- I upgraded subversion to 1.6.3, and wanted to make sure I had the latest kdesvn for KDE 3.5 and subversion 1.6.3. I went to kdesvn support site but it wasn't clear if 1.0.5 was sufficient for subversion 1.6, so I downloaded kdesvn 1.0.6 and built it myself (previously 1.0.5 had come from opensuse). Everything looked okay, but... When I click on the Help | Info about kdesvn part I see: Code: -------------------- Built with subversion library 1.4.4 Running ...

Faulting application grpwise.exe, version 6.0.1.0, faulting module grpwise.exe, version 6.0.1.0, fault address 0x0000ff90.
The above subject line and below is the error I can see from the event viewer on the XP workstation of one of my users when trying to login to GroupWise with the GroupWise Client32. She can access our GroupWise6 server through WebAccess and through an old Citrix server we have running the GroupWise5 client. I can not figure out why the GW Client32 will not allow access. "Faulting application grpwise.exe, version 6.0.1.0, faulting module grpwise.exe, version 6.0.1.0, fault address 0x0000ff90." I found this Novell TID#10076201 to be the closest thing to the problem I ...

ANN: FireDataGrid 1.0 beta 3 for Delphi XE6 (Firemonkey) has been released! [Edit]
Dear colleagues, we are pleased to announce that version FireDataGrid 1.0 beta 3 for Delphi XE6 (Firemonkey) has been released. Version is quite stable and can be considered as a release candidate. This demo version adds two examples. MultiSelectDemo - demonstrates the ability to work in several selection modes (single row, multiple rows, single cell many cells, selection with rubber band and etc.). CustomEditorDemo - demonstrates the ability to embed custom cell editor to the grid view. In the example are being reviewed two options of the editors, based on embedded TControl and direct int...

ANN: InfoPower FireMonkey 2.0.1.6 Release (Free for a limited time)
Woll2Woll Software announces an update to its InfoPower FireMonkey library supporting RAD Studio XE5. This component suite features our FireMonkey datagrid component which is remarkably fast and poweful on all platforms, and enables developers to leverage their existing database investment to the mobile world. It supports all supported XE5 platforms including Win32, Win64, Android, iOS, and OSX32. It is also designed to be aesthetically pleasing to the end-user in style, intuitive feel, performance, and ease of use, all while maintaining the Delphi RAD (Rapid application Devel...

superreview granted: [Bug 283181] installer version text needs to be upgraded from 1.0 to 1.0.1 : [Attachment 175188] Bump version in installers to 1.0.1/1.7.6
Ben Goodger <bugs@bengoodger.com> has granted Chase Phillips <cmp@mozilla.org>'s request for superreview: Bug 283181: installer version text needs to be upgraded from 1.0 to 1.0.1 https://bugzilla.mozilla.org/show_bug.cgi?id=283181 Attachment 175188: Bump version in installers to 1.0.1/1.7.6 https://bugzilla.mozilla.org/attachment.cgi?id=175188&action=edit ...

Web resources about - Use Firemonkey with iOS 6.0.1 - embarcadero.delphi.firemonkey

Firemonkeys - GamesIndustry International
The world's leading games industry website. Get insight from todays industry leaders with news, interviews and analysis of global gaming trends. ...

Firemonkey’s Real Racing 3 To Launch At The End Of February
In September, Apple demoed Firemonkey’s Real Racing 3 at the iPhone 5 event . Three months later and the game has yet to show up in the App Store. ...

EA Games and Firemonkey Bringing Real Racing 3 to Android, Fasten your Seat Belts
Start up your engines race fans, EA Games is teaming up with Firemonkey to bring Real Racing 3 to mobile devices. If you’re a fan of more realistic ...

EA's Firemint and IronMonkey Studios Merge to Become FireMonkeys
... game development studios into one mega-studio in Australia. Firemint and IronMonkeys will be merged into a single studio now known as Firemonkeys ...

News: Firemonkeys announces Real Racing 3
Firemonkeys, a new gaming subsidiary of Electronic Arts born from the merger of FireMint and IronMonkey, has announced the coming release of ...

firemonkeys - iMore
EA has pushed out another impressive update to its equally impressive iOS racer, Real Racing 3, that for the first time brings cars from Ferrari ...

Firemonkeys on Real Racing 3 going free-to-play
... got a hands-on preview of Real Racing 3. We also spoke with Ptolemy Oberin, one of the game’s programmers and project lead at developer Firemonkeys, ...

Real Racing 3 coming in 2012 from Firemonkeys
The first game from recently merged developer Firemonkeys is Real Racing 3 , the developer revealed moments ago during EA's Summer Showcase event ...

Firemonkeys Previews Real Racing 3 for iPhone and iPad
Firemonkeys, the new combined studio from EA combining the IronMonkey and Firemint gaming studios, has announced the development of Real Racing ...

EA Mobile Moves: IronMonkey & Firemint Merge Into “Firemonkeys,” Now Have 50M Players Between
... that it is merging two top mobile game studios, IronMonkey and Firemint , which will fittingly combine to create a new company, called Firemonkeys. ...

Resources last updated: 1/13/2016 12:20:21 AM