Delphi X5 Android App Deployment

Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?
0
Utf
9/12/2013 9:30:05 PM
embarcadero.delphi.deployment 422 articles. 0 followers. Follow

11 Replies
2045 Views

Similar Articles

[PageSpeed] 20

> {quote:title=Jeff Overcash (TeamB) wrote:}{quote}
> Sérgio Francisco wrote:
> > Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?
> 
> You might have to give it 30-60 seconds to fully deploy.  I found on my Galaxy 
> Tab 2 that deploying through usb was often very slow.
> 
> -- 
> Jeff Overcash (TeamB)
>        (Please do not email me directly unless  asked. Thank You)
> And so I patrol in the valley of the shadow of the tricolor
> I must fear evil. For I am but mortal and mortals can only die.
> Asking questions, pleading answers from the nameless
> faceless watchers that stalk the carpeted  corridors of Whitehall.
>               (Fish)


I gave a lot of time... not working not a simple or a demo... somethissng is not ok.
0
Utf
12/28/2012 4:31:32 PM
Sérgio Francisco wrote:
> Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?

You might have to give it 30-60 seconds to fully deploy.  I found on my Galaxy 
Tab 2 that deploying through usb was often very slow.

-- 
Jeff Overcash (TeamB)
       (Please do not email me directly unless  asked. Thank You)
And so I patrol in the valley of the shadow of the tricolor
I must fear evil. For I am but mortal and mortals can only die.
Asking questions, pleading answers from the nameless
faceless watchers that stalk the carpeted  corridors of Whitehall.
              (Fish)
0
Jeff
9/12/2013 10:48:59 PM
> {quote:title=Sérgio Francisco wrote:}{quote}
> Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?


So i tried with all demos and with a X45 laser , samsung Y, the emulator and does the same ... but the app respond to touch and play sounds.. so i suppose it doesnt show firemonkey only ?  Im doing something wrong(i suppose not,i have installed clean every thing from install) or is a bug ?

Edited by: Sérgio Francisco on Sep 12, 2013 4:57 PM
0
Utf
9/12/2013 11:58:32 PM
I also tested the new delphi android capabilities.
I use Android Overmax device.
I have a white screen is is all demo run.
If touch the screen the keyboard pops up, but see the white screen.


> {quote:title=Sérgio Francisco wrote:}{quote}
> Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?
0
Peter
9/13/2013 5:50:06 PM
> {quote:title=Sérgio Francisco wrote:}{quote}
> Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?


So can someone help ... i cant set delphi working with adroid,
0
Utf
9/15/2013 12:34:20 PM
> {quote:title=Sérgio Francisco wrote:}{quote}
> So i tried with all demos and with a X45 laser , samsung Y

I do not know what is X45, maybe Micromax?
But Samsung Y I see it is ARMv6.

Minimum requirement is:
-ARMv7 with NEON suport
-Android 2.3.3

You can check your device with:
https://play.google.com/store/apps/details?id=com.ss.syscheck
or
https://play.google.com/store/apps/details?id=com.Bfield.CpuIdentifier

Best Regards,
Cristian Peta
0
Cristian
9/15/2013 2:31:15 PM
> {quote:title=Sérgio Francisco wrote:}{quote}
> Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?


So it worked on a sony walkman, but i have a laser x45 is a arm cortex a9 i think is a armv7 witn neon and andoroid >4  and it still a blank screen. So whats wrong  i have to buy only nexus ????
0
Utf
9/16/2013 11:20:24 AM
> {quote:title=Sérgio Francisco wrote:}{quote}
>...i think is a armv7 witn neon

You think....
For Cortex A9, NEON support is optional. You need to check to be sure. You can try with SysCheck.

Best Regards,
Cristian Peta
0
Cristian
9/16/2013 11:41:50 AM
> {quote:title=Cristian Peta wrote:}{quote}
> > {quote:title=Sérgio Francisco wrote:}{quote}
> >...i think is a armv7 witn neon
> 
> You think....
> For Cortex A9, NEON support is optional. You need to check to be sure. You can try with SysCheck.
> 
> Best Regards,
> Cristian Peta


It says neon capable with CPU Identifier and android version 404
0
Utf
9/16/2013 8:03:29 PM
> {quote:title=Sérgio Francisco wrote:}{quote}
> Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?


I tried it with Galaxy Tab3 and doesnt work , it have neon is armv7 android 4
0
Utf
9/18/2013 8:51:30 AM
> {quote:title=Sérgio Francisco wrote:}{quote}
> Ive started an new app as firemonkey mobile add a button to it selected the device on the android device list, ran the program and it deploys app to android but is a white blank screen with no button. Something isnt right ? Error or i have to do anything else ?

i have same problem
did you find out what cost this problem?
Necmetdin Karademir
0
Necmetdin
3/13/2014 1:15:08 PM
Reply: