Trying to upgrade Indy10, E2202 Required package 'rtl' not found

Hi

I open   IndySystem120.dpk  It tells me that it will upgrade
 from 2007 I say ok.

In project manager I now have IndySystem120 bpl I right-click that
and chose compile, but I get a fatal error:

[DCC Fatal Error] IndySystem120.dpk(30): E2202 Required package 'rtl' not found

$(BDS)\lib;$(BDSUSERDIR)\Imports;$(BDS)\Imports;
$(BDS)\Lib\Indy10;$(BDSCOMMONDIR)\Dcp;

Is the first part of the search path I can see when I want to add a file
and I know that rtl.dcp is in $(BDS)\lib

This is in my registry:
[HKEY_LOCAL_MACHINE\SOFTWARE\CodeGear\BDS\6.0]
"RootDir"="H:\\CodeGear\\"

And that is the correct root directory.

I tried removing the rtl.dcp from the Requires list and add it again
by browsing to it, but that didn't help

Any idea what I can do ???

Thanks in advance.
Best regards
Asger-P
0
Asger
8/31/2011 9:49:48 AM
embarcadero.cppbuilder.socket 566 articles. 0 followers. Follow

3 Replies
2158 Views

Similar Articles

[PageSpeed] 25

"Asger Joergensen" <junk@asger-p.dk> wrote in message 
news:393820@forums.embarcadero.com...

> I open   IndySystem120.dpk  It tells me that it will upgrade
> from 2007 I say ok.

Then you are opening the wrong package.  Indy has separate .dpk files for 
each Delphi version.  You need to use the one that is meant for your 
particular version of Delphi (which is what exactly?).

-- 
Remy Lebeau (TeamB)
0
Remy
8/31/2011 4:36:54 PM
Hi Remy Lebeau

On the: 31. of august-2011 At: 18:36 Remy Lebeau wrote:

> "Asger Joergensen" <junk@asger-p.dk> wrote in message
> news:393820@forums.embarcadero.com...
>
>> I open   IndySystem120.dpk  It tells me that it will upgrade
>> from 2007 I say ok.
>
> Then you are opening the wrong package.  Indy has separate .dpk files for
> each Delphi version.  You need to use the one that is meant for your
> particular version of Delphi (which is what exactly?).

RAD Studio 2009


Best regards
Asger-P
0
Asger
8/31/2011 4:40:18 PM
"Asger Joergensen" <junk@asger-p.dk> wrote in message 
news:393970@forums.embarcadero.com...

> RAD Studio 2009

120 is the correct package for RS2009 (unless you are using a really old 
version of Indy 10, then use 130 instead), so you should not have gotten an 
upgrade warning.  But RTL is indeed a required Package, and it is a core 
package of the IDe, so you should not have gotten a "not found error unless 
your IDE's search paths are not configured correctly.

-- 
Remy Lebeau (TeamB)
0
Remy
9/3/2011 6:33:35 AM
Reply:

Similar Artilces:

"E2202 Required package 'rtl' not found" Error with XE2.
So I installed XE2, and all of the 3rd party component automated installs worked fine. But when I try to manually install other 3rd party components (that don't have an automated installer), I get the "E2202 Required package 'rtl' not found" error. I have tried uninstalling XE2, reinstalling, repairing, modifying, etc. but still get the same error message. Any ideas? Steve Problem solved. I found that the following paths were missing from the library path: * d:\delphixe2\lib\win32\debug * d:\delphixe2\lib\win32\release * d:\delphixe2\lib\win64\debug * d:...

E2202 Required package 'rtl' not found -- D2009 can you help please
Have reinstalled D2009 on a fresh PC after hard disk failure and now cannot compile any package at all, always get the above error message. Feel stupid as I've been programing in Turbo Pascal, Borland Pascal and Delphi every day apart from holidays since the mid 80s but cannot think what to do and cannot find out via the Help. I have tried putting "C:\Program Files\CodeGear\RAD Studio\6.0\lib" into Environment Options | Delphi Options | Library- Win32 | DCP output directory, to no avail. Any help mighty welcome! Thanks -- Mike > {quote:title=Michael Scott wrote:}{quote} &...

E2202 Required package 'designide' not found
I am trying to import into XE5 an ActiveX control previously used in D6. When the .bpl is installed the build fails and the message ' [dcc32] E2202 Required package 'designide' not found' is displayed. Any ideas? Phil Sanfilippo wrote: > I am trying to import into XE5 an ActiveX control previously used in D6. When the .bpl is installed the build fails and the message ' [dcc32] E2202 Required package 'designide' not found' is displayed. Any ideas? The D6 code is incorrectly pulling in design time code. You need to segregate the design time code in...

Error E2202 Required Package 'vcl50' not found
Hi, the problem is with DELPHI XE im trying to install the component IBOQUERY with the package IBO40ART.dpk but when i did COMPILE, pop the error. i work with delphi 2007 and i installed a lot of packages and components and is so easy but in DELPHI XE is a big deal ... how can i install the vcl50 to install the compent ... or where i can downloaded ... thx for your time. Miguel Guzman wrote: > Hi, the problem is with DELPHI XE im trying to install the component > IBOQUERY with the package IBO40ART.dpk but when i did COMPILE, pop > the error. i work with delphi 2007 and i instal...

[DCC Fatal Error] E2202 Required package 'Vcl50' not found
I am trying to compile a project that was coded in Delphi 5 using Delphi XE. I get that error even though I select "Build with runtime packages" which includes Vcl50. Karthik K wrote: > I am trying to compile a project that was coded in Delphi 5 using > Delphi XE. I get that error even though I select "Build with runtime > packages" which includes Vcl50. A project compiled in XE should be using the current VCL package, not vcl50.bpl which only works with Delphi 5. -- -Mike (TeamB) On 6/11/2010 7:17 AM, Karthik K wrote: > I am trying to compile...

''''''''''''''''''''
Name: haznen Email: haznenatyahoodotcom Product: Gran Paradiso Alpha 8 Summary: '''''''''''''''''''' Comments: '''''''''''''''''''''''''''''''''''' Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061204 UGES/1.7.2.0 GranParadiso/3.0a1 From URL: http://www.mozilla.org/projects/granparadiso/ Note to readers: Hendrix gives...

XE5/7 Fatal Error E2202 Required package 'IPIndyImpl' not found
This compile time error (Fatal Error E2202 Required package 'IPIndyImpl' not found) occurs only in XE6/7 (Enterprise) but not in XE2. I've looked over all the code and there all no calls to Indy components (nor to any Web-related components/methods/properties). How can I go about tracing the source of this error? Thank you, Larry X ...

'''''
Name: mario Email: ramar17atfastwebnetdotit Product: Gran Paradiso Alpha 2 Summary: ''''' Comments: K: Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2) Gecko/20070206 GranParadiso/3.0a2 ...

'use' and 'require'
------_=_NextPart_001_01C35AB9.4ADA5CA0 Content-Type: text/plain Hello all, Is there a way to 'variablize' the version for a 'use' statement. This way, if I wanted to change version I could only change it in one place with those changes cascading across all apps. Usage would look something like this: use $perl_version; Thanks in advance, Jason Allison Principal Engineer ARINC Incorporated Office: (410) 266-2006 FAX: (410) 573-3026 ------_=_NextPart_001_01C35AB9.4ADA5CA0-- Allison, Jason (JALLISON) wrote: > Hello all, > > Is there ...

Method 'send' not found for invocant of class 'IO::Socket::INET'
--089e0102ef549874460520a3c043 Content-Type: text/plain; charset=UTF-8 In the cloned repository of Bailador I ran perl6 examples/app.pl It launched the web server printing Entering the development dance floor: http://0.0.0.0:3000 [2015-09-26T10:04:46Z] Started HTTP server. but when I tried to access it with a browser it crashed with: [2015-09-26T10:04:49Z] GET / HTTP/1.1 Method 'send' not found for invocant of class 'IO::Socket::INET' in method run at /Users/gabor/rakudo-star-2015.09/install/share/perl6/lib/HTTP/Easy.pm6:193 in sub baile at /Users/ga...

Error 2202: Required package 'VCL' not found
I get this error in Delphi XE6 when I try to build an old package based on the VCL. I put the VCL source folder into my library path but that did not help. I did not have the right folder listed in the library path. Problem fixed. ...

'do' won't 'do' if '/'
Greetings to All from Au, Have a NetWare Perl 5.8.4 and wanted to tweak File\Spec\NW.pm to try and standardise on '/' separators. If I run a test script (t/uni/lower.t) with an unmodified NW.pm, it calls t/uni/case.pl, that, in case.pl, (when the path separators are '\'), the $file is '..\lib\unicore\To\Lower.pl' and the following code portion works, with $simple getting a returned table: sub casetest { my ($base, $spec, $func) = @_; my $file = File::Spec->catfile(File::Spec->catdir(File::Spec->updir, "lib", &qu...

'Install' button should be 'Upgrade' when upgrading
I've been meaning to file a bug report ever since I started upgrading by installing over the top of the old version, which hasn't been very long (I used to uninstall the old version first). Found out this bug was reported almost 4 years ago. It is just an extremely minor/cosmetic bug, maybe someone can finally fix it? https://bugzilla.mozilla.org/show_bug.cgi?id=689057 ...

the meaning of 'try' and why not only 'begin'...
Hello, One of the things I love of Delphi (and object pascal in general) is the readibility and the 'synthetic elegance' to do something, where other programming languages are spigolous and verbose. In this way many times I asked why 'exists' try...except clause, in particular the use of 'try', instead using simply pascal begin of a block: 'begin'. I mean, much code would be synthtetic but still readible in a such way: {code} begin ... [except,finally] ... end; {code} instead of: {code} begin ... try ...

Web resources about - Trying to upgrade Indy10, E2202 Required package 'rtl' not found - embarcadero.cppbuilder.socket

Resources last updated: 1/18/2016 4:49:28 PM