Question .NET 2.0 Webservices compatibility issue with .NET 1.1 Client

 Hi all,

I have a web service that has been created in .NET 2.0 which returns a custom type 'trading addresses' which is based on a generic list containing trade address objects.

Now I have called this web method from my .NET 1.1 client, and it seems I have a collection of type TradingAddresses. I am just wondering what exactly my type TradingAddresses is if it was a core Generic List in .NET 2.0. What do Generic list collections get converted to in .NET 1.1 when the wsdl is created?

(also, some fields in the TradeAddress class are Nullable types, which is a .NET 2.0 only type, what happens to this type in a .NET 1.1 proxy class?

Thanks in advance

0
Tryst
6/25/2008 10:45:46 PM
asp.net.xml-web-services 7071 articles. 0 followers. Follow

2 Replies
1058 Views

Similar Articles

[PageSpeed] 11

It may have a perfomance improvement of web service from .NET 1.1 to .NET 2.0, but we can migrate code between them easily, so proxy class generated by any of them will fit the requirement.


Richard Tsuei (Chikun Cui)
Contact me via E-mail: ricktsuei@gmail.com
Weblog: http://ricktsuei.cnblogs.com
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Please remember to click “Mark as Answer”, if it is solution to your Problem
0
ricktsuei
6/25/2008 11:35:04 PM

 Thanks for the reply,

so any incompatible types between NET 2.0 down to 1.1 will be handle by the WSDL to bring it in line with a similar type against that framework?

Thanks

0
Tryst
6/26/2008 9:47:48 AM
Reply:

Similar Artilces:

Differences between .net 1, .net 1.1, .net 2.0 and .net 3.0 #2
Hi, This seems to be a common question, but i havent got an answer yet:(Can, any one please explain me the differences between these versions.If you keep your feet firmly on the ground, you'll have trouble putting on your pants! There are too many differences for one email - - from 1.0 to 1.1 (not a whole lot of real change, other than fixes, at least compared to 1.1 to 2.0) With 2.0, there were many new declarative controls, with many new ideas added in With 3.0, it's a superset of 2.0 - instead of replacing the installation completely, it just 'added on' new functionality - I would...

Differences between .net 1, .net 1.1, .net 2.0 and .net 3.0
Hi, This seems to be a common question, but i havent got an answer yet:(Can, any one please explain me the differences between these versions.If you keep your feet firmly on the ground, you'll have trouble putting on your pants! Have a look into this links http://en.wikipedia.org/wiki/.NET_Framework http://blogs.msdn.com/mohammadakif/archive/2006/12/03/net-3-0-different-versions-of-the-net-framework.aspx http://www.codeproject.com/aspnet/ComparisonASP1xASP20.aspAshok Rajawww.iGold.inDon't forget to click "Mark as Answer" on the post that helped you. This credits that m...

Issue with clients consuming a web service that was upgraded from .NET 1.1 to .NET 3.5
I am currently working with an application that was converted from Visual Studio 2003 to Visual Studio 2008 and we are having issues with a client consuming the web service portion of the application.  The web services were written in .NET 1.1 using the Web Services Enhancements 2.0 and was upgraded to use the .NET 3.5 framework.  One of our clients application, which is still written in .NET 1.1 was reference the upgraded web service and tried to consume the web service and received the following error: System.Web.Services.Protocols.SoapException: Se...

Where is the ADO.NET Sybase driver for .NET 1.1 and .Net 2.0?
Hi All Does anyone know where I can get the Sybase drivers for ADO.NET for both versions, 1.1 and 2.0/3.0? Cheers Chris Burrell Hi Chris, There is no release of ASE ADO.NET Provider 2.0 (I assume you refer to ASE provider, not ASA - if ASA please port to sybase.public.sqlanywhere.general). For the 1.1 Provider: It is available in the ASE SDK for windows or the PC Client CDRom included with ASE product. On the SDK its available as 12.5.1 and 15.0 On ASE PC Client I think 12.5.1 is part of ASE 12.5.X and 15.0 is part of ASE 15.X 2.0 provider should release som...

.net 2.0 to .net 1.1
Hello , This is shrirang. Currently i am working .net2.0 web application. but the same application is runing on production in .net 1.1 freamwork . we are not using any new feature of 2.0 in our application . can i run build of 2.0 on 1.1 freamwork . if yes can you  please tell me necessary steps to achive it .     Thanks in advance for your kind help     Regards Shrirang i think it is not possible to run the 2.0 application in 1.1 , so try to change to the frame work in the production server . ThanksRaja Ragothaman Hi Shrirang, Please contact web adm...

having .net 1.1 and .net 2.0
Was just wondering if you someone could tell me the ramifications of the following:  I have .net 2.0 but did not uninstally .net 1.1, i have visual studio 2003, and visual web developer installed on the computer as well as sql server 2000.  my question is whether that is a problem having the two runtimes installed at the same time?  i did this because i wanted to use VWD but keep vs 2003 in case i needed to do any development for work....any comments are appreciated.  --jpIf my post is helpful please mark as answerRegards -- jp(http://www.rzrsolutions.com/rzrWeb20/...

Making a .NET 1.1 Web Project .NET 2.0 enabled
We were able to use such things as  below in the InstantASP forum source code.  I'm trying to do the same with Presstopia but it errors out when putting the below in their web.config. <machineKey validationKey="..." decryptionKey="..." validation="SHA1" decryption="3DES" />So what did InstantASP have to do to make their 1.1 code able to use machinekey then if it's not a .NET 2.0 application?  I want to do the same for Presstopia.   I figure there are general things you can do to allow a 1.1 app to make it able to ...

Sharing cookie between .NET 1.1 and .NET 2.0 web app
I have two servers A and B.  A hosts .NET 1.1 web apps, while B hosts .NET 2.0 web apps.  I have a common login page written in .NET 2.0 (thus it's on server B).  In order to share the cookie, I set the machine key attributes (validation and encryption) of all apps to the same keys, and set all .NET 2.0 web apps to use decryption="3DES".  But for some reasons, my .NET 1.1 still cannot read the cookie generated by the .NET 2.0 login page.  Anyone has similar problem before?  Am I missing anything? Thanks. WenWen I am afraid you can only share t...

HELP Running a web-site with .NET 2.0 and NET 1.1
Hi evreybody,  I have a HUGE problem. I running a website that I have just created with ASP .NET 2.0 technology, well within my web site there is an web application that needs to run under V1.1. I'm using IIS 6.0 and I was wondering to see if anybody can help me run my new site, and run that web app at the same time. Basically is two sites within one web directory, the way you acces both sites is by the same link, just one is ROOT/default aspx (V2.0) and the other is Root/webapp/default.aspx (v1.1) can anybody help me... :( THANK you you will have to define them as two separate w...

Upgrade/migration issues from VS2003+.NET 1.1 to VS2005+.NET 2.0
Hi,  Visual Studio is great when everything works well and you don't know what is happening under the hood. However when things don't work it is really frustrating since you just don't know what is going on.  I have a project (a web site) that was originally developed for VS2003 and ASP.NET 1.1. When I loaded this project on VS2005 (and ASP.NET 2.0), VS told me that it will migrate it to the new environment: it did a number of things, generated a migration report and created/moved files under App_code and such directories. I tried this process a number of times b...

Can a .NET 1.1 page execute in a .NET 2.0 web site?
I've got a ASP.NET 1.1 web site to which I would like to add some ASP.NET 2.0 web pages. Could I just change the web site to point to the 2.0 .NET version and still have the .NET 1.1 web pages work so that both versions are in the same web site? Have you some of you approached this? Thanks. The official answer is maybe It's not officially supported, but most ASP.NET 1.1 pages will run fine under ASP.NET 2.0.  Officially you should run the upgrade wizard on your 1.1 pages. This is a  pretty good blog entry.      JamesMy Blog: http://www.wintersfamily.plus.c...

WS-Security with VS.NET 2005 Web Service and .NET 1.1 Client
We ship a webservices client piece into the field which is required to run on the .NET 1.1 version of the framework, this is defined by our business people and cannot change. We would like to work with .NET 2.0 in VS.NET 2005 for the backend Web Service piece. We are able to get the 2 to communicate fine and it is not a problem. The issue now is that we need to introduce security through WS-Security. I have not been able to find much information about interop between the 2 environments and WS-Security and cannot get the security elements to be invoked in VS.NET 2005. Currently we are trying ...

.DLL compiled with .NET 1.1 to be used in Web app done in .NET 2.0
Hi all,If I have a bunch of business objects that where compiled in .NET version 1.1, would it be possible for my ASP.NET (done in .NET 2.0) application to pick up these objects (.dll file) and start to use them?(Would be great if some-one could provide some form of documentation on this)ThanksTryst Hi Tryst, This should work fine.  In general, you can use V1.1 assemblies with V2.0 applications.  The reverse, though, is not true. Hope this helps, Scott ok, cool.ThanksTryst Comparative study on VS .Net 2003 and VS.Net 2005 .Net Framework versions used are ver...

coverting from .net 1.1 to .net 2.0
Hi All, Currently I'm facing a problem.I have an application that is built on ..net 1.1 using Vs2003.Its performance is so slow.So i want to add some partial updates to the page.How can I execute this in .net 1.1.In .net 2.0 we can use Ajaxtools, But .net 1.1 does't support ajaxtools.How to solve thgis problem.From where can I start?Please help me I'm struck in the middle.PLease forward me any sample codes You have. Thank you Hi, Why are you using VS2003. Convert your aplication in 2005/8 and use AJAX. Regards, Shahaji UThanks and Regards,Shahaji Udar.MCTS,Pune,IN...

Web resources about - Question .NET 2.0 Webservices compatibility issue with .NET 1.1 Client - asp.net.xml-web-services

Astrological compatibility - Wikipedia, the free encyclopedia
This article has an unclear citation style . The references used may be made clearer with a different or consistent style of citation , footnoting ...

A Love Test: Compatibility Calculator on the App Store on iTunes
Get A Love Test: Compatibility Calculator on the App Store. See screenshots and ratings, and read customer reviews.

Android Design in Action: Sleep Monitors and Backward Compatibility - YouTube
Join Nick Butcher, Adam Koch and Roman Nurik as they discuss various elements of Android Design. This week, we'll take a look at the sleep monitor ...

Is compatibility in the stars or your gut?
Is compatability in the stars or your gut? Compatibility; we’re obsessed with it. Does this job suit me? Does this apartment meet my needs? Does ...

E3: Xbox One to gain backwards compatibility
Older Xbox games to work with new console, Microsoft has announced at E3 2015 in Las Vegas.

Xbox One finally finds its feet with backwards compatibility, games-focused dashboard
... snappy video game system. On Friday Microsoft began rolling out the biggest software update yet to its Xbox One console, adding backwards compatibility ...

Apple unveils longer, thinner iPhone 5 with Australian 4G LTE compatibility
APPLE has unveiled a longer iPhone with a large 4-inch screen that will work on Australia's 4G LTE networks operated by Telstra and Optus.

Human frailty and masculinity: Mitch Clark shows their compatibility
Raw and unedited, this was a private hell made instantly public.

Sony brings backwards compatibility to PlayStation with Gaikai deal
First and third-party games to be streamed to hardware

Lego teases updated Mindstorms EV3 with new Linux firmware, infrared, and iOS compatibility
... that it will launch an updated Mindstorms EV 3 kit later this year that runs new Linux firmware with out-of-the box iOS and Android compatibility. ...

Resources last updated: 12/29/2015 4:18:58 PM