Sharepoint help! Error msg : "A Web Part or Web Form Control on this Web Part Page cannot be displayed or imported because it is not registered on this site as safe"

hihi,

I have set up a testing virtual server on my local machine.

I installed win server 2003, wss 2.0, sql server 2000, and visual studio .net 2003.

i tried to create a project in C# but when i build it and import the web part (.dwp) into the page, there is this error msg

"A Web Part or Web Form Control on this Web Part Page cannot be displayed or imported because it is not registered on this site as safe"

 I seached most of the sites and they informed that the problem lies in the safe control in web.config

i enter the safe control in web.config but i does not know where to put my simpleWebPart.dwp file. (i cant find any wpcatalog folder in my inetpub, only wpresource)

below is the safe control i added into the web.config file:

<SafeControl Assembly="SimpleWebPart, Version=1.0.0.1, Culture=neutral, PublicKeyToken=ddb2eac06c4607d6" Namespace="MyWebParts" TypeName="*" Safe="True" />

i am using a strong name key too.(Specs.snk)

 Thanks in advance!

hazel

0
hazeltan
1/24/2007 3:25:20 AM
asp.net.vs2002-vs2003 3502 articles. 0 followers. Follow

0 Replies
4064 Views

Similar Articles

[PageSpeed] 26

Reply:

Similar Artilces:

Web part in MOSS not showing in the "Add Web Parts" web page dialog in the nested sites
hey guys,  I created a web part and it seems to work fine ( I followed  the Sahil's article: http://www.codeguru.com/csharp/.net/net_asp/webforms/article.php/c12293__1/)I added the web part using the page:_layouts/NewDwp.aspx located in the profiles site, which is http://ServerName/sites/MySite/then I asked a coworker to try the web part, he went to his profile, click in Site Actions, Edit page, Add a Web Part and he wasn't able to see it in the list, so he needed to go to Site Settings -> Web Parts -> New -> check the web part and click on Populate Gallery. S...

ERROR: "Visual Web Developer does not support opening Sharepoint web sites." HELP
Hi all, I am having trouble opening/creating a web site on a server running sharepoint services.I am opening/creating an ASP.Net website using Visual Studio 2005. I'm on my development machine running Windows XP.The server I am trying to open/create it on is a Windows 2003 server.It is always give me this error: "Visual Web Developer does not support opening Sharepoint web sites. See help for more details".I have read read very old posts about this error, but none of the info was about to solve the problem for me.Would greatly appreciate it if someone could help me with th...

Can "Add Web Reference" if web service deployed to new web site, Can't add ref if deployed to Virt Server under Default web site (Sharepoint)
I have created a web service wich I can deploy successfully to a new IIS Web, but of course I have to set the port to something other than 80 (and I'd rather just use a virtual server under the Default web). If I try to deploy my web service under the Default Web as a new virtual server, and then try to "Add a web Reference" to the service, it fails with a 404: not found error. Notes: WServer 2003 My IIS server is running Sharepoint Portal Server (SPPS)sp2.  VS2005 Any ideas? /Bob C in GRR In Sharepoint Portal Admin I had to add a Path Exclusion.  Took me a whi...

"visual web developer does not support creating web sites on a Sharepoint Web Server"
I get this message when I try to create a web site using VS2005 using HTTP, not the file system. "visual web developer does not support creating web sites on a Sharepoint Web Server". Anyone know how to fix this?  Thanks Added info for the above post:I am running Windows XP locally and simply am trying to create a web site in VS2005 using HTTP.  I am not using Visual Web Developer, nor do I have it installed on my machine.The error message mentions Visual Web Developer, so I wanted to clarify that I'm running VS2005 and not VWD.Thanks This is the third report I've s...

How to change "File System" web site to "HTTP" Web site
I created a new web site as file based "File System". How can I change this same site to "HTTP" based web site. When createing a new website notice the Location pulldown box contains 3 options (File System, HTTP, FTP) But I do not see how to change my "File System" web site to "HTTP" when the project is alredy created and open. Please advise!! Well, you can open IIS, create a new website. Set its home directory to the Web folder of your site. Then go and create a new project using http. I don't really think you can convert between File Syst...

Updating "Parent" Web Page with Value from Pop-up "Child" Web Page
Hi, all. I'm having a problem updating a cell in a table row on my parent web page with the updated value from my child web page. I am using a script to pass the value back to the parent page (script is executed in child web page button exit event handler). If I put the updated value in a textbox on the parent page, it works fine. However, when I attempt to put the updated value in the table row cell I get an error: table row is not an object or the object is null. NOTE: I am doing this without a postback on the parent page. I tried creating all the rows dynamically in the code beh...

Create web form with Web Matrix "error"
I have created the web form (Filterd Data Report) with Web Matrix, but when I run the following error: Compilation Error Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately. Compiler Error Message: BC30289: Statement cannot appear within a method body. End of method assumed.Source Error: Line 62: Sub DataGrid1_SelectedIndexChanged(sender As Object, e As EventArgs) Line 63: Line 64: Function MyQueryMethod(ByVal empno As...

superreview cancelled: [Bug 249231] Use only "web site" and "web page" in Firefox : [Attachment 155345] Same as previous with extraneous changes removed
Jeff Walden (remove +fxhelp to email) <jwalden+fxhelp@mit.edu> has cancelled R.J. Keller <rlk@mozdev.org>'s request for superreview: Bug 249231: Use only "web site" and "web page" in Firefox http://bugzilla.mozilla.org/show_bug.cgi?id=249231 Attachment 155345: Same as previous with extraneous changes removed http://bugzilla.mozilla.org/attachment.cgi?id=155345&action=edit ------- Additional Comments from Jeff Walden (remove +fxhelp to email) <jwalden+fxhelp@mit.edu> Removing review request from the patch that's now prompt-hindered w...

superreview requested: [Bug 249231] Use only "web site" and "web page" in Firefox : [Attachment 155345] Same as previous with extraneous changes removed
R.J. Keller <rlk@mozdev.org> has asked Ben Goodger <bugs@bengoodger.com> for superreview: Bug 249231: Use only "web site" and "web page" in Firefox http://bugzilla.mozilla.org/show_bug.cgi?id=249231 Attachment 155345: Same as previous with extraneous changes removed http://bugzilla.mozilla.org/attachment.cgi?id=155345&action=edit ------- Additional Comments from R.J. Keller <rlk@mozdev.org> r=rlk@trfenv.com for the help content. Ben, can you review this for 1.0rc1? ...

Javascript inside "web user control" not run if load "web user control" under ajax UpdatePanel
I have this problem and please if some can help me, I place here a sample code to see, but in my real problem the web user control have a very complicate javascript. I have a web user control that have some javascript inside, let say for example.1 <script type="text/javascript" > 2 function RunMe() 3 { 4 alert("Client id:<%=ClientID%>"); 5 } 6 </script> 7 8 9 <a href="javascript:RunMe()">Run javascript</a> a simple call to a simple javascript, inside the web user control And now I have...

Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Windows SharePoint Services-compatible HTML editor....DataFormwebpart error.
Hi, I am working with sharepoint publishing portal. I have created Custom list 'MyList' and page layout which contains this list at root site. I have created 2 pages one at rootsite and one at subsite from this page layout. In the sharepoint designer , this 'MyList' renders as Listviewwebpart on page layout. when i convert into DataFormwebpart by right click 'Convert to XSLT view' , it works fine with root site page. But it gives error 'Unable to display webpart' on subsite page.   Can anybody help me on this?   Hello,This may help you to ...

Importing n Adding custom web parts onto a web part page
I created a custom webpart using the ASP.NET Web Control Library Template in a  C# project. Then i created a .dwp file for the web part and even edited the web.config file in the c:\inetpub\wwwroot  folder to set the safe property of the webpart to true. I then imported the .dwp file into sharepoint . Now when try to drop the web part onto a web part zone it says             "A web part or web form control on this web part page cannot be displayed or imported because it is not registered as safe on this site" What sh...

Enumerating all the web parts on a page
I have a web part that needs to examine every other web part on a given page for info. I've tried two approaches, but neither seems to be the answer I'm looking for. First, I tried getting a reference to Parent (which returns the WebPartManager) and enumerating through it's Controls (or WebParts) collection. This almost works - it gives me every web part in the same WebPartZone as my web part. But it doesn't give me all the web parts in the other zones. Example:            WebPartManager wpm = (WebPartManager)this.Pa...

Dynamic Web Part Loading Error: "path" argument cannot be empty if the "type" argument is UserControl
I would like to dynamically load web parts, but without using LoadControl*. However, when I try to use the following code, a runtime error is thrown whose meaning is mostly meaningless to me. Control ctrl = (Control)new MyUserControl(); // Control ctrl = LoadControl( "MyUserControl.ascx" ); ctrl.ID = "DynamicUserControl"; GenericWebPart myWebPart = MyWebPartManager.CreateWebPart(ctrl); MyWebPartManager.AddWebPart( myWebPart, MyWebPartManager.Zones[1], 0 );   The error is thrown on the last line, during AddWebPart:   Additional information: The "path" argument cannot be e...