Compiler Error Message: The compiler failed with error code1.

 Hi all,

I just installed the software which was fine and no errors...
when i went to run it first time at local host it came up with the following error...
anyone know what this means?? Confused [*-)]

I have created different ASP.NET projects and it runs no problem...

Regards

Sicose

Server Error in '/PortalVBSDK' Application.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: The compiler failed with error code 1.



C:\WINDOWS\system32> "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\vbc.exe" /t:library /utf8output /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\portalvbsdk\84a299d7\90ad2ea8\assembly\dl3\158c1828\00216695_aa14c301\ASPNETPortal.DLL" /R:"C:\WINDOWS\assembly\GAC_32\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\portalvbsdk\84a299d7\90ad2ea8\App_global.asax.fciixhfp.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Web.Services\2.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Web.Mobile\2.0.0.0__b03f5f7f11d50a3a\System.Web.Mobile.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll" /R:"C:\WINDOWS\assembly\GAC_32\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll" /R:"C:\WINDOWS\assembly\GAC_32\System.Web\2.0.0.0__b03f5f7f11d50a3a\System.Web.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll" /out:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\portalvbsdk\84a299d7\90ad2ea8\App_Web_desktopportalbanner.ascx.cdcab7d2.totcg6s8.dll" /D:DEBUG=1 /debug+ /define:_MYTYPE=\"Web\" /imports:Microsoft.VisualBasic,System,System.Collections,System.Collections.Specialized,System.Configuration,System.Text,System.Text.RegularExpressions,System.Web,System.Web.Caching,System.Web.SessionState,System.Web.Security,System.Web.Profile,System.Web.UI,System.Web.UI.WebControls,System.Web.UI.WebControls.WebParts,System.Web.UI.HtmlControls  "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\portalvbsdk\84a299d7\90ad2ea8\App_Web_desktopportalbanner.ascx.cdcab7d2.totcg6s8.0.vb" "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\portalvbsdk\84a299d7\90ad2ea8\App_Web_desktopportalbanner.ascx.cdcab7d2.totcg6s8.1.vb"


Microsoft (R) Visual Basic Compiler version 8.0.50727.42
for Microsoft (R) .NET Framework version 2.0.50727.42
Copyright (c) Microsoft Corporation.  All rights reserved.

C:\Program Files\ASP.NET Starter Kits\ASP.NET Portal (VBSDK)\PortalVBSDK\DesktopPortalBanner.ascx(25) : error BC30456: 'GetApplicationPath' is not a member of '<Default>'.

                LogoffLink = "<" & "span class=""Accent"">|</span>" & ControlChars.Cr & "<" & "a href=" & Global.GetApplicationPath(Request) & "/Admin/Logoff.aspx class=SiteLink> Logoff" & "<" & "/a>"
                                                                                                          ~~~~~~~~~~~~~~~~~~~~~~~~~                                                                     
C:\Program Files\ASP.NET Starter Kits\ASP.NET Portal (VBSDK)\PortalVBSDK\DesktopPortalBanner.ascx(81) : error BC30456: 'GetApplicationPath' is not a member of '<Default>'.

                                         __w.Write( Global.GetApplicationPath(Request) )
                                                    ~~~~~~~~~~~~~~~~~~~~~~~~~           
C:\Program Files\ASP.NET Starter Kits\ASP.NET Portal (VBSDK)\PortalVBSDK\DesktopPortalBanner.ascx(83) : error BC30456: 'GetApplicationPath' is not a member of '<Default>'.

      __w.Write( Global.GetApplicationPath(Request) )
                 ~~~~~~~~~~~~~~~~~~~~~~~~~           
C:\Program Files\ASP.NET Starter Kits\ASP.NET Portal (VBSDK)\PortalVBSDK\DesktopPortalBanner.ascx(86) : error BC30456: 'GetApplicationPath' is not a member of '<Default>'.

      __w.Write( Global.GetApplicationPath(Request) )
                 ~~~~~~~~~~~~~~~~~~~~~~~~~           
C:\Program Files\ASP.NET Starter Kits\ASP.NET Portal (VBSDK)\PortalVBSDK\DesktopPortalBanner.ascx(107) : error BC30456: 'GetApplicationPath' is not a member of '<Default>'.

              __w.Write( Global.GetApplicationPath(Request) )
                         ~~~~~~~~~~~~~~~~~~~~~~~~~           
function OnToggleTOCLevel1(level2ID) { var elemLevel2 = document.getElementById(level2ID); if (elemLevel2.style.display == 'none') { elemLevel2.style.display = ''; } else { elemLevel2.style.display = 'none'; } }


Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

0
sicose
1/8/2006 6:35:21 PM
asp.net.portal-starter-kit 2189 articles. 0 followers. Follow

2 Replies
534 Views

Similar Articles

[PageSpeed] 24

Hi, I'm not sure why this works, but it does...

Put "Global.ASPNET.StarterKit.Portal." in front of every "Global.GetApplicationPath(Request)" so that they now read "Global.ASPNET.StarterKit.Portal.Global.GetApplicationPath(Request)", and it should work fine.

0
Super
1/11/2006 12:01:27 AM
Thanks for reply.. i will try that later
0
sicose
1/11/2006 12:49:18 AM
Reply: