MDAC 2.5 required to run, cannot install - installer error "2.5 is already there" whereas it is 2.8 which is there

 Hello!

I have a problem with Data Access. There is a DLL i need to use, which was compiled in VB.6 using MDAC 2.5. I am using ..NET 2.0 and on my machine it's MDAC 2.8.When my program is trying to use that DLL, I get an error of connection not being open.

The guy who created that DLL says I need to have MDAC 2.5 on my machine in order to use the DLL properly. However, when I download and try to install MDAC 2.5 it tells me that it's already installed on the machine. Yet, when I go to check in the registry, I get 2.8 and 2.6 as a rollback version.

Here is the question: how do I install MDAC 2.5, and if I need to uninstall MDAC 2.8 how do I do this and whether I be able to reinstall it later to run along with 2.5 for I will need 2.8 as well. Please advise.  

 Thanks,


Alexei Fimine
_____________
Don't forget to mark this post as "Answer" if it indeed answered.
-1
fimine
1/31/2008 1:58:42 PM
asp.net.object-datasource 16182 articles. 0 followers. Follow

1 Replies
1012 Views

Similar Articles

[PageSpeed] 14

 No way - you can't roll back MDAC on WinXp Sp2.


Alexei Fimine
_____________
Don't forget to mark this post as "Answer" if it indeed answered.
-1
fimine
2/8/2008 2:16:40 PM
Reply: