Microsoft AJAX Application Works On LocalHost But Not Web Host - Uses Bridge For Web Service Calls

I recently made some changes to a example site: http://www.countrycodelist.com. The site functions correctly on my computer but when I upload it to a remotee server it does not.  I have tested it in both medium and full trust and it still does not work on a remote host.

The URL of the page that I want to become the primary page is here:

The code for the web service calls and bridge is almost entirely based on the example here: http://www.asp.net/learn/videos/view.aspx?tabid=63&id=66.  It works on my personal computer fine, but as you can see, http://www.countrycodelist.com/Default_Test.aspx, does not function as intended (making calls to both the Flickr and Amazon.com APIs when the search button is clicked).


You can download a Word document I made for anyone willing to help at: http://countrycode.web134.discountasp.net/CountryCodeListSupportDoc.doc.  It shows how the application functions on my home computer, how it is intended to run, and how it works on one of the remote servers I tested it on (the host has given me full trust).

Just to reiterate, the Country Code List example makes two service calls to the Amazon and Flickr APIs with a bridge and asbx file if that makes a difference. 
The changes are exactly from the code in this Microsoft ASP.NET AJAX sample.
I can send you screenshots of how the application works when I build it in Visual Studio.
0
jon333
1/4/2007 7:49:19 PM
asp.net.networking-webservices 2181 articles. 0 followers. Follow

4 Replies
1003 Views

Similar Articles

[PageSpeed] 44

Is the extension asbx registered with IIS on the server machine?

0
Rama
1/4/2007 8:14:41 PM

The .asbx extension is not registered in IIS.  What should the MIME type be, I am administering IIS remotely through a control panel?

Also the URL of the test page should be: http://countrycode.web134.discountasp.net/Default_Test.aspx

0
jon333
1/4/2007 8:48:21 PM

Actually I meant ASp.NET should be registered as the handler for *.asbx pages. It seems that in your case it is correctly registered.

I have no problem in getting you search page to work. It shows the search results as well as the images from flickr  correctly . 

 

0
Rama
1/5/2007 2:13:11 AM
Between my second post and your reply script mapping for .asbx was addedpoint to the asp.net 2.0 dll and it started working.  Thanks!!!
0
jon333
1/5/2007 2:24:18 AM
Reply: