mvctoolkit Assembly 'MVCToolkit, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a high

I have visual studio 2008 SP 1 .

I created a new MVC Web Project and added a reference to the MVCToolkit dll.I tried to build and it shows following exception Error    5    Assembly 'MVCToolkit, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a higher version than referenced assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'    f:\MVC\MVCProjects\MyFirstMVCApplication\LIBS\MVCToolkit.dll    MyFirstMVCApplication.

 I have searched my system but didnt get  System.Web.Extensions, Version=3.6.0.0.

Please guide me from where should I get System.Web.Extensions, Version=3.6.0.0 .

 

Thanks

 

0
D
12/30/2008 1:31:38 PM
asp.net.mvc 4300 articles. 0 followers. Follow

7 Replies
2421 Views

Similar Articles

[PageSpeed] 25

See at, 

C:\Program Files\Reference Assemblies\Microsoft\Framework\ASP.NET 3.5 Extensions


-Mani

"Most good judgment comes from experience. Most experience comes from bad judgment"
0
Manivannan
12/30/2008 4:13:03 PM

Hi D.G. -

The MVC toolkit has been outdated for about a year and is no longer supported.  You should be using the MVC Beta release, which can be found at http://www.asp.net/mvc.

0
levib
12/30/2008 8:11:23 PM

 Thanks for reply.

mvc toolkit includes number of html helpers like html.button.

If I will not include mvctool kit from where I will get all these helpers already in toolkit.

 

0
D
12/31/2008 4:34:10 AM

Many of the types that were in the toolkit are already available as part of the System.Web.Mvc binary.  Some of the others were relocated to MvcFutures, which can be found at http://www.codeplex.com/aspnet/Release/ProjectReleases.aspx?ReleaseId=18459.

0
levib
12/31/2008 4:39:08 AM

 I have added the mvc future release in my project but there is still no change in html helpers.

 

0
D
12/31/2008 5:30:30 AM

Are you referencing the correct namespace?  Open Web.config and scroll to the references section, and make sure there's an entry for Microsoft.Web.Mvc.  If this entry doesn't exist, go ahead and create it.  This should make all of the HTML helpers available to you.  See http://blog.rodj.org/archive/2008/10/16/asp.net-mvc-update-preview-5-to-beta.aspx (Step 3) for an example of how to reference namespaces.

Note that some of the helpers (like Html.SubmitButton()) were permanently removed and are not available in the Futures assembly.

0
levib
12/31/2008 5:41:47 AM

This thing solved my problem.

Thanks alot.I was missing namespace in webconfig.

0
D
12/31/2008 6:16:01 AM
Reply:

Similar Artilces:

Could not load type 'System.Web.UI.ScriptReferenceBase' from assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
on my localhost, everything is working just fine, developing a few hours... then i publish to another server (windows server 2003)...and suddenly my website is broken. i could track i down to a scriptreference in my scriptmanager - which used to work perfectly.now i don't know where it went wrong - because i developed several things, including the addition of autocomplete textbox with the control toolkitbut even after removing all the code for the autocomplete textbox, the problem wasn't solved. i seem to be the first one to have this problem, because google doesn't return anythi...

Could not load type 'System.Web.UI.Compatibility.CompareValidator' from assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
 Hello everyone.i m facing Required field validators problem  with ajax.Validators works fine in my application when it runs  frm localhostBut when I deployed the application on server it stops working.the thing i was missing  <tagMapping> tag.  <tagMapping>        <add tagType="System.Web.UI.WebControls.CompareValidator" mappedTagType="System.Web.UI.Compatibility.CompareValidator, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>   &n...

Could not load type 'System.Web.UI.Compatibility.CompareValidator' from assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'. (E:\SES3\Frontend\SESWe
After installingthe new Ajax release, I cannot compile my project. I tryied removing the <tagMapping>from the web.config, and was able to compile the project, BUT I go error on page: sys.argumentundefinedexception: value cannot be undefined. parameter name  Regards, Adina There is a known problem with the validators with the RTM.  More info about it here. I was getting the "Could not load type 'System.Web.UI.Compatibility.CompareValidator' from assembly 'System.Web.Extensions.." error too!  My project finally compiled correctly after removing the <tagMapping&g...

Unable to create type 'live:IDLoginStatus'. Could not load file or assembly 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The s
Hello,  I try to use a windowslive website in visual studio 2008 with framework 3.5 I have installed the framework 3.5 and i get following error although the site is working perfect in localhost: Unable to create type 'live:IDLoginStatus'. Could not load file or assembly 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.After this i check my gac and i manually (with configuration tool 2.0) installed 3.6 in my gac. I still get the same error. What am i doing ...

MVC Refresh
I just downloaded the new template and am trying to us it, it works fine untill I get to a Add or Edit action and then I get the following error: Could not load file or assembly 'System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040) Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it ...

'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference
I have seen many posts with this problem, but not one I found actually makes it clear to me how to solve it. The site is build with VS2008, and deploying it using VS2008 to my server works fine. Both my server and my development PC have ASP.NET 3.5 installed. I now have to deploy this web to a server that has ASP.NET 1, 1.1 and 2 (no 3.0, no 3.5). I copied the  the System.Web.Extensions.dll I found on the server to my bin directory (overwriting the one that came from my server). -> same error  The error is on line 95 of my web.config : 94   <httpModules>...

Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does n
Hello All,If this is a repeat of posting that have been created, I sincerely apologize.  I have been looking for a solution for quite some time and although I have run across a lot of different posts offering solutions, nothing seems to be work.  Here is my dilemma:I have created a website with several pages using ASP.NET 2.0 and AJAX Extensions (including the AJAX Control Toolkit).  The pages run fine on my Development machine but on my IIS machine, I continue to recreate a Parser Error in regard to System.Web.Extensions.  Here is what I have done thus far: I have a...

AJAX Beta 2
Hi... I'm experiencing a problem with the new AJAX Beta 2. When I try and put the UpdateProgess on a simple page, I get the belowCould not load type 'Microsoft.Web.UI.UpdateProgress' from assembly 'Microsoft.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.TypeLoadException: Could not load type 'Microsoft.Web.UI.Up...

Could not load type 'namespace.User' from assembly 'assemblyName, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.
Hi Folks,   I am having a very frustrating time trying to resolve an issue I have been experiencing. I have 1 solution which contain three different projects within it.   The first project has NO reference to anything in the other two.   The second project references the DLL produced by the first project.   The third project references the DLL produced by the first project and also the DLL produced by the second project.  Now my issue is that in the third project i instantiate some web custom controls  from the DLL in the second project and the desired...

Could not load file or assembly 'System.Web.Extensions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
Dear Sir, I have an issue about using CrystalReport in VS2008 by using target framework as .NET 2.0 with AJAX toolkit enabled. When I have put CrystalReportViewer in ASPX page then run, the top of the page always said "Could not load file or assembly 'System.Web.Extensions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)" I have tried to use the AssemblyRedirect but it isn't work. Here is the code wha...

Could not load file or assembly 'System.Web.Extensions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
 I created a website with AJAX using VS2005, installed the framework in the production server and the website is working fine. then I installed VS2008 + Service pack in my computer without uninstalling VS2005, then converted my project to VS2008, with no issues.then I installed Framework3.5 in the production server without uninstalling Framework2.0. Tested the website and it's good except when I try to run a Crystal report it gave me this error :    Could not load file or assembly 'System.Web.Extensions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf...

Error 92 Could not load type 'System.Web.Hosting.HostingEnvironment' from assembly 'System.Web, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.
helloi'm a new  web developer i am trying to upgrad an esisting project fron visual studio 2003 to visual studio 2005 when trying to run the project i got that errorError    92    Could not load type 'System.Web.Hosting.HostingEnvironment' from assembly 'System.Web, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.        so ....any idea?  Hi tamer, It looks like Visual Studio 2005 is still trying to load the class in the 1.0 version of assemblies. Could you try removing the...

Error 92 Could not load type 'System.Web.Hosting.HostingEnvironment' from assembly 'System.Web, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. #2
hello :i am tying to upgrad an existing project from visual studio 2003 to visual studio 2005and i get the following errorrError    92    Could not load type 'System.Web.Hosting.HostingEnvironment' from assembly 'System.Web, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.        so does any one have any idea about the reason for it and how to fix it?  Hi, Please look at another of thread for more details: http://forums.asp.net/p/1210076/2139042.aspx#2139042Zhao Ji MaSincerely,Microsoft...

Couldn't resolve assembly 'System.Web.Extenstions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
I get this error message when I try to use the Add, New Test ..., Unit Test Wizard with my web-site.    Couldn't resolve assembly 'System.Web.Extenstions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'Could someone explain why?  I notice that these two magic numbers never seem to change. Is that right?Please see: http://forums.asp.net/p/1245183/2289988.aspx#2289988I looked in "C:\Program Files\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\v1.0.61025" and there it is: "System.Web.Extensions.dll" Why can't the VS20...

Web resources about - mvctoolkit Assembly 'MVCToolkit, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a high - asp.net.mvc

Resources last updated: 1/1/2016 10:46:54 AM