Unable to use SQL Server because ASP.NET version 2.0 Session State is not installed on the SQL server. Please install ASP.NET Session State SQL Server version 2.0 or above.

Can anybody point me in the direction of how to resolve this error,

Unable to use SQL Server because ASP.NET version 2.0 Session State is not installed on the SQL server. Please install ASP.NET Session State SQL Server version 2.0 or above.

I am running Visusl Studio 2005, SQL Server 2005 Standard, running on WIndows XP Pro.

I am trying to use SQL for session state management. I originally ran the following code from the command line prompt,

aspnet_regsql.exe -E -ssadd -sstype p

This created an ASPState database. I then manually added my default ASP.NET login as a user. In my web.config file I have the following

<sessionState mode="SQLServer" sqlConnectionString="Integrated Security=SSPI;data source=localhost;" timeout="20" />

I have searched the web without success and this issue is starting to drive me crazy! I am sure that it must be something totally stupid that I am missing. Can anybody help?

0
Scout77
3/7/2006 3:24:08 PM
asp.net.installation-setup 5668 articles. 1 followers. Follow

1 Replies
1859 Views

Similar Articles

[PageSpeed] 39

 Go to aspstate database èright click è propertiesèpermission èadd (public ) database role ègive permission to this role è>and enjoy
0
Eng_Ahmad_2007
12/4/2007 9:27:08 AM
Reply:

Similar Artilces:

Unable to use session state server....requires session state server version 2.0 or above.
So, I have Windows 2003 IIS latest service packs running. Its running .NET 2.0 and .NET 1.1 applications in seperate application pools. Just today I applied the following patch to the server. (The server is not running any 3.0 or 3.5 applications or application pools)  Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86 Microsoft .NET Framework 3.5 Service Pack 1 is a full cumulative update that contains many new features building incrementally upon .NET Framework 2.0, 3.0, 3.5, and includes cumulative servicing upda...

SQL Server Reporting Services for SQL SERVER 2000 AND Visual Studio.NET 2005 .NET 2.0
Hi, Which version of SQl Server Reporting Services will work with SQL SERVER 2000 in pararrel with ASP.NET 2.0 (.NET 2.0 framework)?  Thanks, Azam HighOnCodingWanna get high! Hi, Okay I got the answer. Yes, we can use the SQL SERVER 2005 Reporting Services with SQL SERVER 2000. HighOnCodingWanna get high! ...

Having problems trying to install SQL Server 2005 express /.net framework 2.0
Hi I'm having problems trying to install the above programme from the microsoft site and feel that I'm not getting anywhere.  'I receive the following message during installation "microsoft SQL server 2005 set up has detected a problem and cannot proceed. Either Microsoft.Net Framework 2.0 is either not installed on this system or is corrupt.' I have dinstalled any previous versions of .net, instances of sql server 2005 ran ccleaner and then checked my Add and Remove programmes and checked the microsoft support site for the solution and that didn;t work  ...

Session Management in SQL SERVER for .NET 2.0
Hi, I need to maintain Session variables in the Sql Server Database. But for maintaining the Session, the aspnet_regsql.exe must be run in the .net 2.0 framework. I have a clarification on running aspnet_regsql.exe in asp.net 2.0 I have a Web Server 'TESTWEB' where my source code resides. The Database server resides in another server. The exe must be run in the command prompt from C:\Windows\Microsoft.Net\Framework\v2.0\mentioning the parameters as Database server name, User id, Password. But the doubt is, whether this exe must be run only from this web server 'TESTWEB'...

This version of Microsoft Sql Server Management Studio can only be used to connect to Sql Server 2000 and Sql Server 2005 servers
When I connect SQL Server 2005 to a remote database i get the error: "This version of Microsoft Sql Server Management Studio can only be used to connect to Sql Server 2000 and Sql Server 2005 servers". Can I confirm it is because: the remote db is of SQL Server 2008? There is a soln mentioned in http://forums.asp.net/t/1324047.aspx Did anybody try this (installing 2008 express: http://www.microsoft.com/express/sql/download/)? I am just checking again, whether it will disturb my existing SQL Server installation, in any means...? Though it is mentioned that it will g...

SQL Server 2005 Installation problems with SQL Server Express & SQL Server 2000
Hi Guys, I have had SQL Server Express and Sql Server Management Studio Express installed on my machine for some time and recently tried to install a trial of SQL Server 2005 as well.  (Yes, I'm migrating from Visual Studio Express to Visual Studio Professional, just as in tended!) Everything went fine except that nothing seemed to be installed.  I searched in all the obvious places - both on the Start/Programs menu and on the hard-drive: nothing. A check under Add/Remove Programs showed that Sql Server 2005 Express was installed, but called SQL Server 2005. So after a number o...

BCP of 4.9.2 SQL Server to 11.0.2 SQL Server
We have a client wishing to bcp data out of a 4.9.2 SQL Server database and bcp the data into an 11.0.2 SQL Server database. Just knowing of the problems that have arisen lately with regards to the System 11 bcp utility and the fact that 4.9.2 is such an old release, is the above task possible? If not, what is my alternative? Regards, -- Robert C. Marx SQL Financials International 770.291.8506 MarxR@SFI.com Rob Marx wrote: > > We have a client wishing to bcp data out of a 4.9.2 SQL Server database and > bcp the data into an 11.0.2 SQL Server database. Ju...

use dw .net 2,0 with SQL SERVER
I want to use dw .net 2,0 with SQL SERVER but I have problems in when use the method settransaction (), I am using oledb. Gracias rudolph124@hotmail.com Please provide a more detailed description of the problem and a code sample if possible. Regards, Dave Fish Sybase On 31 Jul 2006 13:30:52 -0700, bladimir calcina wrote: >I want to use dw .net 2,0 with SQL SERVER but I have >problems in when use the method settransaction (), I am >using oledb. Gracias rudolph124@hotmail.com I want to use dw .net 2.0 with sqlserver and this is totally new for my, was proving...

SQL query that works in SQL Server Management Studio, but doesn't on .NET 2.0 page
SELECT favorites.FID, favorites.filename, favorites.username, files.status, files.private, files.views, files.title FROM favorites INNER JOIN files ON favorites.filename = files.filename WHERE (favorites.username = @username) AND (files.status IS NULL) AND (files.private = @private)@private is manually set to 'no'@username is set to profile.usernamewhen I run the above query in microsoft sql server mgmt studio express on the database, it presents all the information i'm asking for very easily. however when i try to implement this query on a aspx .net2.0 page with teh sqldatasourc...

sql anywhere 10.0.1 direct install & maintenance patch install different version no of .net adapter
sql anywhere 10.0.1 direct install & maintenance patch install different version no of .net adapter Is this an expected behavior? thanks vsv are we talking about ebf 3515? the dll version appearing in .net reference is 10.0.1.35152 and .net does not complain the Sybase central reports sqlanywhere as 10.0.1.3515 is that what you got too? Oh btw, I have not rebooted the PC post ebf 3515 patch. However it reported an earlier version prior to the ebf I will reboot tonight and see what happens "vsv" <nospam@nospam.com> wrote in message news:46e...

Can't seem to install SQL server 2005? Install completes, but where is SQL Server 2005
I went to one of the Microsoft "Ready To Launch" events over a year ago. Microsoft was gracious and gave everyone who attended a free copy of Visual Studio 2005 and SQL Server 2005. I have installed the Visual Studio and use it all of the time. I also installed the SQL server 2005 but I can not find the application on my computer. After the install the only items that appear to have been installed are the following: SQL Server Configuration tools(SQL Server Configuration manager,SQL Server  Error and usage reporting, SQL Server surface area confiuration, Reporting Services configu...

Unable to install DNN 2.0.4
I'm getting all kinds of errors when I'm trying to setup a new store. Here are a few examples: System.Data.SqlClient.SqlException: Incorrect syntax near the keyword 'ON'. at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteNonQuery(SqlConnection connection, CommandType commandType, String commandText, SqlParameter[] commandParameters) at Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteNonQuery(String connectionString, CommandType commandType, String commandText, SqlParameter[] commandParameters) at Microsoft...

.NET 2.0 Reporting Module using SQL Server Reporting Services
Hello Everyone,I have created a generic module using ASP.NET 2.0, MS SQL Server 2005 and SQL Server 2005 Reporting Services. This module is intended to provide a generic user interface for selecting and generating reports. You can configure its respective table for your fixed or flexible parameters for each report. It also supports end user access level security for each report and report group which is generally required for any basic reporting module.You can view reports in two different styles:-- Drop down--Tree View And You can view your report in 3 supported formats.  This is an in...

Application created in new version of .NET (3.0 or 3.5) can use the library created in older version of .NET(i.e.-1.0 or 2.0)?
Hi All, I am using Visual Studio .NET compiler for compiling my application . We have plugins (as library) which the user can write by their own in .NET . We are building our code in Visual Studio 2005 but we have already some plug-ins which are written in previous versions of Visual Studio (i.e. 2002 and 2003). Is these plug-ins will work with the new build of the application or I need to build these plug-ins as well in Visual Studio .NET 2005. These plugins are created as library. Is their any differences between .NET 1.0, 2.0 and 3.0 because of which the old libraries (created in o...

PB 10.2.0 Connect SQL Server Using ADO.NET Provider
I have a problem with connection to SQL Server database using ADO.NET after upgrading to PB10.2.0 build 8011 runtime on the client machine. But it worked fine in version 10.0.1 build 6044 . Anyone can help me to figure ot that problem? TIA. John Ho. Can you try to provide details of the problem? <John Ho> wrote in message news:427aeaa1.7f95.1681692777@sybase.com... >I have a problem with connection to SQL Server database > using ADO.NET after upgrading to PB10.2.0 build 8011 runtime > on the client machine. But it worked fine in version 10.0.1 > build 604...

Web resources about - Unable to use SQL Server because ASP.NET version 2.0 Session State is not installed on the SQL server. Please install ASP.NET Session State SQL Server version 2.0 or above. - asp.net.installation-setup

States of India by installed power capacity - Wikipedia, the free encyclopedia
^ "ALL INDIA REGIONWISE GENERATING INSTALLED CAPACITY OF POWER" (PDF) . Central Electricity Authority, Ministry of Power, Government of India. ...

Facebook, Messenger Pre-Installed on New Nokia 215, Nokia 215 Dual SIM Low-Cost Handsets
Facebook and Facebook Messenger are among the preinstalled applications on the new Nokia 215 and Nokia 215 Dual SIM entry-level phones from Microsoft ...

HTC reveals HTC First, an Android smartphone pre-installed with Facebook Home
HTC today revealed the HTC First, the first Android smartphone that comes with Facebook Home pre-installed on the device. With Facebook Home ...

Introducing installed app category targeting: a new way to target users and gain insights into mobile ...
We’re excited to introduce installed app category targeting: a new tool that enables app advertisers to reach users based on the categories of ...

Installed a new HDD - Flickr - Photo Sharing!
Seagate 100GB, 7200RPM in the 3 year old PowerBook.

FIRST EVER IPAD MINI INSTALLED INTO DASH OF A CAR - YouTube
Soundwaves of Tampa is the first to install a iPad Mini into a dash of a car. Please check us out and build pics at http://Facebook.com/soundwavesoftampa ...

Queensland's first Bitcoin ATM installed in South Brisbane
What is believed to be Queensland&#8217;s first Bitcoin ATM is up and running at a South Brisbane cafe, allowing customers to withdraw and sell ...

Cameras installed on hull of ISS (00:59)
RAW VIDEO: Russian cosmonauts perform a spacewalk to install photographic and scientific equipment on the hull of the International Space Station. ...

Where in the US is solar installed?
New data shows that Californians' penchant for photovoltaics has them leading in pipeline capacity by a factor of five, while Nevada's love of ...

Giant Gollum installed at airport ahead of Hobbit film
A 12 metre-long sculpture carved using robotics and chainsaws has been installed at Wellington Airport ahead of The Hobbit premiere.

Resources last updated: 11/25/2015 8:25:21 PM