Getting a "Could not load type" error from an ASP.NET 1.1 app

We've got an ASP.NET 2.0 application running on a Windows 2003 Server.  I've created a couple of application pools within IIS, so that I can associate ASP.NET 2.0 apps with one and ASP.NET 1.1 apps wtih the other one.  We've got another ASP.NET app on the same server, and for various reasons we've got to roll that app back to ASP.NET 1.1.  I've put it onto the machine, went to the ASP.NET tab for the app in IIS, made certain that it was using the 1.1 .NET Framework, and then on the General tab made certain that it would use the application pool I'd created specifically for the purpose of running .NET Framework 1.1 applcations against.

However, although I've followed all of these precautions, I am still getting the following error message:


Parser Error

Description: An error occurred during the parsing of a resource required to service this request.  Please review the following specific parse error details and modify your source file appropriately.

Parse Error Message: Could not load type 'Appointments.Global'

Line 1: <%@ Application Codebehind="Global.asax.vb" Inherits="Appointments,Global" %>

 Source File: C:\inetpub\wwwroot\Appointments\global.asax  Line: 1

Version Information: Microsoft .NET Framework Version: 1.1.4322.2407; ASP.NET Version 1.1.4322.2407


I really don't see what the problem is.  The .dll file in the the bin folder under the Appointments folder under wwwroot.  We've got to have both ASP.NET applications running on this Windows 2003 Server, and one running against the .NET Framework 2.0 and the other against the .NET Framework 1.1.  As far as I know this should be possible.  So, what's wrong?


Doctor Who
0
DoctorWho
8/14/2007 5:36:20 PM
asp.net.installation-setup 5668 articles. 1 followers. Follow

2 Replies
966 Views

Similar Articles

[PageSpeed] 19

<%@ Application Codebehind="Global.asax.vb" Inherits="Appointments,Global" %>
 Check out there is a comma next to appointments, it should be a period(.). And also do you have code behind file Global.asax.vb?? if yes check 
what name space it is in.  If there is no Global.asax.vb file then delete Codebehind="Global.asax.vb" Inherits="Appointments,Global" from the header part
 

 


Raghu
(MCSD.NET, MCAD.NET, MCDBA)
[Don't forget to click on Mark as answer on the post that helped you ]
0
rmaiya
8/14/2007 5:49:43 PM

The Inherits="Appointments,Global" was a typo on my part.  It really is Inherits="Appointments.Global" in the file.

I tried what you suggested, but still came up with a problem.  It is strange, because the same .MSI that we use to create the ASP.NET app on the other server, is the one I was trying to create on this one.

What I found finally took care of the problem was deleting the Appointments folder out of IIS, and re-creating it when I installed the .MSI file again.


Doctor Who
0
DoctorWho
8/14/2007 7:58:30 PM
Reply:

Similar Artilces:

Developed C#.net WebService 1.1 for Client C#.net 1.1. Getting error "Server was unable to process the Request" Pls Help
Hi., I developed Microsoft C#.net Web Services2003 for the Client Application C#.net 2003. When it runs in 5 machines it gives good performance and has no errors. But if i run the same application in about 80 client machines. Getting error "Server was unable to process the request". I use Sql Server 2005 as my database. I get error even when i login at a time for about 25 users. Tried modifying machine.config too. But went unsuccessful. Live Server is 2003 using IIS 6.0 I use very expensive data handling.  Its very urgent pls help. Have to post in Live Server. Thank u., ...

"Error loading XML file :\windows\microsoft.net\framework\v1.0.3705"...does this mean v.1.1 code trying to run in a v.1.0 app?
I uploaded some new files into my existing third-party hosted site, including a .DLL into \BIN\, which is running AS.NET v.1.0. I got the following error message when browsing to one of the pages using the code in the namespace defined in the DLL: Error loading XML file c:\windows\microsoft.net\framework\v1.0.3705\Config\machine.config Request for the permission of type System.Security.Permissions.StrongNameIdentityPermission, mscorlib, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 failed. (c:\windows\microsoft.net\framework\v1.0.3705\Config\machine.config) ...

Retrograding httpHandler from .NET 2.0 to 1.1, get "Parser Error Message: Could not create type" message
Hi there,I have written a httpHandler using VS2005 and .NET 2.0 that builds and works fine.However, I am now having to convert it to .NET 1.1, which I hoped would just be a case of changing the runtime used by the web app (as in running the 1.1 version of aspnet_regiis, with a "-s" switch pointing at my web apps folder). After doing this though (and fixing a few minor differences with web.config), if I then navigate to my handler I get the following error message:Server Error in '/Path/To/MyWebApp' Application.Parser ErrorDescription: An error occurred during the parsing of...

Migration from .net 1.1 to .net 2.0 and deployed in server: error "Server Application Unavilable"
Hi, I have upgraded one .net 1.1 application to .net 2.0. though locally the application is running fine, when deployed in the server it is giving the following error : Server Application Unavailable The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request. Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused thi...

error "Failed to get datetime data" using dw.net 1.0.1
Hello, My situation: I have a vs2005 project with dw.net version 1.0.1 (build 5502), database is asa10. When my regional settings are Dutch(Belgium) I have no problems at all. When the settings are Italian(Italy) I get a "Failed to get datetime" error when I retrieve when my data contains dates. When the date fields are not filled in then I do not get the error. A date of '2008-1-1 08:00:00' also gives errors. When I try to retrieve the same data in the datawindow painter I also get no error. Can anyone help me? Greetings, Mich=E8le DW.net 2.5 is now th...

Can anyone tell me the diff between .net framework versions "1.1.4322.573" and "1.1.4322.903"
Production environment is running 1.1.4322.573 Pre Production environments are running 1.1.4322.903 We are seeing some javascript errors that are only happening in our production environment. All of our pre production environments for testing, development and what not seem to be running fine. We get the generic client side error that says which line, which char number and the brief description. The actuall error states "Expected ';' " . Here is the line of code that it's complaining about. "theform = document._ctl6:Form1;" This is microsoft ge...

Method "UrlPathEncode" available in .NET 1.1 but VS.NET 2003 not seeing it
I'm trying to reference HttpUtility.UrlPathEncode(SomeStr) in my VB code but I get a build error saying "'UrlPathEncode' is not a member of 'System.Web.HttpUtility'."I've included "Imports System.Web.HttpUtility" at the codebehind page though it won't build. Appearently, when I use HttpUtility.UrlPathEncode(SomeStr) in a page with no codebehind page, it is interpreted fine. Is this because I am trying to build the code behind using VS.Net2003? Is there a way around this short of creating these pages with no code behind?King Hi Kelder, I think it should be ser...

.Net 1.1 with .Net 2.0 virtual directory using AJAX "Sys undefined"
I'm having an issue running an AJAX app I built, I think I might know what the problem might be, but if so, I am not sure how to fix it. The main site is built with 1.1 and new application is 2.0.  I have the new application configured properly (as far as I can tell) in its own app pool, etc..  The app runs just fine (I have other 2.0 apps that run along side the main 1.1), but I am getting an error: "Sys undefined...."  I've checked to enusre the mappings for the .axd extension for this particular VD are pointing to the correct place as ...

Cannot use persona add-on in 3.6 Beta i. I get this error message:"Personas 1.3.1 could not be installed because it is not compatible with Firefox 3.6b1".
Name: Jonathan Sprague Email: sprag80atgmaildotcom Product: Firefox Release Candidate Summary: Cannot use persona add-on in 3.6 Beta i. I get this error message:"Personas 1.3.1 could not be installed because it is not compatible with Firefox 3.6b1". Comments: I have Windows 7. Personas 1.3.1.does not add-on to my system. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1 (.NET CLR 3.5.30729) From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback bu...

.NET 1.1 version of "Previous Page?"
I have a web app built in ASP.NET 1.1 and C#.  I need to base some controls on a page on what page the user has navigated there from, e.g. a button's text and On_Click function will depend on how the user got to the page.  I know that in .NET 2.0 I could use an "if (Page.PreviousPage == "PageName.aspx") statement, but is there an equivalent in 1.1? No previous page on 1.1 as far as I know.CheersAlMy BlogMapStats.NETPlease click on 'Mark as Answer' if this post answered your question! Perhaps if I explain in more detail what I need to accomplish, you or someone else can ...

Has a "sunset" date been announced by Microsoft for .NET 1.1 support?
My employer has developed a large custom software package using Visual Studio 2003 and .NET 1.1.  Our other projects are mostly in .NET 2.0 and we are starting to work with .NET 3.5.  We need to find reasons why the customer should pay for one of our developers to spend 1-2 weeks doing a conversion to version 2.0 or 3.5.  The customer is trying to cut costs, so typical programmer reasons for the conversion won't cut it (e.g. "VS 2003 is way uncool and the other geeks don't respect me...").  Just kidding.  Seriously, we would like to give them the ri...

Differences between .net 1, .net 1.1, .net 2.0 and .net 3.0
Hi, This seems to be a common question, but i havent got an answer yet:(Can, any one please explain me the differences between these versions.If you keep your feet firmly on the ground, you'll have trouble putting on your pants! Have a look into this links http://en.wikipedia.org/wiki/.NET_Framework http://blogs.msdn.com/mohammadakif/archive/2006/12/03/net-3-0-different-versions-of-the-net-framework.aspx http://www.codeproject.com/aspnet/ComparisonASP1xASP20.aspAshok Rajawww.iGold.inDon't forget to click "Mark as Answer" on the post that helped you. This credits that m...

"Copy Project" results in: HTTP:/1.1 500 "Internal Server Error"
Hi all,   I have tried finding a fix to this error on Google, etc. to no avail. Does anyone know what it means and/or know how I can fix this. I have had no problem uploading other webApps to hosting co.'s (although I haven't tried "copy project" to GoDaddy until now). Is this a problem with the hosting Co., or my configs? I know there is an easy answer to this question, but I am perplexed.   -cmf...

All I get is "Conversion Issues", 1 Error, Not Converted 1... please help
Help please.. I am converting to a VS 2005 Web project, the libraries convert, but the website/project in the Conversion Report just says "Conversion Issues" and says there was 1 Error, Not Convert 1.. no explaination...-Chau Nguyen-http://DNAfor.NET...

.NET 1.1 to 2.0 "remember me" checkbox no longer works
I have a site I recently updated to ASP.NET 2.0 from 1.1 and everything works fine (with minimal fiddling) except the remember me check box on the log in page.  I use custom forms authentication.  Web.config defines the timeout as 60 minutes: <forms name="NIDB1AuthCookie" protection="All" timeout="1" loginUrl="Login.aspx" cookieless="UseCookies" />And in the login.aspx.cs file I have it check the checkbox to see if its checked and then manually set the cookie to expire in 30 days.  if (cbRememberMe.Checked){ //Set cookie to expire in 30 days if user checks the remem...

New 1.1 Installation on W2K & "Server Application Error"
Hello folks. First time poster but have spent the past few days digging around here trying to solve my problem. I'm having no luck so I'm hoping someone here has some ideas. Server: Win 2k Pro SQL Server 2000 ..NET Framework 1.1 IE 6.0.2800.1106 IIS 5.0 This server is NOT a domain controller. It is my desktop dev server which is part of the domain. I'm not sure what else anyone would want to know... So my probem is the: "Server Application Unavailable The web application you are attempting to access on this web server is currently unavailable. Please hi...

Installed VS.NET 2002. That installed 1.0, but I HAD 1.1 installed. How to remove 1.0?
I haven't seen this anywhere, so I figured I would add it here. First of all, it is incorrect to recommend to anyone that who has VS.NET 2002 to do ANYTHING but first install VS.NET 2002. The installl order for VS.NET 2002 and .Net Framwork 1.1 SHOULD BE: 0. Install ALL windows updates for your pc EXCEPT FOR .NET Framwork 1.1 1. Install VS.NET 2002 2. Install MSDE that comes w/VS.NET 2002 (USE A NAMED INSTANCE! Never usee the default instance) 2. Install MDAC 2.8 3. Install .Net Framework 1.1 4. SOMEHOW GET RID OF .NET Framework and get VS.NET and IIS 5.x to work w...

Differences between .net 1, .net 1.1, .net 2.0 and .net 3.0 #2
Hi, This seems to be a common question, but i havent got an answer yet:(Can, any one please explain me the differences between these versions.If you keep your feet firmly on the ground, you'll have trouble putting on your pants! There are too many differences for one email - - from 1.0 to 1.1 (not a whole lot of real change, other than fixes, at least compared to 1.1 to 2.0) With 2.0, there were many new declarative controls, with many new ideas added in With 3.0, it's a superset of 2.0 - instead of replacing the installation completely, it just 'added on' new functionality - I would...

"Type abstract" error when I try to open default.aspx (DNN3.1.1)
Hi, I am new in DNN and I having face following problem: when I open DotNetNuke Project's default.aspx with vs2003, it pop up error message "The file could not be loaded into the web forms designer. Please correct the following error and then try loading it again: " "Type Abstract" "Make sure all of the classes used in the page are built or referenced in the project. Click Help for more information" I have tried to solve this problem by search on Google and this discussion forum. I did find some information but I still can't get around this problem. I would really appreciate ...

Create setup pakage: Parser Error: Line 1: <%@ Master Language="VB" CodeFile="MasterPage.master.vb" Inherits="MasterPage"%>
Hello, I got stuck. My application is working find in the vs2005 development as I create the master page and content page. I can view my content page in the vs 2005 development without any error. I create my new web setup project (WebSetup1) as I add: 1. Primary ouput and content files 2. WebApplication1.dll 3. WebApplication1.pdp 4. WebApplication1.xml Then I build webSetup1 project. Then I install my webSetup1 to IIS server choosing Virtual Directory: WebSetup1 Installation sucessful But when I browse my defalut page from IIS I get the error: Parser Error Description: An ...

is .net framework 1.1 same as .net framework SDK 1.1
is .net framework 1.1 same as  .net framework SDK 1.1 Basically Framework 1.1 of .NET includes the Sofware Development Kit (SDK) 1.1 http://www.microsoft.com/downloads/details.aspx?FamilyID=9b3a2ca6-3647-4070-9f41-a333c6b9181d&displaylang=en Regards,Vinz"Code, Beer and Music" that's my way of being a programmer!How to get your Forum Question Answered | Blog | CodeASP.NET I think .net framework 1.1 is just the runtime library to view .net 1.1 programs.  the .net framework SDK 1.1 one is the actual development library used to create them.   Eri...

Paging Repeater treating page 11 as "1" and "1" not "11"
Dear AllI have a paging repeater, and I am displaying pages according to the amount of records I am retreiving from the database.  My code is as follows:-ASPX           <asp:Repeater runat="server" ID="rptPageNumbers" OnItemCommand="rptPageNumbers_ItemCommand">              <ItemTemplate>                <asp:LinkButton ID="LinkButton1" runat=&quo...

Parser Error
What do I make to solve that problem? Parser Error Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately. Parser Error Message: Stream is not a valid resource file.Source Error: Line 1: <?xml version="1.0" encoding="utf-8" ?> Line 2: <locales> Line 3: <inactive>Source File: /dotnetnuke320/App_GlobalResources/Locales.Portal.xml.resources    Line: 1 Version Information: Microsoft .NET Framework Versio...

Getting "openUserWin is not defined" JS error with 1.5.0.3, but not 1.0.6
I use a terrible web-based bugtracking product called 'Extraview' for tracking software development defects (bugs). It has an 'Edit Defect' form where I can update a bug's comments / notes / build / assigned-to / etc. This form works fine in Firefox 1.0.6 and IE6, but since I've upgraded recently to Firefox 1.5.0.3, it does not work at all. There are buttons along the top, such as 'update', 'clone', 'interest list', 'history', and 'close', which invoke a JavaScript function "openUserWin" to carry ...

When using <identity impersonate="true"> in .NET 1.1, and 2.0 is there some differences?
When setting <identity impersonate="true"> in .NET 1.1, and 2.0, is there some differences that I should be aware of? Will identity impersonate act differently in .Net 1.1 vs .Net 2.0, both using IIS 6.0? Is there an article I can read that will explain this if its true? Thanks, xyz789          Try this: http://msdn2.microsoft.com/en-us/library/ms998351.aspx specifically, the what's new in 2.0 section of that page: http://msdn2.microsoft.com/en-us/library/ms998351.aspx#paght000023_whatsnew Rachel AppelMVP - ASPInside...

Web resources about - Getting a "Could not load type" error from an ASP.NET 1.1 app - asp.net.installation-setup

Resources last updated: 2/15/2016 3:38:52 PM