Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0 (and etc.) HRESULT 0x8013104

That little HRESULT, as you may know, means exactly what the error says: The assembly wasn't found.

I have a Visual Studio 2005 web project I'm publishing into a folder.  When I copy that folder up to it's location on my test server, I get the following message because .NET Framework 3.5 is not installed on that server (nor should it have to be--the AJAX extension DLL is already on that server).

I looked though all my Project settings, to see if I was missing something that was telling VS to reference System.Web.Extensions as a .NET 3.5 (instead of an ASP.NET AJAX 1.0) assembly, to no avail. 

This is what the assembly reference is in the web.config, so I would have thought it would also output for the precompiled site:
         'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

And this is what ends up causing the error:
         'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

Does anyone know how VS 2005 can automatically decide to change my references at compile-time?  Is there a way for me to override that behavior?  And shouldn't it be a default behavior to do exactly as the user asks?

Uninstalling Framework 3.5 (Pre-release)--and then re-doing the publish--resolved the issue, but now VS 2008 Beta 2 doesn't have .NET 3.5 to build off of.

I really want this to be a pre-release glitch, so let me know if you need more information to solve this.

0
v2gusk
8/10/2007 9:45:01 PM
asp.net.futures 1064 articles. 0 followers. Follow

5 Replies
503 Views

Similar Articles

[PageSpeed] 1

plz delete that line when error will come and re configure that refernace
Nothing is really over,untill the moment stop trying for it...
Amitsp(MCTS,MCP)
sqlreporting.blogspot.com
0
prajapatiamit2003
8/11/2007 10:05:26 AM

It seems that you have not run that script that disables to publisher policy which redirects the reference to the 1.0 assembly to 3.5. Take a look at the following page, and at the bottom, it says "you should run this script ...", and see if it helps.

http://msdn2.microsoft.com/en-us/vstudio/aa700831.aspx

 


==============================================
If you get the answer to your question, please mark it as the answer.
0
hongping
8/13/2007 5:08:23 PM

Thank you so much hongping!

I so much more prefer errors that are my-side, rather than Microsoft-side, especially when those "errors" keep me from testing out the latest, greatest stuff.
 

0
v2gusk
8/21/2007 9:59:45 PM

 thank you so much...

 

it looks like many people doesnt read at all! :D

 

 

thanks again! 

0
Rothariger
10/25/2007 12:39:52 PM

 Now i also able to run my web application by resolving this problem.


http://developerassistant.blogspot.com
0
codemobile
12/6/2008 2:16:49 PM
Reply:

Similar Artilces:

Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does n
Hello All,If this is a repeat of posting that have been created, I sincerely apologize.  I have been looking for a solution for quite some time and although I have run across a lot of different posts offering solutions, nothing seems to be work.  Here is my dilemma:I have created a website with several pages using ASP.NET 2.0 and AJAX Extensions (including the AJAX Control Toolkit).  The pages run fine on my Development machine but on my IIS machine, I continue to recreate a Parser Error in regard to System.Web.Extensions.  Here is what I have done thus far: I have a...

Could not load type 'System.Web.UI.ScriptReferenceBase' from assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
on my localhost, everything is working just fine, developing a few hours... then i publish to another server (windows server 2003)...and suddenly my website is broken. i could track i down to a scriptreference in my scriptmanager - which used to work perfectly.now i don't know where it went wrong - because i developed several things, including the addition of autocomplete textbox with the control toolkitbut even after removing all the code for the autocomplete textbox, the problem wasn't solved. i seem to be the first one to have this problem, because google doesn't return anythi...

coplilation error : Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the fi
I have problem compiling my website on 2 machine(win 2003 server & windows vista). The problematics machines has these components installed: 1.Net framework 3.5 sp1 2.vs 2008 sp1 ver: 9.0.30729.1 sp 3.windows sdk for vs 2008 sp1 It works grate on 3 different machines (xp,2003) that has the same components installed and the Microsoft ASP.NET 3.5 Extension CTP. I can't install the Microsoft ASP.NET 3.5 Extension CTP because I already have the .net 3.5 sp1 installed. Here is my web.config ...

Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0
 I developed my asp.net project using VS 2005. My web server is a Windows server 2003 and is installed framework 2.0 and Ajax 1 extension. Everrything works well until I intalled VS 2008 in my development machine.My website works fine on my development machine. But when I publish it to my web server, it raise a parser error: Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0... I used ajax toolkit in my project. First, I found the web.config contained a statement: <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken...

Configuration Error
Hey everyone,I am very very very new to development.  In fact, this is my first website.  I've built the site and it works fine when I test it on my local machine, but when I try to deploy it and type in the URL, I get the following error:  Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: Could not load file or assembly &#...

Parser Error Message: Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0
Hi guys. I have created a Web Site on IIS 6.0 on a remote server. I installed .NET 2.0 + configured server side extensions.  I then installed Visual Web Developer 2008 on my local XP machine. This installed .NET 3.5. I created a New Web Site in VWD 2008 (using HTTP). I connect OK to the remote server. However when I try to preview the default.aspx I receive error: Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your conf...

Unable to create type 'live:IDLoginStatus'. Could not load file or assembly 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The s
Hello,  I try to use a windowslive website in visual studio 2008 with framework 3.5 I have installed the framework 3.5 and i get following error although the site is working perfect in localhost: Unable to create type 'live:IDLoginStatus'. Could not load file or assembly 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.After this i check my gac and i manually (with configuration tool 2.0) installed 3.6 in my gac. I still get the same error. What am i doing ...

mvctoolkit Assembly 'MVCToolkit, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a high
I have visual studio 2008 SP 1 .I created a new MVC Web Project and added a reference to the MVCToolkit dll.I tried to build and it shows following exception Error    5    Assembly 'MVCToolkit, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a higher version than referenced assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'    f:\MVC\MVCProjects\MyFirstMVCApplicati...

Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
Hi, I am using VS2008 and .net 3.5, #. i m trying to access default.aspx in the browser and it shows the error as "Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified."   Also when i use any of the Ajaxcontrol toolkit tools, i m getting the these kind of errors. I hav copied the ajaxcontroltoolkit.dll and .pdb in the bin folder. but i m getting the same error. Please help me.  I will  be grateful if anyone can send me the co...

Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified
I have downloaded the Ajax Control Toolkit Website Project. I want to run on Visual Studio 2005. But when I run the project I got the error like  Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified . </system.web>     <httpModules>        <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neu...

Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
hello i am getting this error in my application...i used ajax in web site..please help me Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.Source Error: Line 30: <compilation...

Could not load file or assembly System.Web.Extensions, Version=3.5.0.0
Hi,   Just created a web site to play with MVC in VWD 2008 SP1 with a template for VWD MVC web sites I found googling. The template adds a reference to System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35  I have System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35 in my GAC. I guess this 3.5.0.0 is the version that installs with VWD 2008 SP1. So I changed my config file to <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> The web si...

Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. #2
Hi, i copied the solution folder   and put this folder to another  computer and i try to run it show the error message " Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified." Please guide me very urgent.Regards,Kannandesikan You need to install the ASP.NET AJAX extensions on the web server. ...

Could not load file or assembly 'System.Web.Extensions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
Dear Sir, I have an issue about using CrystalReport in VS2008 by using target framework as .NET 2.0 with AJAX toolkit enabled. When I have put CrystalReportViewer in ASPX page then run, the top of the page always said "Could not load file or assembly 'System.Web.Extensions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)" I have tried to use the AssemblyRedirect but it isn't work. Here is the code wha...

Web resources about - Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0 (and etc.) HRESULT 0x8013104 - asp.net.futures

Resources last updated: 1/20/2016 1:58:31 PM