The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] )

Hello,

I wanted to upgrade my DNN 1.0.... version to DNN version 2.
Therefore I renamed the Version 1 DNN to an "OLD" directory, and I created a new directory with the name of the old one. In this way I had not to change the links in my other webpages.
Futhermore, I deleted the Verion 1 database (MSDE 2000).
I downloaded the version 2 DNN and unzipped it to the destined directory.
When I started up for the first time in order to let the database be generated I got the following errormessage:
The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] )
What did I do wrong, and how can I get this right?
Thanks in advance,
Jos Richters

www.visualdata.nl
"He who pretends to know everything does't know much!" Keep on asking!
0
JosRichters
2/26/2004 2:31:48 PM
asp.net.dotnetnuke 25171 articles. 0 followers. Follow

3 Replies
757 Views

Similar Articles

[PageSpeed] 54

Check out my post on this topic: 

http://www.asp.net/Forums/ShowPost.aspx?tabindex=1&PostID=477465
There was some useful stuff people suggested that may help.
0
gary
2/26/2004 3:12:37 PM
I had this issue and resolved it by changing both SQL connection strings in the web.config file.  It appears that in 1.x DNN there is only once connection string in the .config file but in 2.x there are two.

Just a suggestion but this is how I fixed the issue when it happened to me.
Hope it helps!
George Hayner

0
ghayner
2/26/2004 3:48:42 PM
Jos,

The DNN installer won't really create a new database, you still have to create a new one prior to browsing to the new virtual directory to kick off the installer. Try creating a new database, then make sure both references in the web config point to it, and then browse to the new virtual directory with DNNv2.0 files.
Good luck, I've done this about 3 or 4 times now, and that's the process that works for me.
iwonder
iwonder
Mission, KS - USA
0
iwonder
2/26/2004 8:16:29 PM
Reply:

Similar Artilces:

Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] )
I am trying to install the beta verion 3.0.9. This is the error I am getting. Can anyone help me? You might want to do a search on this subject. There's tons of documentation....

The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) #2
one reason for getting this message is quite simple if you recompile dotnetnuke2.1.1 then the version number will end up to be 2.1.2 thus if you recompile the source then turn the incremental version number off in the project properties before compiling. leave it at 2.1.1 It would be better if the core team turned this off in the production set before setting it up for download as I would assume that in upcoming updates this could create a few problems without recompiling the source i often get this error when there is an error in my connectionstring or some error connecting to data...

The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) #3
Hi I'm having to trouble to initiate the dotnetnuke portal no matter what I do. I'm trying to set it on my local web server (xp professional) on a local sql server I have created a virtual directory and everything instructed in the documentation I keep getting the aboved message in the subject What am I missing here, Please advise .... thanks in advance Romy Here is my web.config <configuration> <!-- register local configuration handlers --> <configSections> <sectionGroup name="dotnetnuke"> ...

The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) #2
Hi,For some time, I'm trying to install DNN 3.2.I've come accross serveral errors, always related to the connection sting.I'm installing DNN on a portable for testing purposes.Pc-name = PORTABLEMSDE called DOTNETNUKEDatabase called DotNetNukeCreated a user DotNetNukeUser ; pass DotNetNukeUser with db_owner permissions on the database.Connection string: <!-- the old connectionString setting has been deprecated and replaced with the data provider section below --> <appSettings>  <add key="SiteSqlServer" value="Server=PORTABLE\DOTNETNUKE;Database=DotNetNuke;ui...

Solution to The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] )
Hi, I see many of you are having the same problem installing DNN; DotNetNuke Upgrade Error The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) ERROR: Could not connect to database specified in connectionString for SqlDataProvider I had the same problem and tried everything on this forum to solve it, without any luck. This is what you need to do; Add the user you want to use for DNN (the one you put in the connect string) to the db_owner role. That's all!!! A "normal" user that has full control over the d...

The assembly version [ASSEMBLYVERSION] does not match the database version [DATABASEVERSION]".
hello,friends My name's onlymyhead and I'm very interested in using DNN to study with my PC. I want to install the DNN 2.0 Beta with the OS: Windows 2000 Server, SQL server 2000 and IIS 6.0 on my PC. but IE noted me with the page "The assembly version [ASSEMBLYVERSION] does not match the database version [DATABASEVERSION]".although i have known that it is due to the file of web.config, i cant correct it. please tell me details how to correct the file. windows 2000 server loaded in d:\ sql server 2000 loaded in d:\ thank you very much See thread... http://www.asp...

The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) #3
I know this error has been posted many times, but I couldn't find any reference to it in this context and I could use some help.  Here's the full error: DotNetNuke Upgrade Error The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) ERROR: Could not connect to database.Object reference not set to an instance of an object. This occurred on a system that had been working for several months.  Someone opened the solution in VS, removed and re-added the core DotNetNuke project, and then this error came up.  I have verified t...

DDN stops with The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ), tried a lot...
hi all i know that this error message was discussed often here, but i have looked at some threads discussing that error message, but i am not able to fix it on my own. here's my story: - i have downloaded DNN 3.08, unzipped - i have installed sql MSDE, installed, and also installed sql web data manager from microsoft - i copied the unzipped folder to inetpub\wwwroot\dotnetnuke\ - i have given the aspnet user full control on the folder and all subfolders - i created a database called dotnetnuke, and a database user called dontnetnuker with a password of online, my connect...

Continually getting message "The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) "
I am trying to install DotNetNuke and have been stymied by this error message. DotNetNuke Upgrade ErrorThe Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) ERROR: Could not connect to database.SQL Server does not exist or access denied. I know the database server is up, and I can sign in to it, but DNN absolutely will not work.  I have deleted the database and re-created it twice for this issue, but thus far, none of the suggestions for fixing it have worked.I followed (I thought) the readme  directions that were included in the zip ...

Assembly version does not match Database version
I'm trying for the first time to open DotNetNuke in my browser and get the following error:   DotNetNuke Upgrade Error The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) ERROR: Could not connect to database.Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection. Any suggestions? Thanks in advance   it looks like theres a problem with your connection string...Wessam Zeidan Is that the first time you try to install dotnetnuke ? Is it a local installation. What Version of DNN What o...

The assembly version does not match the database version
Hi, everybody, My name's thuantam and I'm very interested in using DNN to study with my PC. I want to install the DNN 2.0 Beta with the OS: Windows 2003 Server, SQL server 2000 and IIS 6.0 on my PC. but IE noted me with the page "The assembly version [ASSEMBLYVERSION] does not match the database version [DATABASEVERSION]", I think the error caused by my SQL Server. What can I do to fix this error. Thanks, thuantam In there are two places in your web.config that you need to set your own<appSettings><add key="connectionString"....... ensure both plac...

The Assembly Version does not match the Database Version #2
When navigating to the DotNetNuke site, I get this error: DotNetNuke Upgrade Error The Assembly Version ( [ASSEMBLY VERSION] ) does not match the Database Version ( [DATABASE VERSION] ) ERROR: Could not connect to database specified in connectionString for SqlDataProvider It worked when using the default MsAccess database. Then I tried to switch to use MSDE. By for example using ODBC, I can connect to the Database with the user and password provided in the connectionString in Web.Config. This is the only change done: applying sa as uid and a password as pwd in the connecti...

Install error: assembly version does not match database version
I'm just installing DNN for the first time.zip file: DotNetNuke_3.1.0_Source.zipcopied development.config to web.config - modified per install doc (AutoUpgrade=true, UseDNNConfig=true)modified Install\DotNetNuke.install.resources per install docError message:DotNetNuke Upgrade ErrorThe Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) Failed to load Install template.in thanks advancePeter B Did you set the connectionString properties in the new web.config? S. Shawn MehaffiePC Resources, LLC yes:<add key="SiteSqlServer" value="Server=...

Web resources about - The Assembly Version ( [ASSEMBLYVERSION] ) does not match the Database Version ( [DATABASEVERSION] ) - asp.net.dotnetnuke

Using Powershell to Get and Update the AssemblyVersion information in your AssemblyInfo.cs file
I have a need to update our build version number in our various *AssemblyInfo.cs files each and every time we do a release build of our products. ...

Using Grunt to Update the AssemblyInfo.cs version number
Grunt.js is a slick task runner which can be used for stuff other than JavaScript. In fact Our team is using it to build our .Net and Windows ...

Archive
Home Tools Laughing Baby About Login Archive April 2014 (1) February 2014 (1) January 2014 (2) December 2013 (1) November 2013 (3) October 2013 ...

Install Nerdbank.GitVersioning by AArnott · Pull Request #121 · nuproj/nuproj · GitHub
nuproj - Building NuGet packages with Visual Studio and MSBuild

Issues - elmah - Error Logging Modules and Handlers for ASP.NET - Google Project Hosting
My favorites ▼ - Sign in elmah Error Logging Modules and Handlers for ASP.NET Project Home Downloads Wiki Issues Source New issue Search Search ...

Archive
Articles Blog Videos Archive The Good, The Bad, and Everything In Between Sep 2014 Features Of ES6 Part 5: The Spread Aug 2014 Karma Is Not Just ...

Miscellaneous Utility Library
Every so often, someone on the newsgroup asks about something which doesn't exist in the framework, but which I think should. Sometimes, I'll ...

SvnRevisionTool – app .net console dev files windows – unclassified software development
Prints out the current SVN revision info of a working directory and automatically writes it into your .NET project for the build.

Embedding a TFS Build label in all assemblies 2010-03-17
The default TFS build label does not have a xx.xx.xx.xx pattern, but looks like “MyBuild_20070418.1”. So we cant assign the value to the AssemblyVersion ...

Setting Assembly Version with Windows PowerShell
I've been using the Build Version Increament add-in for Visual Studio to automatically set the assembly and file versions. It works fine, however, ...

Resources last updated: 12/19/2015 7:01:10 PM