Install fail on m6.net hosting. Installs up to the line Performing general upgrades.

I successfully managed to install on my dev XP Pro machine but then when I tried to run the install on my hosting provider m6.net I found the DB tables, views, sp are created but that is it.

In the install page I get this error.

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

After I close the page and then return to my site I get this page:

DotNetNuke Configuration Error

Domain Name "www.spilmansoftware.com" Does Not Exist In The Database

DotNetNuke supports multiple portals from a single database/codebase. It accomplishes this by converting the URL of the client browser Request to a valid PortalID in the Portals database table. The following steps describe the process:

1. Web Server Processing
  • When a web server receives a Request from a client browser, it compares the file name extension on the target URL resource to its Application Extension Mappings defined in IIS.
  • Based on the corresponding match, IIS then sends the Request to the defined Executable Path ( aspnet_asapi.dll in the case of ASP.NET Requests ).
  • The aspnet_isapi.dll engine processes the Request in an ordered series of events beginning with Application_BeginRequest.

  • 2. Application_BeginRequest ( Common.Globals.asax.vb )
  • The Request URL is parsed based on the "/" character
  • A Domain Name is constructed using each of the relevant parsed URL segments.

    Examples:

    URL: http://www.domain.com/default.aspx = Domain Name: www.domain.com
    URL: http://209.75.24.131/default.aspx = Domain Name: 209.75.24.131
    URL: http://localhost/DotNetNuke/default.aspx = Domain Name: localhost/DotNetNuke
    URL: http://www.domain.com/virtualdirectory/default.aspx = Domain Name: www.domain.com/virtualdirectory
    URL: http://www.domain.com/directory/default.aspx = Domain Name: www.domain.com/directory

  • Using the Domain Name, the application queries the database ( Portals table - PortalAlias field ) to locate a matching record.

    Note: If there are multiple URLs which correspond to the same portal then the PortalAlias field must contain each valid Domain Name in a comma seperated list.

    Example:

    URL: http://localhost/DotNetNuke/default.aspx
    URL: http://MACHINENAME/DotNetNuke/default.aspx
    URL: http://209.32.134.65/DotNetNuke/default.aspx
    PortalAlias: localhost/DotNetNuke,MACHINENAME/DotNetNuke,209.32.134.65/DotNetNuke
  • Has anyone successfully installed at the hosting provider m6.net?
    Any ideas?

    Thank you for your help

    Stan

    0
    stanomatic
    3/28/2005 5:00:34 PM
    asp.net.dotnetnuke 25171 articles. 0 followers. Follow

    15 Replies
    711 Views

    Similar Articles

    [PageSpeed] 23

    I had a similar thing happening when I was trying to install on WH4L and then realized the problem was I was giving the ASPNET account permissions when WH4L is running IIS6 so I needed to give the Network Service account permissions on the folder structure. As soon as I did this and tried to install it worked flawlessly.  I don't know if this is your problem or not, but it's something to check.
    UNLESS someone like you cares a whole awful lot, nothing is going to get better. It's not!
    0
    the_lorax
    3/28/2005 6:21:48 PM
    When I've seen that type of failure for me in the past it's been a problem with all the files getting ftp'ed correctly. Also want to make sure the permissions are set correctly.
     
    The first part you see is just telling you that you can modify the web.config to show more complete error info by setting it to off instead of RemoteOnly
     
    Good Luck.
    0
    Eppy
    3/28/2005 7:06:01 PM

    the_lorax,

    Thanks for the tip. I called them and they said they are running II6 and are supposed to give me permissions. I will post either way.

    Stan

    0
    stanomatic
    3/28/2005 7:43:46 PM
    No prob. :)  I beat myself up for a couple of days before I figured out the problem I was having. The worst part is I knew about that issue and just kind of spaced it. I felt pretty dumb when I figured it out. LOL  Anyway, I got it up and going and managed to set up a couple of sites including the forums and gallery modules. Now I have to write a custom module or two of my own.
    UNLESS someone like you cares a whole awful lot, nothing is going to get better. It's not!
    0
    the_lorax
    3/28/2005 10:20:47 PM
    The actual problem is that you failed to add the domain alias to your DB before uploading, thus DNN cannot find the domain and is unable to handle it. It can only handle the one you were working with in the format of  localhost/dotnetnuke. Add an alias to your app locally: www.yourdomain.com and perform the upload once again.
    Do you know the truth when you hear it?
    0
    hooligannes97
    3/29/2005 12:36:08 AM

    Stan,

    I think the_lorax has a solution to get this up and running quickly.  I would love to know if this works for you.  If you are letting DNN create your database on M6, I don't think the solution that hooliganes posted is your ticket. 

    Kurt

    0
    MrFortFun
    3/29/2005 5:42:00 AM
     MrFortFun wrote:

    ...I don't think the solution that hooliganes posted is your ticket. 

    When you create your site inside wwwroot, correct permissions are inherited so Network Service has modify permissions for your DNN folder. If your folder is installed elsewhere, then you need to assign those permissions manually.

    From stanomate quoted error, I posted the most probable cause. However, my intention is not to prove myself right. Please post how you solved this, so we can inform the Core Team to provide a different error when this happens. You see if the problem is permissions ypu should not receive this message.


    Do you know the truth when you hear it?
    0
    hooligannes97
    3/29/2005 2:04:54 PM

    Like I said above, I'm not sure this is your problem. The reason I said to check the permissions for the Network Service account is I was seeing the same error. I would get a permissions error when doing the install. The error message would tell me the ASP.NET account didn't have permissions to some file. Then if I hit the site again, I would get the "cannot find your domain in the DB" error because the install was being botched and that part of the setup never happened. My portal DB entries were never being created even though the tables and stored procs were all being created. What I would suggest is making sure you have permissions set up correctly and then if possible clear out your DB and try the install again. Once I had my permissions set up for the Network Service account and cleared out the DB, the install ran flawlessly.


    UNLESS someone like you cares a whole awful lot, nothing is going to get better. It's not!
    0
    the_lorax
    3/29/2005 3:26:52 PM
    After a bit of research, I found that this error says that DNN has tried to parse the name of the URL against the info of the DB, so it does connect to the DB. There's nothing that needs read/write permissions in this procedure so I stick to my suggestion and I specifically ask stanoman, did you add the URL to your DNN before you did the upload? Please do post back and let us know.
    Do you know the truth when you hear it?
    0
    hooligannes97
    3/29/2005 4:55:01 PM
    My point was that the installation procedure should create that entry in the DB for you but if your permissions aren't set correctly, the installation script dies before it gets to the point where it is creating that record in the DB. The permissions issue is only related to the "website not found in the DB" problem in the sense that the install script crashes before the code creating that entry is executed. I never had to manually create an entry in the DB to get my site up and going. I saw the exact same message he's getting when I didn't have my permissions right and tried to reload the site after my installation crashed. Once again though, I'll state that I'm not saying this is undoubtedly his problem but simply something to check. :)
    UNLESS someone like you cares a whole awful lot, nothing is going to get better. It's not!
    0
    the_lorax
    3/29/2005 5:11:02 PM

    Thank you community for so many responses. I am interested in the install of DNN on my hosting provider and not the upload from my dev environment. I may need a little direction from hooligannes97 on what settings and where to set these setting upon install to test his theory. I have read the install doc and set my web.config but I do not see an area to set the portal alias name. When I look at the ftp structure directory it reads: /MYUNSERNAME/MYSITE.com/MYSITE.com. Given that information I went into the DB PortalAlias and entered many different configurations. Examples: /MYUNSERNAME/MYSITE.com/MYSITE.com | MYSITE.com/MYSITE.com | www.MYSITE.com | . Each time I cleared the version table then hit my site to start the install with the same problem, DNN displays the first error in previous post then upon visiting the site again I get the second error. MrFortFun also host at m6.net and we are both trying to resolve this problem. I still am leaning towards the permission issue.

    Stanomatic

    0
    stanomatic
    3/29/2005 5:40:14 PM

    What you have posted above about "custom errors" isn't really the error. It's what is displayed because you had an error occur during installation.

    Try editing your web.config and replacing the line: (this is the default setting)

    <customErrors mode="RemoteOnly" />

    With:

    <customErrors mode="Off" />

    This should allow you to see the error remotely (it may also be a security hole, I'm not exactly sure) Once you change that setting, if possible, clear out your DB completely and try the install again. This will at least allow you to see what error you're really getting during install.

    Note: I couldn't see the actual error code displaying on the screen without highlighting it with the mouse. It was black text on a black background. Run the install again and then highlight the install history to see if there are errors.


    UNLESS someone like you cares a whole awful lot, nothing is going to get better. It's not!
    0
    the_lorax
    3/29/2005 9:08:37 PM
    I have had this error on a couple of occassions on dev servers I was
    installing to. I looked at the error at first and also thought I could
    just add the info to the database and I'd be all set. 

    Fact is the install went bad and you need to start over again. I wiped out everything and pushed the files again, set the permissions, edited the web.comfig for the connection string & object qualifier and off I went.

    While I'm at it I might mention Crystal Tech (www.crystaltech.com) has a developers asp.net plan for 2.95 a month.

    Good Luck!

    0
    Eppy
    3/30/2005 12:39:58 AM

    Update!

    I was put on the back burner at m6.net. The FIX WAS A NEW ISP. http://websecurestores.com/

    No problems here. If m6.net ever figures out the permission thing then I will let you all know. I still have a few site there that I might make DNN.

    Thanks for the info guys.

    Stan

    0
    stanomatic
    4/2/2005 11:58:48 PM
    I use M6.NET as well and I was wondering how you like them.  I have a few bones with those guys Angry [:@] but the problem is I do not know where to go to get the same types of packages from other ISPs.

    pkoanui
    0
    pkoanui
    4/4/2005 1:30:01 AM
    Reply:

    Similar Artilces:

    installing .net 1.1 framework after .net 2.0 framework has already been installed
    I am configuring my server 2003 (standard edition) to host a service application that will be accessed with mobile devices. The requirement for the mobile licenses to work properly is that I install the 1.1 framework. I downloaded the redistributable file and went to install it and was prompted, "The product you are trying to install has already been installed with your operating system. Use Windows update to install the latest updates." Through the "add/remove programs" window there is no indication the .net 1.1 framework is installed. When I navigate to C:\WINDOWS\Microsoft .NET...

    11.1 Net Install fails during package install
    I'm trying to perform a net install of 11.1 and ran in to a problem with package install. Any ideas? I've run the install twice, the first time failing on on a glibc package. I repeated the install and it made it 82% through the package install. The error gives the package name (yast2-network this time) saying it failed. The expanded detail shows a Subprocess failed Error: RPM failed: error: unpacking of archive failed on file /usr/share/... : cpio: MD5 sum mismatch Network error? repo error? or hardware problem? Thanks in advance! -- CobraPA -----------...

    Creating custom installer to install .net framework and installer of another software
     hii m trying to create a custom installer which will install .net framework 2.0 and i have another installer  of a software that i also want to be installed on Install(System.Collections.IDictionary stateSaver) event. Is it possible with custom installer.or i need to use something else like setup Project/Web setup project.please help me out  Regardsnav  Hi nav, Based on my understanding, you want to install .NET Framework 2.0 and another installer with your setup project. If I have misunderstood you concern, please let me know. In my opinion, you need setup boot...

    Anyway to re-install .net framework on a botched install that wont un-install?
      Newbie User (me) 64bit machine Win Server 2008 Beta 3 Data Center  64bit SharePoint Services 3.0 SharePoint Server Project Server SQL Express SQL Server   Ok so All I wanted to do was get a test bed up for Project Server ..   I installed SharePoint Services and Project Server.. it worked ..  the tech update feature had a minor error at the end so as a newbie I just figured I would install Share Point Server to fix it ..  etc   .. then it seemed like I had some missing features in Project Server so I installed the AS DC (Domain controler) ...

    cpan>install NET::SSH ----> Can't install NET::SSH don't know what it is?
    Good day! This is the first time I'll be using the cpan to install modules. I run: perl -MCPAN -e shell and answer the questions one by one. When its done, I issued install NET::SSH at the cpan> prompt and I got the message: Can't install NET::SSH Don't know what it is. Question: How will I make cpan> know what NET::SSH is? Is there something I have to update first? How can I search for some useful modules using cpan> rather than using cpan search in www.cpan.org? What is auto bundle? And what does 'cpan -a' does? When I ran it, I can some...

    Applications that Install the .NET while installing the app.
    Does anyone know what applications currently install the .net framework? Specifically, I'm interested in which Microsoft applications install the .net framework without needing a separate download. For example, does Office 2003 install the .NET framework when the application is installed? Thanks in advance for the help. Steve usually the .net framework is installed by the manufacturer along with the OS. so almost every comp thats being shipped now with win xp has .net 1.1 hth***********************Dinakar NethiLife is short. Enjoy it.*********************** Thanks for th...

    Debian Installation with the Net-Installer RC2
    Debian Installation with the Net-Installer RC2 http://www.osnews.com/story.php?news_id=9271 *********************************************************** Quote *********************************************************** There are many ways of installing Debian, this is just how I do it. This guide is dedicated to all the newbies out there, and users with old boxes. *********************************************************** Unquote *********************************************************** -- Kayode Okeyode http://del.icio.us/kayodeok http://www.kayodeok.co.uk/weblog/ ...

    Inspiron 1000 install problem (11.1, 11.2, net install, dvd install)
    Ok, I have a plain jane Inspiron 1000, 2ghz celeron, 256m ram, 40gig hd, dvd. I burned 11.2 to dvd, 11.1 to dvd, tried installing both. Both get the dreaded "cannot create repository" (i'm paraphrasing). No problem, I download and burn 11.1, 11.2 net install's, checksums check out ok. I go through the first part where it downloads stuff from download.opensuse.com (or something similiar), then it fails again, not able to install. I get no message on the net installs. Just fails real quick with a red box. I tried a text install, fails. What gives? --...

    Installed VS.NET 2002. That installed 1.0, but I HAD 1.1 installed. How to remove 1.0?
    I haven't seen this anywhere, so I figured I would add it here. First of all, it is incorrect to recommend to anyone that who has VS.NET 2002 to do ANYTHING but first install VS.NET 2002. The installl order for VS.NET 2002 and .Net Framwork 1.1 SHOULD BE: 0. Install ALL windows updates for your pc EXCEPT FOR .NET Framwork 1.1 1. Install VS.NET 2002 2. Install MSDE that comes w/VS.NET 2002 (USE A NAMED INSTANCE! Never usee the default instance) 2. Install MDAC 2.8 3. Install .Net Framework 1.1 4. SOMEHOW GET RID OF .NET Framework and get VS.NET and IIS 5.x to work w...

    Installation of datawindow
    I have seen this posted earlier on this forum however there has never been a solution given to the issue of the installation of DW.NET giving the error can not find Visual Studio.NET thus not registering the control. I can go and do this manually in VS.NET however this is a pain in the butt to do. Is there a solution to this problem???? Thanks TPS ...

    DBI install fails / Net-Daemon fails on forkm.t test
    If this is the wrong place for this post, please forgive the intrusion, and perhaps suggest appropriate place? Newbie trying to install Bundle::DBI and using the automated CPAN method. The installation fails at the t/forkm.t test for Net-Daemon. t/forkm.............Starting server: /usr/bin/perl -Iblib/lib -Iblib/arch t/server --mode=fork logfile=stderr debug 1..10 FAILED tests 1-10 Failed 10/10 tests, 0.00% okay I've searched archives, etc. a fair bit and only found a couple of references to a forkm test failure. They were both platform specific issues...

    Failed to install VS .NET
    I tried to install VS .NET into my W2000 server SP2 but never succeeded. Each time i try to install, it just say "User Cancelled Setup" even though i didn't tell it to cancel. The message just comes after like 10mins into the installation after i click install for the 2nd step. When i looked at the log, it says the following steps failed - [09/12/02,09:29:25] Setup.exe: GetGlobalCustomProperty({710A502B-4669-405C-A985-BA21545509BA}) [09/12/02,09:29:25] VS70pgui: ISetupManager::GetGlobalCustomProperty() failed to find global prop in CFinishPage::GetGlobalProperty() [0...

    Utilize .NET 2 [.net 1.1 installed]
    Hi, My PC running Win XP (SP2), .Net Framework 1.1 and 2.0 and VS 2003. I am beginner in ASP.Net. When I try to used a ASP.Net 2 property with a control, shows me error and I also noticed .net framework ver. at the botton of broswer window. What should I do to utilize .net framework 2.0 functionality? Thanks First, you'll need Visual Web Developer or Visual Studio 2005 to create .NET 2.0 sites. In order to deploy a .NET 2.0 site, you'll need to set the .NET Framework version to 2.0 on the ASP.NET tab for the sites properties in IIS. HTH,RyanRyan OlshanASPInsider | Microsoft MVP, ASP.NET...

    Install .Net 3.0 Before Initial Install of VizStudioPro/
    Hi all, I have a new machine (XP 64), and I ran into trouble with the VS Pro install, After a number of start-stops, I decided to uninstall VS Pro, plus the .Net Framework. My next challenge was to install the 64-bit .Net Framework. After a number of failures installing via Windows Update, I decided to download the Framework from Microsoft Download, and the install went just fine. So here is my question? Should I now download and install .Net Framework v, 3.0 before installing VSPro, or should I wait for the install to complete, upgrade to SP1 of VSPro, and then download and install ....

    Web resources about - Install fail on m6.net hosting. Installs up to the line Performing general upgrades. - asp.net.dotnetnuke

    University of Music and Performing Arts, Vienna - Wikipedia, the free encyclopedia
    The University of Music and Performing Arts, Vienna ( German : Universität für Musik und darstellende Kunst Wien , abbreviated MDW ) is an Austrian ...

    Demi Lovato falls on stage while performing Cool For The Summer - video
    DEMI Lovato fell flat on her back during a gig at New York City’s iconic Madison Square Garden venue on Friday night.

    Molybdenum this year's worst-performing commodity
    An obscure metal used to make steel has become this year's worst-performing commodity.

    You think AFL coaches face pressure: what about principals of high-performing state schools?
    Being a high-achieving non-selective state school produces high demand for places and a lot of pressure to keep improving results. Meet Pitsa ...

    The Revenant: Actor Grace Dove talks about performing with Leonardo DiCaprio
    The B.C. First Nations actor who plays Leonardo DiCaprio's wife in The Revenant says she had nothing but great experiences working opposite the ...

    Internet in tears over video of kids choir performing Arabic welcome song
    It’s a shaky and grainy video, but its message is what has the Internet in tears.

    How Are Presidential Candidates Performing on YouTube?
    With a GOP debate tomorrow night , we decided to check in and see how Republican presidential candidates are performing on YouTube. To no surprise, ...

    Israel's best-performing tech stock hasn't sold a single product
    An Israeli upstart which is trying to sell investors on a future in which physical objects materialise with the press of a buttonis attracting ...

    Here Are the Best- and Worst-Performing Assets of 2015
    From currencies to corporate bonds. As 2015 draws to a close, it's time to tally up the best- and worst-performing investments of the year. ...

    Laurie Anderson performing in Times Square tonight for dogs; 'Heart of a Dog' excerpt is this month's ...
    As you may have already seen, a three-minute excerpt of Laurie Anderson's Heart of a Dog film is being shown on Times Square billboards every ...

    Resources last updated: 1/15/2016 1:44:57 AM