The working process (w3wp.exe) doesn't recomile the page or doesn't load the newer version into the AppDomain.

The page doesn't recompiled even if I change it's markup/code or some global
application files such as web.confg, global.asax etc. Recompilation occures only
if I restart the IIS or simply kill the working process (w3wp.exe). 

Did anybody encounter this problem?

Thanks in advance.


Victor Amelkin
R&D, ASP.NET Team
Developer Express Inc.
0
Victor
7/17/2008 1:05:56 PM
asp.net.config-deploy 12495 articles. 0 followers. Follow

6 Replies
149 Views

Similar Articles

[PageSpeed] 42

 Wat made you to think that its not recycling?

Does memory consumption is not coming down, if this made you to believe that its not recycling, how much memory its consuming when you are changing the config or asax page?

 


Please mark it as answer if it resolves the issue.

visit: http://technicalsol.blogspot.com
0
sumitd
7/17/2008 4:07:51 PM

>  Wat made you to think that its not recycling?

I'm not simply thinking so. It's a fact, that the compiler (csc.exe) is not accessed
by the ASP.NET working process (w3wp.exe) when I request the page second time
(and all next times) - checked with the SysInternals Process Monitor.

If all were working fine, the IIS must track changes in the wwwroot folder and it's
subfolder, so when you make some changes in your application files, IIS handles
all these changes and deprecate old assemblies in the ASP.NET temporary files
folder ( + ".delete" to the page assembly file name). So, when you'll access the
page next time, the respective assembly is not found and the page will be compiled.
There is not such behavior in my case. So, when I access the page - nothing happens.


Victor Amelkin
R&D, ASP.NET Team
Developer Express Inc.
0
Victor
7/17/2008 4:43:50 PM

I've already desribed these problems on Microsoft Connect,
but there is no intelligible answer yet: Feedback 356349.


Victor Amelkin
R&D, ASP.NET Team
Developer Express Inc.
0
Victor
7/17/2008 4:52:35 PM

Could you able to see the changes on the page when you access the page next time? 


Please mark it as answer if it resolves the issue.

visit: http://technicalsol.blogspot.com
0
sumitd
7/17/2008 5:12:03 PM
Is file-change notifications turned on? It should be on by default, and it is required for detecting file changes. http://support.microsoft.com/kb/911272 

 


==============================================
If you get the answer to your question, please mark it as the answer.
0
hongping
7/17/2008 5:21:12 PM

Hi HongPing,

My FCNmode value was 1, so the file change notifications haven't being sended.
I've change it to 0, and now all works fine. I hope, it will for a long time.
I only can guess what made FCN turned off...

Thank you.


Victor Amelkin
R&D, ASP.NET Team
Developer Express Inc.
0
Victor
7/17/2008 6:29:58 PM
Reply:

Similar Artilces:

superreview granted: [Bug 239535] [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") : [Attachment 15469
Robert O'Callahan <roc@ocallahan.org> has granted Constantine A. Murenin <cnst+bmo@bugmail.mojo.ru>'s request for superreview: Bug 239535: [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") http://bugzilla.mozilla.org/show_bug.cgi?id=239535 Attachment 154694: patch http://bugzilla.mozilla.org/attachment.cgi?id=154694&action=edit ...

superreview requested: [Bug 239535] [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") : [Attachment 154
Constantine A. Murenin <cnst+bmo@bugmail.mojo.ru> has asked Robert O'Callahan <roc@ocallahan.org> for superreview: Bug 239535: [Mac] nsDateTimeFormatMac is broken in Japanese locale (Page Info fails to load / Media Tab doesn't work / Cookie Manager doesn't show "Expires") http://bugzilla.mozilla.org/show_bug.cgi?id=239535 Attachment 154694: patch http://bugzilla.mozilla.org/attachment.cgi?id=154694&action=edit ...

Spellchecker doesn't work: no error, just doesn't work
Hey all. This is only happening with one person. It's all GW7 no SP. has worked fine before. Anyway when they type along it doesn't catch that spelling and it doesn't fire up spell check before it's sent like it is checked off to do. It does nothing. It just sends it when you click send; no error, nothing. I did a rebuild, analyze/fix. I have it set at all levels for this user. any ideas Mark, well, I'd try a more recent client version first. GW7 was less than stellar before SP1. Uwe -- Novell Support Connection Volunteer SysOp Please don...

Urgent: AutoCompleteExtender doesn't work/Updatepanel doesn't work
This is my code for the AutoCompleteExtender <asp:textbox id="txtQuickSearch" runat="server" CssClass="inputText" style="width:145px; "></asp:textbox> <atlas:AutoCompleteExtender runat="server" ID="acSearch"> <atlas:AutoCompleteProperties TargetControlID="txtQuickSearch" Enabled="True" ServicePath="http://localhost/Sony.BusinessSuite.Web.UI/AtlasServices/MasterData.asmx" ServiceMethod="GetAllModels" minimumprefixlength="2" /> </atlas:AutoCompleteExtender> When i start typing fiddler shows: # Result Host URL Body Caching Content-Type User-...

Freenx doesn't work, NX doesn't work with compiz. Questions
FreeNX just doesn't work. NX from nomachine installed well, but I guess that limits me to two logins? NX doesn't work with compiz, tho, at least from machines not running compiz. So no great surprise. :-) Is there any way to run startkde that disables compiz and uses kwin? Alternatively, hows the easiest way to handle alternative logins? I could link the two documents folders together, but then I'd have problems with file permissions. I'm just looking for ideas here, I could live with two logins. -- dougnc -------------------------------------------...

Custom Datagrid: Doesn't display and doesn't work
Hi all,Hope someone can share their experience! I am trying to make a custom datagrid, only in appearance for now. Results:1. On dragging the control from the VS toolbox: get a grey rectangle, not the table like look. 2. On running the Web page: no HTML.<code>Imports System.ComponentModelImports System.Web.UI.WebControlsImports System.Web.UI<DefaultProperty("Text"), ToolboxData("<{0}:custDG runat=server></{0}:custDG>")> Public Class custDG    Inherits DataGrid    Public Sub New()        Me.BorderColor = ...

keeps making me download update, but, update doesn't work, makes me download update, update doesn't work..................
Name: donald davis Email: galenachefatyahoodotcom Product: Firefox Summary: keeps making me download update, but, update doesn't work, makes me download update, update doesn't work.................. Comments: That's pretty much the whole deal. An update screen pops up, I update, the update doesn't take and the next time I use firefox mozilla the same thing happens over and over and over. Thanks Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.4 ...

Installation 'Sybase DataWindow PS' printer on W98 doesn't work (so PDF export can't work either)
I have a problem with export DataWindow content to PDF on W98 systems. (I don't have any problem with PDF export on other systems like as WINNT, W2K, WXP). I found out that the problem is in the Sybase DataWindow PS printer. It looks like installed but it DOESN'T WORK on W98. When I try print something on this printer then no PostScript file is created. So I tried manual installation of it but it occurs an error during manual installation (I used description of instalation from Bruce Armstrong). The error said that printer driver (PSCRIPT.DLL) can't be loaded. I use...

I don't know why paging, sorting doesn't work in firefox
Hi. I have a gridview and paging and soring enabled but I tested on IE it works perfectly fine but when I load it on Firefox, the page link and sort link don't work at all. I don't know what the problem is. Anybody knows how to make them work on Firefox?  Hi:   It seems your problem is solved here: http://forums.asp.net/p/1183698/2015763.aspx#2015763   This post will be closed. ThanksSincerely,Allen ChenMicrosoft Online Community SupportPlease remember to mark the replies as answers if they help and unmark them if they provide no help....

<location> doesn't work when parent directory of path doesn't exist
Hi, I'm having a problem setting up web.config to challenge for authentication on some pages, but not others. Here is what I'm doing:<configuration>...    <system.web>...        <authentication mode="Windows" />        <authorization>            <allow users="*"/>        </authorization>...    </system.web>    <location path="se...

default 'Save Page As' doesn't work
File->Save Page As (HTML only or Complete) will not save the text on this page: http://www.socionics.com/prof/enfj.htm (When you relead the saved page it loads the socionics home page, and if you disable the internet connection you get a page can't load error.) I searched for an extension that may work, but I don't see one. I regularly use the Highlighter extension and save web pages - research. I often come accross pages that dodn't actually save, and I don't realize this until later when I go to load the saved page. (I'm checking more often to make sure...

Keyboard shortcut 'ctrl+T' doesn't always work
Name: Georgi Liubenov Email: liubenoffatmaildotbg Product: Firefox Summary: Keyboard shortcut 'ctrl+T' doesn't always work Comments: When pdf document is opened in a tab 'ctrl+T' shortcut doesn't work. I have to go to File -> New Tab to open a tab. Browser Details: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 From URL: http://hendrix.mozilla.org/ Note to readers: Hendrix gives no expectation of a response to this feedback but if you wish to provide one you must BCC (not CC) the sender for them to ...

default 'Save Page As' doesn't work #2
File->Save Page As (HTML only or Complete) will not save the text on this page: http://www.socionics.com/prof/enfj.htm (When you relead the saved page it loads the socionics home page, and if you disable the internet connection you get a page can't load error.) I searched for an extension that may work, but I don't see one. I regularly use the Highlighter extension and save web pages - research. I often come accross pages that don't actually save, and I don't realize this until later when I go to load the saved page. (I'm checking more often to make sure ...

the 'new' google home page doesn't work
Google updated their home page a couple days ago, with new tabs and stuff under the hood. I am a Mac user, btw, and now it is waaayyyyy off center with firefox. Works in Safari, Opera, and Camino. For some reason, the left half of the page is white, and everything is off to the right. A setting for me, or something Firefox? Firefox is my default browser, as it should be for everyone, and Google is my default homepage. Why can't we all just get along? Thanks for any ideas or tips or info. T tmagster@gmail.com wrote: > Google updated their home page a couple days ag...

Web resources about - The working process (w3wp.exe) doesn't recomile the page or doesn't load the newer version into the AppDomain. - asp.net.config-deploy

Resources last updated: 12/27/2015 11:29:48 AM