Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral....

Hi I have been developing an application to on VS2008 in C# and now i tried to deploy it for the first time on my windows 2003 server. The app ran great in VS2008 but when i try to deploy it on the server for some testing i get the following. Iv been looking around on the internet and tried chaning line 45 from 3.5.0.0 to 2.0.0.0 etc but it doesnt work. Could any help me understand what is wrong and how i can fix it?

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 43: 
Line 44:           <assemblies>
Line 45:             <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
Line 46:             <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
Line 47:             <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

Source File: C:\Inetpub\wwwroot\CMS\web.config    Line: 45

Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

0
flummer
1/15/2008 10:17:45 AM
asp.net.config-deploy 12495 articles. 0 followers. Follow

5 Replies
2907 Views

Similar Articles

[PageSpeed] 8

You need .NET Framework 3.5 on the server too.

When you install VS2008 on your development machine, .NET Framework 3.5 is installed as well. Also, when you create new web sites, by default the target framework is 3.5, and thus requires 3.5 assemblies to be present ont the deployment environment.

 


==============================================
If you get the answer to your question, please mark it as the answer.
0
hongping
1/15/2008 6:54:36 PM

Right you are.

I tried delpying the website on another server and noticed that i had framework 3.0 servicepack 1 installed but framework 3.5 was not present. After installing that the application started running.

-1
flummer
1/16/2008 6:15:43 AM

I was using Visual Studio 2008 to build an HTTP Module to do some SharePoint munging, and suddently some incremental change I made started generated the error message about 3.5 missing.  Up until that time, my code was running fine with 2.0, but some tiny change suddently started requiring 3.5.  Strange.

Thank you for saving me some time.  This post helped me out.

 

David


David Levine
President, Asparagus Corporation
0
eniveld
2/26/2008 10:40:27 PM

Sorry for being a bit slow. I am very new at this. My hosting provier states they have .Net Framework 3.5 but I am still getting this error. Would someone give me a little detail here?

0
WayneF
7/7/2008 11:12:38 AM

Just an update, as it turns out, my provider did not have .NET framework installed.

0
WayneF
7/13/2008 1:28:13 PM
Reply:

Similar Artilces:

Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
Hi, I am using VS2008 and .net 3.5, #. i m trying to access default.aspx in the browser and it shows the error as "Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified."   Also when i use any of the Ajaxcontrol toolkit tools, i m getting the these kind of errors. I hav copied the ajaxcontroltoolkit.dll and .pdb in the bin folder. but i m getting the same error. Please help me.  I will  be grateful if anyone can send me the co...

Could not load file or assembly 'System.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified
 Hi, I am using Jasper.. I downloaded JASPER and the sample code from http://www.microsoft.com/downloads/details.aspx?FamilyId=471BB3AC-B31A-49CD-A567-F2E286715C8F&displaylang=en but when  i try to run Samples.. I get the error :  Could not load file or assembly 'System.Core, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified i can find only System,Core under 3.5 version. I tried running the project from VS2005 and from VS2008.. still the problem persists....

Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does n
Hello All,If this is a repeat of posting that have been created, I sincerely apologize.  I have been looking for a solution for quite some time and although I have run across a lot of different posts offering solutions, nothing seems to be work.  Here is my dilemma:I have created a website with several pages using ASP.NET 2.0 and AJAX Extensions (including the AJAX Control Toolkit).  The pages run fine on my Development machine but on my IIS machine, I continue to recreate a Parser Error in regard to System.Web.Extensions.  Here is what I have done thus far: I have a...

coplilation error : Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the fi
I have problem compiling my website on 2 machine(win 2003 server & windows vista). The problematics machines has these components installed: 1.Net framework 3.5 sp1 2.vs 2008 sp1 ver: 9.0.30729.1 sp 3.windows sdk for vs 2008 sp1 It works grate on 3 different machines (xp,2003) that has the same components installed and the Microsoft ASP.NET 3.5 Extension CTP. I can't install the Microsoft ASP.NET 3.5 Extension CTP because I already have the .net 3.5 sp1 installed. Here is my web.config ...

mvctoolkit Assembly 'MVCToolkit, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a high
I have visual studio 2008 SP 1 .I created a new MVC Web Project and added a reference to the MVCToolkit dll.I tried to build and it shows following exception Error    5    Assembly 'MVCToolkit, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' uses 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' which has a higher version than referenced assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'    f:\MVC\MVCProjects\MyFirstMVCApplicati...

Could not load type 'System.Web.UI.ScriptReferenceBase' from assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
on my localhost, everything is working just fine, developing a few hours... then i publish to another server (windows server 2003)...and suddenly my website is broken. i could track i down to a scriptreference in my scriptmanager - which used to work perfectly.now i don't know where it went wrong - because i developed several things, including the addition of autocomplete textbox with the control toolkitbut even after removing all the code for the autocomplete textbox, the problem wasn't solved. i seem to be the first one to have this problem, because google doesn't return anythi...

Could not load file or assembly 'App_Web_zdfvephf, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
 When  i tried  to access  my home page  it  shows the following  Error Could not load file or assembly 'App_Web_zdfvephf, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified. Try to Find your project folder from this location, Close your Visual Studio and delete it, and restart your visual studio and then rebuild. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files Hope you are Using ASP.NET v. 2.0. Hope this Helps,-Deepak - DeepakDon&...

Unable to create type 'live:IDLoginStatus'. Could not load file or assembly 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The s
Hello,  I try to use a windowslive website in visual studio 2008 with framework 3.5 I have installed the framework 3.5 and i get following error although the site is working perfect in localhost: Unable to create type 'live:IDLoginStatus'. Could not load file or assembly 'System.Web.Extensions, Version=3.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.After this i check my gac and i manually (with configuration tool 2.0) installed 3.6 in my gac. I still get the same error. What am i doing ...

Could not load file or assembly 'Microsoft.SharePoint.Library, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified
 I get this error when i add the reference of Microsoft.Sharepoint.dll in my web application. My requirement is to display the Performance point Server Dashboards and Reports in my web application. When i deployed this application on the same server where the share point is deployed and tried using the <WebPartPages:SPWebPartManager ID="WebPartManager1" runat="server" EnableClientScript="true"/> control i get the error Object reference not set to instance of an object. I have registered the control using the following: <%@ Register TagPre...

Could not load file or assembly 'Microsoft.ReportViewer.Common, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified
Hi All,   I am facing this problem after publishing the web site on web server.   If u have any solutions of that problem then please reply me.   Thnaks & Regards Dheeraj Mittal dheeraj_mittal02@yahoo.co.in    Have you checked whether Reporting Services is configured in your hosted Server Ashok Rajawww.iGold.inDon't forget to click "Mark as Answer" on the post that helped you. This credits that member, earns you a point and marks your thread as Resolved. This Issue due to Report viewer not installed on web ser...

Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified
I have downloaded the Ajax Control Toolkit Website Project. I want to run on Visual Studio 2005. But when I run the project I got the error like  Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified . </system.web>     <httpModules>        <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neu...

Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
hello i am getting this error in my application...i used ajax in web site..please help me Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.Source Error: Line 30: <compilation...

Could not load file or assembly 'System.Core, Version=3.5.0.0,
I copied the files from my dev server to my production server (my app works find on my development server), but now, I getting this error when I try to launch the app on my production server...  Any ideas what this means or how to fix?  (this is the first time I've ever tried to move an app from dev to production in .NET  Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Me...

Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. #2
Hi, i copied the solution folder   and put this folder to another  computer and i try to run it show the error message " Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified." Please guide me very urgent.Regards,Kannandesikan You need to install the ASP.NET AJAX extensions on the web server. ...

Web resources about - Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral.... - asp.net.config-deploy

Resources last updated: 1/2/2016 1:11:22 AM