A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Background:

I am running a e-commerce website which will call a remote payment gateway when customer check out.

I have tested my web application at my local machine. Everything just works fine. I have no problem to connect my payment gateway

 However, after I have upload all my application code to my hosting company, I cannot check out because my web application cannot connect to the payment gateway

And get following errors:

"

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

Source Error:

Line 154:						OrderNumber = AppLogic.GetNextOrderNumber();
Line 155:						//String status = Gateway.MakeOrder(cart,"Credit Card",String.Empty,CardName,CardType,CardNumber,CardExtraCode,CardExpirationMonth,CardExpirationYear,OrderNumber,String.Empty, String.Empty, String.Empty,String.Empty,String.Empty,String.Empty,String.Empty,String.Empty);
Line 156:						String status = Gateway.MakeOrder(cart,OrderNumber);
Line 157:						if(status != "OK")
Line 158:						{

:

The application code (c#) has used httpwebrequest to create the connection with the payment gateway.

HttpWebRequest myRequest = (HttpWebRequest)WebRequest.Create(AuthServer)

 The payment gateway interface is https://process.gatewaycompany.com/trans.asp

I have checked with my hosting company, they said they have not use proxy on the hosting server, neither have they blocked port 443 for outbound https connection.

I also changed another hosting company. still getting the same error.

I have also added followng cofig parameter in my web.config

" <system.net>

   <defaultProxy>

    <proxy bypassonlocal="true" usesystemdefault="false" />

   </defaultProxy>

  </system.net> "

but still helpless

Thanks for reading this and Please help

 Sad

 

3
bullman
3/21/2007 7:16:46 AM
asp.net.config-deploy 12495 articles. 0 followers. Follow

11 Replies
11671 Views

Similar Articles

[PageSpeed] 59

Hi,

I'm having the same error only in quality testing environment, but it only happened once in a while. Lately it began to happen very often and consistently.

As far as I can tell, there are no network connectivity problems (the web services used are accessible from the web application machines) and no proxys are used.

The proxy config in web.config didn't help either.

Did you find any solution to this problem?

Thank you,

Paulo Cunha
 

0
paulocunha
5/7/2007 3:57:04 PM

 I too am having this type of issue, and tried the suggested fix (I assumed the change went on the web service server's web.config).

Lets see if someone from Microsoft can explain. 


/Bob C in GRR
0
Bob_Chauvin
6/15/2007 3:56:33 PM

 I'm having the same problem!

 Did you find any solution? I'm tearing my hair out here.

 


 

-1
Lois
6/22/2007 2:45:28 PM

 The only solution I found was to install VS on the server.

 Chime in here, perhaps MS will listen if more than one of us complains.

https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=283035
 


/Bob C in GRR
1
Bob_Chauvin
6/22/2007 6:06:21 PM

Yep me too. I'mhaving the same problem. Am trying to do a simple httpWebRequest. Have tried using both intranet and internt URLs and neither work. Keep getting

 A connection attempt failed because the connected party did not properly respond after a period of time

0
ifflanb
6/25/2007 1:17:51 AM

 Please update this page https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=283035 as it is monitored by MSFT.


/Bob C in GRR
0
Bob_Chauvin
6/25/2007 1:49:52 PM

This sounds like a simple network issue.  Either your local network or the payment provider endpoint is too busy or unavailable.  Perhaps you should write your code in a way that will retry the connection a specified number of times.  It may be true that there is some bug or poor code in the framework that is causing this, but it is more likely that the network is letting you down.  After all, no network is 100% available 100% of the time, so it makes sense to write your code accordingly. 

0
Matt
6/25/2007 2:24:50 PM

 

Matt-dot-net:
This sounds like a simple network issue.

I am not sure...

Matt-dot-net:
Perhaps you should write your code in a way that will retry the connection a specified number of times

Useful to avoid exceptions caused by bottlenecks at server side but not sufficient for the described problem when it occurs permanently.

I think, this is a problem caused by the security configuration of the remote server.

1) Should you try first to configure it with Caspol.exe,

 http://msdn2.microsoft.com/en-us/library/cb6t8dtz(VS.80).aspx

2) if 1) does not work, try again with the .NET Framework Configuration Tool (Mscorcfg.msc) (that comes with the .NET Framework SDK (354 MB)  ;-(

Section : Remoting Services/View Remoting Services Properties

Give us please a feed-back with addfulltrust option added to your application server assembly.

David
 

 


 

1
davidimm
10/16/2007 3:45:09 PM

Hello... What if remoting services properties is empty... I see no way to add anything there?problems

EDIT: I'm running IIS7 on windows server 2008 if that means something to you...it's almost vanilla. not much was tweaked.

0
nubie
8/18/2008 4:45:18 PM

I have exactly the same problem, the website is working fine in localhost but not on live. The payment provider endpoint is also available. I have double checked with the gateway provider. It's pulling out my hair and any help will be much appreciated.

I am hosting on a shared server and so I cannot install any tools.
0
ayeayemyo
11/9/2008 8:28:20 PM

I ran into this as well.  My problem was that I needed to send an email from exchange via my web app.  Our exchange server has two IP's (.60 and .62).  I setup the site locally using .60.  When I tried to recover a password using the built-in password recovery tool, while the site was in production, I got the error..  When I changed it to .62, everything worked fine.  Not much of an answer, but that was my issue...

0
buekow
1/23/2009 7:14:25 PM
Reply:

Similar Artilces:

"A connection attempt failed because the connected party did not properly respond after a period of time or established connection failed because connected host has failed to respond IP:PORT"
 Hi all, "A connection attempt failed because the connected party did not properly respond after a period of time or established connection failed because connected host has failed to respond IP:Port"  this is the error i am geeting while sending an email using System.Net.Mail My Code here :MailMessage objMail;        SmtpClient objSMTP;        // Now create the email        objMail = new MailMessage();        objMail.To.Add...

VS2005 IDE: Add Web Refernece. A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has fa
 I have published a web service, but cannot connect to it in VS2005.  The Web Methods display, but I then get this error:A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond I CAN connect to it outside of VS2005 from IE, Stylus Studio, etc.  /Bob C in GRR Hi  Bob, That might be a problem with proxy. Please try this solution: http://west-wind.com/weblog/posts/3871.aspx. Also you can refer to this article: http://msdn.microsoft...

A connection attempt failed because the connected party did not properly respond after a period of time
 When trying to send an email I'm getting this error. What does it mean? Thanks.A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 216.34.131.135:25 Regards, Curt It means that a connection could not be established to the host at 216.34.131.135 on port 25 I have tried to connect to that host, and it is not accepting mail on port 25 The simple way to test this is go to the command prompt and type: telnet 216.34.131.135 25 this will try and ...

Connection Failed Activation of Network Connection Failed
I am running openSUSE 12.1 Beta 1 GNOME and I cannot get an internet connection. The wireless on my laptop says missing firmware which is fine. It says this on any distro and I can get it working. However, I can not get my wired connection to work. It keeps trying to connect and says "Connection Failed Activation of Network Connection Failed. I have seen other people have this problem online somewhere and they said they had to swap something from manual to auto, but I am not sure what or where. I know that this laptops ethernet card will work fine on here b/c I used ope...

superreview granted: [Bug 219376] Trying to resolve IP's via DNS (Failed connections stall instead of giving Connection Failure Error; pages stop/don't finish/complete loading if ad hosts/scripts fail
Brian Ryner <bryner@brianryner.com> has granted Darin Fisher <darin@meer.net>'s request for superreview: Bug 219376: Trying to resolve IP's via DNS (Failed connections stall instead of giving Connection Failure Error; pages stop/don't finish/complete loading if ad hosts/scripts fail) http://bugzilla.mozilla.org/show_bug.cgi?id=219376 Attachment 132718: v1.1 patch http://bugzilla.mozilla.org/attachment.cgi?id=132718&action=edit ...

not connected when I am connected
What do I need to change on my 'puter when the icon in the toolbar shows and tells me I am connected and the error message tells me I am not and I can not go to web pages, get or send emails. I have to close down and restart to get connected again. This only happens if I am on line and leave the 'puter for an hour or so. As long as I am using it I don't have a problem. This just started about a month ago. I am on very slow dialup, DSL and Cable not in my area, thanks you SBC/ATT tks Elaine wrote: > What do I need to change on my 'puter when the icon in ...

Failed to Connect Firefox can't establish a connection
Hello, I get "Failed to Connect Firefox can't establish a connection to the server at 127.0.0.1:3580." when I try to open a Help File of one of the applications I have. My /etc/hosts file has its entries right: 127.0.0.1 hostname.hostdomain hostname My firewall is also disabled. nmap -sT -O localhost gives me (I have included some): 2401/tcp open cvspserver 2601/tcp open zebra 5900/tcp open vnc 8009/tcp open ajp13 8085/tcp open unknown Device type: general purpose Running: Linux 2.6.X OS details: Linux 2.6.17 - 2.6.25 I understand that the port ...

Connection established
Huge problem at the moment: I am connected to the internet via Wifi (NetworkManager) - and Konqueror tells me I am ONLINE in our local library. They run an open network and users need to log in on a special website to get full internet access. As stated, my computer tells me I would be online, but I don�t have any connection (neither via FF, nor via Konqueror). Same applies when connected via Ethernet. Oh, and I�ve already tried to use and change settings with traditional method with ifup... Strange: In my own villa everything works perfect. * ANY HELP IS VERY MUCH APPRECTIATED. ...

database connection failed with connection cache
I have a connection cache on jag 3.6.1 using com.sybase.jdbc2.jdbc.sybdrives. I am able to ping the connection in jag manager. My problem is in PowerJ 3.6.1. I setup a transaction object using the database wizard(very cool), change it to use a cache and even find the connection cache on the server. when I try to test the connection, I first select a profile jconnect5 and try the connection. I get this error: database connection failed jz006: cought a IoException java.net.connectionException connection refused, no further info. any ideas would be great! You can only...

System.Exception: System.Web.HttpException: The transport failed to connect to the server. System.Runtime.InteropServices.COMException (0x80040213): The transport failed to connect to the server.
I have an application which creates about 50 XML packages and sends a notification about the success/failure of every package. I am running this code in threads and I have restricted maximum no. of threads that can be active at any time to 2.So the package generation and the notification would be performed for 2 packages in parallal. But while sending notifications to users, I am getting the below error only for very few packages[ 1 or 2 out of 50] . The same base code is used by all the packages but i am getting this error intermittently. System.Exception: Error sending mail to [So...

Web resources about - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond - asp.net.config-deploy

Category:Awards established in 1973 - Wikipedia, the free encyclopedia
Wikipedia® is a registered trademark of the Wikimedia Foundation, Inc. , a non-profit organization.

Does Facebook’s Board Of Directors Need More Experience In Established Companies?
The appointment earlier this week of Facebook Chief Operating Officer Sheryl Sandberg to the social network’s board of directors eliminated the ...

Friends of Mike Patterson Trust Established - Facebook
Friends Of Mike Patterson hat eine Notiz mit dem Titel Friends of Mike Patterson Trust Established geschrieben. Du kannst den vollständigen Text ...

Which Established Facebook Platform Apps Are Spreading Most Quickly Today?
On the first official day of Q3 2009, which established apps are still growing the most quickly? Here are the numbers from AppData on today’s ...

Beats by Dre Presents: LeBron James in ‬RE-ESTABLISHED 2014 - Powerbeats2 Wireless‬‬‬ - YouTube
The words “Akron Est. 1984” are inked on LeBron James’ body. Moving back to Cleveland in 2014 is the re-establishment of his legacy in Northern ...

Judicial watchdog established despite concerns from Bar Association
A new judicial watchdog has been established to hold judges and magistrates accountable for minor offences and to respond to complaints from ...

Canberra Raiders going against the tide in recruiting established representative players
The Canberra Raiders are going against the tide in attempting to recruit established representative players, with just 30 per cent of this year's ...

Sydney siege: Foundation established in memory of victim Katrina Dawson
The family of Sydney siege victim Katrina Dawson has established a foundation in her memory, and have also made plans for a memorial service ...

City to Gungahlin light rail community reference groups to be established
The ACT government has put the call out for members of new community and&nbsp;business reference group for the city to Gungahlin light rail project.&nbsp; ...

Newly established Men's Shed robbed, trashed - The Courier
SEBASTOPOL Men’s Shed members feel violated after their facility was broken into and valuable items were stolen.

Resources last updated: 1/18/2016 10:28:32 AM