Gridview height="300px" works but height="40%" doesn't work

I want to divide to top-half (40%), bottom-half(60%). So I can put a gridview in top-half with scroll and put a chart in bottom-half. So when users with different resolution can see same table layout.

But the problem is that if I set the gridview as pixel(such as 300px), it works. If I put the percentage(such as 40%), gridview just shows the whole data(which is more than 40% of height) even thought it supposed to limit its hieght to 40% and make it scrollable. I tried to do stuff in css and everything I know, it's not working. Somebody please help me with this!

 

0
wizbay
6/14/2006 6:43:03 PM
asp.net.client-side 24353 articles. 0 followers. Follow

2 Replies
103 Views

Similar Articles

[PageSpeed] 32

Trying removing DOCTYPE from the page, grid will then render properly in page.
 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
~ Firoz Ansari
Pune, India
http://www.firozansari.com
Why product testing is important?
0
firoz
6/17/2006 9:25:46 AM
Firoz:

What is the idea here? Essentially I am asking why we need to remove it.


0
DotnetLearner99
8/10/2006 4:46:08 PM
Reply:

Similar Artilces:

Alps touchpad "back" and "forward" gesture doesn't work
Name: PGG Email: petergeorgegoetz at netscape.net Product: Firefox Summary: Alps touchpad "back" and "forward" gesture doesn't work Comments: The Alps touchpad is set up to use the scroll area at the top of the pad as "back" and "forward" controls for browsers. Scrolling a page up and down DOES work with touchpad gestures. It works with IE 6.0, but doesn't work with any Firefox version. BTW, it doesn't work with Opera 8.5 either. The Alps driver is 5.4.102.12. I've seen lots of requests for help with thi...

"Change columns" and "Remember search" doesn't work in Bugzilla
hi, "Change columns" and "Remember search" doesn't work in Bugzilla. Clicking on these buttons throws "Page cannot be displayed Technical Information (for support personnel) Error Code: 500 Internal Server Error. The request was rejected by the HTTP filter. Contact the server administrator. (12217) " I am using Bugzilla version 2.22.7, Bugzilla is hosted on Linux server. Any hint on this problem will be of great help. thanks & regards Dhananjaya Guten Tag chintu apr, am Freitag, 13. Juli 2012 um 07:23 schrieben ...

FF 3 beta 3
Name: Jeff Reynolds Email: jeffdotkvnfatgmaildotcom Product: Firefox Release Candidate Summary: FF 3 beta 3 - "send link" or "mailto:" doesn't work if T-Bird already running Comments: Howdy! If Thunderbird is already running, Firefox3 b3 returns an error message if a "mailto:" link is clicked or the "Send Link" menu item is selected. text: "Thunderbird is already running but is not responding. To open a new window you must first close the existing Thunderbird process or restart your system." Win XP, T-Bird 2.0.0.9, Fir...

Like "'" + Billtocompany + "%'" does not work
Dear All,  I have put the following code and not records returned. Do you know Why? Even I have set the variables to be empty string. SQL Data Source: <asp:SqlDataSource ID="SqlDataSource1" runat="server" ConnectionString="<%$ ConnectionStrings:THL2ConnectionString %>"     SelectCommand="SELECT BLInv.InvNo, .....from ...... WHERE (BLInv.BilltoCompany like @BillToCompany) AND (BLInv.CountryCode like @CountryCode) AND (BLInv.Quarter like @Quarter)">        <SelectParameter...

"View Image" works, "Show Image" doesn't, in www.shilohproject.com
Name: David Beaucage Email: ShilohProjectatgmaildotcom Product: Firefox Summary: "View Image" works, "Show Image" doesn't, in www.shilohproject.com Comments: These images are Flash Text, installed through Dreamweaver. There may be something wrong with my settings as related to viewing images, independent of Firefox 3 -- something I did in Firefox 2 made the comic-strip images in Comics.com disappear and remain invisible whatever I did. The other images behaved like the Flash Text in ShilohProject.com. Browser Details: Mozilla/5.0 (Windows; U; Windo...

Run("ping.exe " + XX + " >\ping.txt") doesn't work???
Hi, Run("ping.exe " + XX + " >\ping.txt") doesn't work. Do you have an idea? Thanks A.Willemann I have my answer : ls_cmd = "cmd.exe /c ping.exe -n 1 " + as_ping + " > \ping.txt" li_ret = RUN( ls_cmd, Minimized! ) and work with Windows CE. "Ang´┐Żlique Willemann" <angelique.willemann@logica.com> wrote in message news:48ef3778$1@forums-1-dub... > Hi, > > Run("ping.exe " + XX + " >\ping.txt") doesn't work. Do you have an idea? > > Thanks > A.Willemann > ...

superreview granted: [Bug 369767] "About" and "Preferences" menuitems doesn 't work when running Venkman
Mike Pinkerton <mikepinkerton@mac.com> has granted Josh Aas <joshmoz@gmail.com>'s request for superreview: Bug 369767: "About" and "Preferences" menuitems doesn't work when running Venkman https://bugzilla.mozilla.org/show_bug.cgi?id=369767 Attachment 259741: fix v1.0 https://bugzilla.mozilla.org/attachment.cgi?id=259741&action=edit ------- Additional Comments from Mike Pinkerton <mikepinkerton@mac.com> rs=pink ...

Using "New" for "Object reference not set to an instance of an object" error doesn't work...
Hi, I'm trying to build a sql insert statement by reading through each textbox the footer of a DataGrid control. Here's my datagrid code:<asp:DataGrid ID="Datagrid1" runat="server" OnPageIndexChanged="dgPersonnelType_PageChanger" AutoGenerateColumns="False" CellPadding="4" AlternatingItemStyle-BackColor="#FFFFBB" AllowPaging="True" PageSize="20" ShowFooter="True"> <ItemStyle BackColor="WhiteSmoke" Font-Names="verdana" Font-Size="10px" /> <Columns> <asp:TemplateColumn HeaderText="Insert"> <HeaderStyle BackColor="#CCCC99" Font-Bold="true" ...

superreview requested: [Bug 369767] "About" and "Preferences" menuitems doesn't work when running Venkman
Josh Aas <joshmoz@gmail.com> has asked Robert O'Callahan <roc@ocallahan.org> for superreview: Bug 369767: "About" and "Preferences" menuitems doesn't work when running Venkman https://bugzilla.mozilla.org/show_bug.cgi?id=369767 Attachment 259741: fix v1.0 https://bugzilla.mozilla.org/attachment.cgi?id=259741&action=edit ...

why doesn't "work offline" work?
I would like to be able to take my laptop on the airplane and review past pages I have visited on Firefox 2.0.0.11. Years ago, when using an earlier version of Internet Explorer (like version 2.0), I had this capability. Now, I just can't seem to figure out why "work offline" or the cache set to 800MB isn't enough to make this feature work. I can see the history file where I have been for the past 6 months, I just can't pull up pages, even ones I visited just hours before. I have even tried Opera, thinking it might be better, but it didn't seem much better...

Searching "Entire message" Doesn't Work"
When searching for text within messages in News groups all I get is "No Matches Found". Searching for text within messages works ok for Email. Is this a bug? Phil Phil wrote: > When searching for text within messages in News groups all I get is "No > Matches Found". Searching for text within messages works ok for Email. > Is this a bug? > Phil Are you downloading the News Group messages for off line use? (Tools > Account Settings > {SELECT THE NEWS GROUP} > Synchronization & Storage > Select Newsgroups for Offline use...") ...

<div style="..."> works, but <div class="sameStyle"> doesn't?
Got a bit of a bizarre scenario here. When I add the following style to a div: <asp:Content ID="Content2" ContentPlaceHolderID="contents" Runat="Server"> <div style="height: 50px; background: pink url(/img/icons/remove.png) no-repeat bottom right; border: solid 1px red;"> test<br /> <asp:ContentPlaceHolder ID="contents" runat="server"></asp:ContentPlaceHolder> </div> </asp:Content>   The page works great - the div is displaying the ...

superreview requested: [Bug 380538] <body ononline="..." onoffline="..."> doesn't work
Chris Double <chris.double@double.co.nz> has asked Jonas Sicking <jonas@sicking.cc> for superreview: Bug 380538: <body ononline="..." onoffline="..."> doesn't work https://bugzilla.mozilla.org/show_bug.cgi?id=380538 Attachment 264962: Patch to fix issue when defining both offline and online handles in the body element https://bugzilla.mozilla.org/attachment.cgi?id=264962&action=edit ------- Additional Comments from Chris Double <chris.double@double.co.nz> Fixes the problem where if both an ononline and onoffline attribute was used...

superreview granted: [Bug 380538] <body ononline="..." onoffline="..."> doesn't work
Jonas Sicking <jonas@sicking.cc> has granted Chris Double <chris.double@double.co.nz>'s request for superreview: Bug 380538: <body ononline="..." onoffline="..."> doesn't work https://bugzilla.mozilla.org/show_bug.cgi?id=380538 Attachment 264962: Patch to fix issue when defining both offline and online handles in the body element https://bugzilla.mozilla.org/attachment.cgi?id=264962&action=edit ...

Web resources about - Gridview height="300px" works but height="40%" doesn't work - asp.net.client-side

Resources last updated: 12/13/2015 2:03:32 PM