Ajax application not working when deployed to web server

Follow
Email

I installed the extender and then the toolkit and was able to create the sample application described here: http://ajax.asp.net/ajaxtoolkit/Walkthrough/UsingSampleExtender.aspx

 However, when I deploy the webpage to my company's web server I get the following error when I try to run it:

Server Error in '/ajaxtest' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. (E:\WebSites\ajaxtest\web.config line 41)

Source Error:

Line 39: 		</httpHandlers>
Line 40: 		<httpModules>
Line 41: 			<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
Line 42: 		</httpModules>
Line 43: 	</system.web>


Source File: E:\WebSites\ajaxtest\web.config    Line: 41


 The file it is referencing (E:\WebSites\ajaxtest\web.config) is there. Does anyone have any idea what's going on? I've Googled the problem and searched on here but nothing seems to work.

Thanks in advance!

0
Reply Tyleulenspiegel 3/26/2007 3:52:13 PM
asp.net.ajax_control_toolkit 17816 articles. 3 followers. Follow

7 Replies
119 Views

Similar Articles

[PageSpeed] 22
Do you have System.Web.Extensions.dll in the bin directory in the server?

Nuno Agapito
www.infortucano.pt

Don't forget to click "Mark as Answer" on the post that helped you.
This credits that member, earns you a point and marks your thread as Resolved.
0
Reply Agapito 3/26/2007 5:06:07 PM

Do you mean the bin application of my AJAX enabled web app?

 If so, that particular DLL is not in the bin folder, but it's not in the bin folder on my local machine either and it runs fine there. It just doesn't run on the web server.

0
Reply Tyleulenspiegel 3/26/2007 6:03:21 PM
If you don't have a bin of your application in the bin folder, maybe it's because you don't have a webApp project but a web site project. But, in both cases, you should have more dll's in the bin folder and that dll's should be copied to the bin folder on the server!

Nuno Agapito
www.infortucano.pt

Don't forget to click "Mark as Answer" on the post that helped you.
This credits that member, earns you a point and marks your thread as Resolved.
0
Reply Agapito 3/26/2007 8:30:45 PM

That's true. It is a web site project and not a web app project. However, I do have a bin folder for the application on my development machine and the server. When run on my development machine the application works, but when run on the server it doesn't. And neither bin folder has the dll you mentioned.

 I'm sorry if I was confusing before.

Regardless, I will see about getting that dll into the proper folder and see what happens from there. Thanks again for your help and advice!

0
Reply Tyleulenspiegel 3/26/2007 8:36:59 PM

The dll you need should be here:

C:\Program Files\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\v1.0.61025\System.Web.Extensions.dll

Put it on bin folder on server and it should work, I hope. :P 


Nuno Agapito
www.infortucano.pt

Don't forget to click "Mark as Answer" on the post that helped you.
This credits that member, earns you a point and marks your thread as Resolved.
0
Reply Agapito 3/26/2007 8:53:00 PM

SWEET! That did the trick!

 Thanks a million, Agapito! I really appreciate it.

0
Reply Tyleulenspiegel 3/26/2007 9:05:33 PM

Gracias!  Friend!  it worked. 

 

Yes


hittem in the head ed.
0
Reply Webmonkeymon 3/31/2007 11:56:52 PM
Follow
Email
Reply:
Similar Artilces:

Ajax call works fine when run under debugger (Visual Studio) but when deployed to web server responsetext is always empty
Hi, I'm writing an Asp.Net web app that mines IIS log(s) based on users' search criteria.  The web app has a pool of background threads to search multiple files in parallel.  Even so it can take some time as our IIS logs are large.  To keep the user informed of the search progress I used Microsoft.XMLHTTP object to make http requests (response has status) which I display via the document.title.  When I run this under Visual Studio debugger it works great.  I deployed it to a Windows 2003 server under IIS.  Now when the XMLH...

AJAX not working on deployed server, but works on test server
Hello, I tried to search on this question, but I'm not sure how to form it, so if it has been answered, my appologies. I had an application developed by a 3rd party company using ASP.NET (2.0, C#) and AJAX.  On their test server the AJAX is working.  I have a page that has three drop downs.  The top drop down populates the second and the second populates the third.  On my production box, the app is not getting the new data for the second and third drop downs.  (But it does on the test server)  I am running MS 2003 server with IIS and ASP.NET and AJAX insta...

Web application on same server as SQL Server 2005 does not work
Hi all I have a web application on a machine (running on WINDOWS SERVER 2003) which also happens to have SQL Server 2005 also installed. The Web App uses the database on the SQL Server. Reporting Services is also set up, which also means report server is setup on that same machine. My problem is that the web app above works perfectly when I run it from my local machine or our test server (both accessing the SQL Server above) but when I run the app from the machine where SQL Server resides, the forms authentication does not work, and any session data is completely removed for no reason...

Deploying Ajax application in a server without Ajax extensions installed
Hi.I'm thinking on depliying new (to be developed) application which will use Ajax Toolkit to hosted server in which Ajax extensions aren't installed and I cant intall it.It is posible just adding the required files to the web application and doing some configuration on Web.config?TIA.  Yes, providing the server is running in full trust mode.  If the server is configured to run in a lower trust mode, I don't think it will work. If server is configured to run in full trust mode, simply upload the AJAX dlls into the application bin directory.BruceDiscountASP.NET: Devel...

Ajax features not working on the server where ajax enable site is deployed
Hi, I have a web site devoped using AjaxControlToolkit 3.0 and VS 2008. all work well on my machine, but if I try to host the site on a server having OS windows server 2003 and IIS 6. Ajax feature of the web site do not work, like calender extender of mask edit extender. bin directory of my web site contains Ajaxcontroltoolkit.dll and other folder required. Any help or pointers on this is highly appriciated.  regards, pravincheers,  are you getting any errors?  if so, pls post em.BruceDiscountASP.NET: Developer Ready ASP.NET Web Hosting- Microsoft Gold Certified Partner- ...

Web setup project to deploy a Web application to a target server
I am working on Visual Studio 2005 web setup..I need to customize installation address, scenario is as follows:  I have web setup (.msi) on my machine..while installing the website, the setup is capturing current machine websites to install the website. I want to install the website on different server...I must be able give the IP address of my target server and expecting the websetup to install the website on target server. Only websetup .msi is available on my current machine, i also have the access to target machine. Is there any way that would do my requirement? Copy pr...

Deployment instructions/process of ASP.NET web application to the Web Server.
Good afternoon All, I am developing a multilingual ASP.NET Web Application (AJAX for javascript multilingual ). Could somebody guide me or help me? I really appreciate your help. (1) Deployment instructions to the web server (or links from where i can get this information) for deployment of multilingual ASP.NET Web Application. (2) Can the asp and asp.net share the same virtual directory (I mean can asp and asp.net pages in the same virtual directory) on the web server. Should i take some precautions before deployment? (3) What i have to do with the resource files. I mean deployment i...

Report works fine from web server but not from asp.net web application
I have a report that works fine from the reporting server but not when called from the asp.net application using a link to the reporting server where the report is located. I also checked the parameters and all values are correctly being passed. When I run the report from the server itself i.e. by logging onto the web server everything works well, but not when I use hyperlink from the wb application. Hi,  From your description, you mentioned the report can be accessed directly from the report server, but when you deployed it into an asp.net application, it failed to work, right?&nbs...

AJAX on iis7 not working on web host but works on my iis6 Development Server
I have AJAX on my asp.net 2.0 site, my development server has iis 6 and have recently begun using a web host that supports AJAX and runs iis 7.  Everything runs fine exept AJAX.  I don't even get an error it usually just performs a full post back when I click on an AJAX link.        I have been searching for weeks for something to help me.  By the way, my web.config does contain: <xhtmlConformance mode="Transitional" /> I would really appriciate any help on this matter, I have run out ideas on this ...

What is reason why application works perfectly on local development server but not on the web server
We have an application where some of the aspects work through the web pages and other aspects do not even though the entire application works without fault on the development machine.  Is there a setting within Visual Studio 2005 which needs to be altered?  The first of our problems was in this function: private void SaveImages() { if (Session["UserType"].Equals("Customer")) { if (FileUpload1.FileName != "") /* { ResizeImage(300, 300, FileUpload1.PostedFile.FileName, Server.MapPath("~\\Customer\\" + Session["username"].ToString() + "\\Classifieds_Images\\") + FileUpload1.Fi...

threaded web application not working on Windows Server 2003 Web Edition
Apologies if this is in the wrong forum area - can it be moved if this is the case? I am developing a vb.net aspx web application, which accepts data over the internet, and then processes, before sending a reply. I have been asked to change it so that the reply is sent as soon as the data has been properly received, and then perform the processing without making the client wait. I have implemented this by starting a thread to do the processing. This way, the reply is sent much quicker. This works perfectly well on my development machine (Windows XP Pro), but when I post it up to...

Unable to Publish the ASP.Net (AJAX enabled) web application on the web server
Hello,I am a newbie to ASP.Net. I created my first web application using ASP.Net.The project compiles and runs perfectly from my local machine.I did a copy website from my local application onto the web server.Now, when I open the server website on the VS Expresss Edition, and build it. I get Errors that says:Error 1 Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. \\\wwwroot\\Form.aspx 396 Error 107 Element 'CalendarExtender' is not a known element. This can occur if the...

Microsoft AJAX Application Works On LocalHost But Not Web Host
I recently made some changes to a example site: http://www.countrycodelist.com. The site functions correctly on my computer but when I upload it to a remotee server it does not.  I have tested it in both medium and full trust and it still does not work on a remote host. The URL of the page that I want to become the primary page is here: http://www.countrycodelist.com/Default_Test.aspx  The code for the web service calls and bridge is almost entirely based on the example here: http://www.asp.net/learn/videos/view.aspx?tabid=63&id=66.  It works on my personal computer fi...

Deploying web application to server
When I build web application on my local server is there a way to transfer it to another witout need to compile it again wish Visual Studio? And how? Thanks for any info on this subject... Hi, you can simply FTP all your site files (web.config, aspx, ascx, asax, image files, etc) to your web server. Then FTP the dll file in your bin folder to the bin folder on the new server. Or you can use "Copy Project..." in VS.net to copy your production files to a server. ...

Ajax is not working on application server
Hi guys, I am using asp.net Ajax extensions on my web application, it worked fine while debugging but when i implemented my application through IIS it didnt work as i want...It keeps refreshing as if there is no Ajax tools what so ever...I tried doing ajax application using javascript (without Ajax extension tools) and worked fine in both debugging and IIS.What seems the problem?  is there something missing in my web.config that i need to configure? Thanks Did you install the ASP.NET AJAX extensions on the server?  (If not using .Net 3.5) If using .Net 3.5, does the server ...

Web service (uses COM object) works through VS built-in Web server, but fails when deployed in IIS
hi all, I have a asp.net 2.0 web application project with a web service. the web service returns a dataset, based on input params. When I run the web service using F5, it works (it is being served by VS built-in web server), but when I run the web service from browser, it hits the IIS (i already set up the virtual directory) and i dont see any data in the output XML. The web service uses reference to an Interop dll for COM object. I am sure there is a prob with interop dll, as other web services seem to work fine.. I searched a lot but could not figure out this weird behavior.. ...

Pls describe , Deploying "Microsoft Reportviewer with ASP.Net in VS 2008" Web Application to WEB Server
   Hi, I am using VS 2008 , I have doubt for uploading Microsoft Reportviewer with  ASP.net WEB Application Pls describe , Deploying "Microsoft Reportviewer with ASP.Net in VS 2008" Web Application to WEB Server   Regards Praveen    ...

Deploy web application on another server.
I'd like to create a setup app for my web application. It will install Web app in IIS and database for the user but I do not know how to that.Sometimes I download samples on the Internet which allow user to do that.Pls help me to do this.Thanks in advance. Regards,pcpvphuc       In Visual Studio, you can create a Web Setup Project.  Johan TheunissenMCPD, MCSE, MCTS BizTalk 2006==============================Please mark the most helpful reply/replies as "Answer". Thanks for your response.I know that but I also want to install database&nbs...

AJAX Not Working in Existing Web Application
I installed ASP.NET AJAX and it works in a new web site (so it's working on my box), but not an existing web site.  I watched the video on adding AJAX support to an existing web site and did that exactly.  I have painfully checked every character and setting in the web.config, projects, solution, etc. but it still won't work.I added an exact copy of the ASPX page used in the demo for adding AJAX to this existing site, the one with the 3 dates, one being in an update panel, and it doesn't work - the entire page refreshes from the server every time.  A confirm button extender do...

Ajax application slow when deploy to server
i have an ajax web application (ajax.net 1.0) written in ASP.NET 2.0  The application runs fast on my local pc. When I deploy the application to server (windows 2003) as a web site, it's very slow.. funny thing is if I create a virtual site under the root (the main web site), it's become fast again. Anyone encounter similar problem before? I didn't install ajax on the server, I just copy the binaries files. The application runs fine just that it's slow under main web site and not the virtual directory site. One of the most common causes of an AJAX application running...

deploying web application on production server
hi folks, we have a wen application and of which we are doin production support. so after some time we so some enhancements, bug fixes and then deploy the code onto the webserver. please tell me what is the best way to do? 1) should i create a .msi file of complete application with increased version and then deploy the application? 2) should i just copy the .aspx and dlls into the wwwroot folder? 3) And is there any way thru which i can just update the production server with changed files only. Something like a patch release? Where I do not re-write the entire folder content. ...

More then one web application on server is not working
Hi everyone, I have a problem with deployment of my applications to servers which I seem not to be able to solve. If I have one application on server everything seems to work fine. If I want to put there another, here the problems start. The application starts reporting strange errors. If I restart IIS and run the second application, the application runs fine. But now if I want to run the first application this one is not working. It seems that the application generates the error already in Session_start never reaching the default page. The server has W2K and IIS 5. On my develop...

how to deploy the web application on different server?
Now, I write the web application using VS.NET on my own PC, but I need to copy the file from my PC to the development server. I try to copy all files from my working directory to the folder at the server and mapping the virtual directory on IIS as well. However, they can't work ( I wrote all the code on the codebehind page) and prompted error at the "Authenication" part at the web.config file, I don't know how to fix it. As I know, all the codes are compiled into the DLL after build the application, so no need to copy the .vb file. Before compiled the application, I switched th...

AJAX AutoComplete not working on our web server
Hi,  I have a basic AJAX enabled website that has the AutoComplete and Tab features. The website and both AJAX features work flawlessly within my test environment (desktop and laptop) but when I upload the exact files to our web server the AutoComplete does not work. Meaning, when you start typing the autocomplete drop-down box never appears. The web server and my test enviorment have installed the same version of the AJAX extensions and AJAX Toolkit; however, the web server does not have Visual Studios installed. Does anyone have any ideas why this feature might not be working ...