"Error Creating Control" - Accordion.Panes - in design view.

'Panes' could not be initialized. Details: 'Panes' could not br added to the collection. Details: Object does not match target type.

I'm getting this error while trying to turn to design view, I'm using the build 6213.

here's the example code:

1    <%@ Control Language="C#" ClassName="TestAccoCont" %>
2    <%@ Register Assembly="AtlasControlToolkit" Namespace="AtlasControlToolkit" TagPrefix="atlasToolkit" %>
3    <atlas:ScriptManagerProxy ID="scriptManager" runat="server" />
4    <atlasToolkit:Accordion ID="operate_container" runat="server" CssClass="Operate Accordion">
5    	<Panes>
6    		<atlasToolkit:AccordionPane ID="tag_container">
7    			<Header>
8    				asd
9    			</Header>
10   			<Content>
11   				123
12   			</Content>
13   		</atlasToolkit:AccordionPane>
14   		<atlasToolkit:AccordionPane ID="find_container">
15   			<Header>
16   				dsa
17   			</Header>
18   			<Content>
19   				3221
20   			</Content>
21   		</atlasToolkit:AccordionPane>
22   	</Panes>
23   </atlasToolkit:Accordion>
  
0
aldwis
9/19/2006 8:21:51 PM
asp.net.ajax_control_toolkit 17816 articles. 1 followers. Follow

11 Replies
1084 Views

Similar Articles

[PageSpeed] 33

Try adding a runat="server" to your AccordianPane tag
0
MickOBrien
9/19/2006 10:21:24 PM

MickOBrien:
Try adding a runat="server" to your AccordianPane tag

 

no, it's not successful. 

 

 

0
aldwis
9/21/2006 11:20:37 PM

Hi !

Thats the same we got (se my post yesterday). I even got in the toolkit demonstrationproject - so its probably not i the code !

The Accordion still runs but it doesn't work in the designview. Seems to be some problem with Visual studio and the new Toolkit.

Sorry to say - but we backed up to previous release after spending alot of hours trying get arround this behavior.

 

0
mc24
9/22/2006 6:39:52 AM

Hi guys,

I'm not sure what problem you're having.   If you put runat="server" on all of your AccordionPanes it will work fine.  I even created and tested the following:
 

<%@ Page Language="C#" %>
<%@ Register Assembly="AtlasControlToolkit" Namespace="AtlasControlToolkit" TagPrefix="atlasToolkit" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<script runat="server">
</script>
<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server"><title>Test Page</title></head>
<body><form runat="server"><div>
    <atlas:ScriptManager ID="ScriptManager" runat="server" />
    <atlasToolkit:Accordion ID="operate_container" runat="server" CssClass="Operate Accordion">
        <Panes>
	        <atlasToolkit:AccordionPane ID="tag_container" runat="server">
		        <Header>
			        asd
		        </Header>
		        <Content>
			        123
		        </Content>
	        </atlasToolkit:AccordionPane>
	        <atlasToolkit:AccordionPane ID="find_container"  runat="server">
		        <Header>
			        dsa
		        </Header>
		        <Content>
			        3221
		        </Content>
	        </atlasToolkit:AccordionPane>
        </Panes>
    </atlasToolkit:Accordion>    
</div></form></body>
</html>
Could you try this and see if it works for you?

Thanks,
Ted


This posting is provided "AS IS" with no warranties, and confers no rights.
0
Ted
9/22/2006 9:58:35 PM

Hi Ted~

The Accordion is displaying correctly now, but I also got new problem...

So, If I put a Data-Bindding-Control in a AccordionPane, in DesignView, it displays nothing indeed.

Here's also the example: 

1    <%@ Control Language="C#" %>
2    <%@ Register Assembly="AtlasControlToolkit" Namespace="AtlasControlToolkit" TagPrefix="atlasToolkit" %>
3    <script runat="server">
4    </script>
5    <asp:Panel ID="Panel1" runat="server" Height="50px" Width="125px">
6    	<atlas:ScriptManagerProxy ID="ScriptManagerProxy1" runat="server">
7    	</atlas:ScriptManagerProxy>
8        <atlasToolkit:Accordion ID="operate_container" runat="server" CssClass="Operate Accordion">
9            <Panes>
10   	        <atlasToolkit:AccordionPane ID="tag_container" runat="server">
11   		        <Header>
12   			        asd
13   		        </Header>
14   		        <Content>
15   					<asp:DataList ID="applyTag" runat="server" DataKeyField="Id" DataSourceID="tagData">
16   						<ItemTemplate>
17   							<asp:LinkButton ID="name" runat="server" Text='<%# Eval("Name") %>' OnCommand="ApplyTag" CommandArgument='<%# Eval("Name") %>'></asp:LinkButton>
18   						</ItemTemplate>
19   					</asp:DataList>
20   					<asp:FormView ID="addTag" runat="server" DataKeyNames="Id" DataSourceID="tagData" DefaultMode="Insert">
21   						<InsertItemTemplate>
22   							<asp:TextBox ID="nameToInsert" runat="server" Text='<%# Bind("Name") %>'></asp:TextBox>
23   							<asp:LinkButton ID="insert" runat="server" CausesValidation="True" CommandName="Insert" Text="Add"></asp:LinkButton>
24   						</InsertItemTemplate>
25   					</asp:FormView>
26   		        </Content>
27   	        </atlasToolkit:AccordionPane>
28   	        <atlasToolkit:AccordionPane ID="find_container"  runat="server">
29   		        <Header>
30   			        dsa
31   		        </Header>
32   		        <Content>
33   			        321
34   		        </Content>
35   	        </atlasToolkit:AccordionPane>
36           </Panes>
37       </atlasToolkit:Accordion>
38   </asp:Panel>
 
0
aldwis
9/24/2006 10:58:02 PM
Hi aldwis,

This is a known issue - the Accordion currently has very limited design time support that just dumps out the contents of any static AccordionPanes.  Since your databound content is being generated dynamically you won't see it at design time.

Thanks,
Ted

This posting is provided "AS IS" with no warranties, and confers no rights.
0
Ted
9/26/2006 8:31:22 PM

I have the same problem.

all my ajaxToolkit:AccordionPane node hase runat server yag as well as accordion itself.

it was working before suddenly it sopped working in design view.

any other idea?


Maysam K Dabbagh
0
m_karbala
9/19/2007 4:38:30 PM

i have the same problem, now with the latest Ajax Control Toolkit (thought the prob would have been solved???)

 heres my code (u can see not a runat=server prob) 

<div>

<ajaxToolkit:Accordion ID="Accordion1" runat="server" Height="224px" Width="450px">

<Panes>

<ajaxToolkit:AccordionPane ID="AccordionPane4" runat="server" ContentCssClass=""

HeaderCssClass="">

<Header>Heading 1</Header>

<Content>Content ash ahf alkjsh aushaiuh ajks uwer iqwu</Content>

</ajaxToolkit:AccordionPane>

<ajaxToolkit:AccordionPane ID="AccordionPane5" runat="server" ContentCssClass=""

HeaderCssClass="">

<Header>Heading 1</Header>

<Content>Content ash ahf alkjsh aushaiuh ajks uwer iqwu</Content>

</ajaxToolkit:AccordionPane>

<ajaxToolkit:AccordionPane ID="AccordionPane6" runat="server" ContentCssClass=""

HeaderCssClass="">

<Header>Heading 1</Header>

<Content>Content ash ahf alkjsh aushaiuh ajks uwer iqwu</Content>

</ajaxToolkit:AccordionPane>

</Panes>

 

</ajaxToolkit:Accordion>

</div>

with the new toolkit, it says a new error -

Error message states: "ERROR RENDERING CONTROL - Accordion 1

 An unhandeled exception has occured.

Collection was modified; enumeration operation may not execute"

I would like to notify here this error never occurs in the downloaded solution (that came along the Toolkit) is there any sort of reference not included in my project, please help


Software Engineer
CTech
MS(SE) - SZABIST
IS1-SOA - Interoperability - XML - Web Services
0
dr
9/24/2007 5:08:45 PM

In my case restarting VS helped.

0
anomander
9/25/2007 10:27:20 AM

I was having this problem also. After comparing with the toolkit sample website, I was able to fix by adding a SelectedIndex="0" property

<ajaxToolkit:Accordion ID="Accordion1" runat="server" Height="224px" Width="450px" SelectedIndex="0">

 hope this helps

0
pwales
11/9/2007 1:56:52 AM

pwales:

I was having this problem also. After comparing with the toolkit sample website, I was able to fix by adding a SelectedIndex="0" property

<ajaxToolkit:Accordion ID="Accordion1" runat="server" Height="224px" Width="450px" SelectedIndex="0">

 hope this helps

 

 

It helped in my case! Where I have a number of static panes... thanks!
 

0
Petrander
2/9/2008 8:08:59 AM
Reply:

Similar Artilces:

"Error creating control" in design view
Hello, I have a page with some home-grown user controls and a 3rd party control on it and I changed a few colours on the 3rd party control. Now I get "error creating control" boxes in the design view for my user controls. The tooltip says it can't create the control "3rd.party.namespace.mycontrol" - like as if it's looking in the 3rd party assembly to find my control. Why? What I am doing wrong? Thanks for any help, ..pd. Make sure you have the Runat="Server" property set. Jeff Thanks Jeff - I don't know what the problem was but I did hav...

"Error Creating Control" on server control
Hi, I developped a simple DataDropDown inherited from dropdownlist just like the one that is available on the MSDN website. Neither my server control nor the microsoft's one works in my development environment. First I opened the example from Microsoft in my development environment, the microsoft datadropdown displays over the control an error "Parser Error : Request of the permission of type System.Web.Aspnethosting ...." In the .NET configuration, I changed the security level for the Local Intranet to "Full Trust". Then the control displayed properly. I ...

"Error Creating Control" in VS.NET 2003 opening aspx files
Hi, I recently upgraded to VS.NET 2003 and when I open some of my aspx files some controls are not generated onscreen and I get a message where the control is supposed to be saying "Error Creating Control". When I hover over it it tells me that some tag is missing. Then I discovered that for some reason some characters in the source file are disappearing like instead of RUNAT=SERVER I get RUNAT=SEVER. I dont save the file and then check the original ASPX in notepad and the tag is correct and in VS.NET is not. How can I fix this? A co-worker does not have this problem on...

"Error on page" when clciking "Jobs" in "Printer Control" with iManager
Hello all, I have the following issue in iManager : when I click on "Jobs" in "Printer Control" tab for a printer object, I have the following error message : "Error on page"/"Done with Error" in the left down corner of my Internet Explorer (v6.0) If I double click on the error message, I have either "Expected ')'" or "Object Expected" in the error description window. What surprise me is the fact that it occurs only on printers from one of our four NDPSM. (This is why I didn't post on the imanager forum) Tho...

"Error Creating Control" when dragging control from toolbox
I am having a problem in a VS 2003 web application.  When I drag any ASP control from my toolbox to my web page, I get an error in the designer saying "Error Creating Control: Parsor Error: Literal content ('Label') is not allowed within a 'System.Web.UI.WebControls.Label'." (I dragged a Label on in this case.) When I switch to the source view, I see that this was added to the top of the page. <%@ Register TagPrefix="cc1" Namespace="System.Web.UI.WebControls" Assembly="System.Web" %> Also, this is what my Label looks like. <cc1:Label id="Label1" runat="server">Label<...

"Error Creating Control"
Hi,I am seeing a "Error Creating Control" message instead of a literal on a web form where the text value is being set using a Resource Expression. The resource file and the key exists but for some reason, the designer is not able to show the resource value. How can I debug this problem? Thanks   ashwinphilar:I am seeing a "Error Creating Control" message instead of a literal on a web form where the text value is being set using a Resource Expression. The resource file and the key exists but for some reason, the designer is not able to show the resource ...

"Error Creating Control"?
Dear All, I checked the thread in this forum and some threads are mentioned this error message in which they also provided the solution to fix it. However, I follow all the steps, it's still failed. The error is still here. When I built the application, it's success, but browsing the page, it's prompted that "Object reference not set to an instance of an object." In my case, I was upgraded the application from VS.NET 2002, CR8.5 to VS.NET 2003 and CR9.0. I make sure that the Reference in the project, the crystalreportviewer in the toolbox, the register tag, the web.conf...

Custom webcontrol
I have created a custom control derived from the DropDownList class. It works just fine, but in designview in Visual Studio, I get the "Error creating control" when I drag the control into the webform. When I hold the mousecursor over it, it says "Object reference not set to an instance of an object". Like I said, the control shows and runs just fine in the browser, so it's not really a big problem. Still, it bugs me quite a lot. Anybody got any suggestions/ideas to why this happens? Thanks!I haven't failed, I've found 10,000 ways that don't work Have ...

"The RPC server is unavailable" and "You are not authorized to view this page" Errors in viewing aspx
when i try to view an aspx page, it gives me an "You are not authorized to view this page"... then it asks me to login again and it will again display "You are not authorized to view this page". i have checked the permissions of the folder where my aspx is located and it has my user account added with full access. in addition, sometimes this page displays "the rpc server is unavailable". i tried microsoft support website but the instructions are not helpful. anyone? Hi there, What version of IIS are your running on your box?? Cheers!Sunny NA...

if use "union select" in "create view"?
-- ********************************* Yang Shuang E-mail:yangshuang@interpowers.com Phone:(010)82856197-209 ********************************* Views are not allowed to contain UNIONS prior to the ASE 12.5 release. It is allowed in 12.5. -bret yangshuang wrote: Re: if use "union select" in "create view"? ...

Hotfix for "Design view does not update HTML" and to "Designer inserts a lot of &nbsp;"
UPDATE: The download is temporary removed since unfortunately update uncovered latent bug that may cause designer to change URL format in image and hyperlink controls. We are expecting to publish fixed version shortly. A hotfix is available for issues most commontly described as "I make changes in Design view but Source does not get updated" and "After certain actions designer inserts a lot of &nbsp; in the page". http://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=17185 Do not be surprised that update is named Office...

Hotfix for "Design view does not update HTML" and to "Designer inserts a lot of &nbsp;"
UPDATE: The download is temporary removed since unfortunately update uncovered latent bug that may cause designer to change URL format in image and hyperlink controls. We are expecting to publish fixed version shortly  A hotfix is available for issues most commontly described as "I make changes in Design view but Source does not get updated" and "After certain actions designer inserts a lot of &nbsp; in the page". http://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=17185 Do not be surprised that update is named Of...

"Write your own extender" example in AJAX Control Toolkit not working
I installed the Control Toolkit, then followed the instructions for the VB version of "write your own extender".Here's the URL of the directions from the toolkit: http://localhost:56850/SampleWebSite/Walkthrough/CreatingNewExtender.aspxI think that I installed everything correctly and followed all directions, but when I try to run the "DisableButton" sample, I get the following error: Extender control 'DisableButtonExtender1' cannot extend 'Button1'. Extender controls of type 'DisableButton.DisableButton.DisableButtonExtender' cannot extend controls of type 'System.Web.UI.WebControls.Bu...

How to programmatically access "Create User" button in CreateUserWizard control and "Log In" button in Login control?
Hello, How can I programmatically access "Create User" button in CreateUserWizard control? Also how can I programmatically access "Log In" button in Login control?  Improving lifestyles for luxury pets: TheFabulousPet Hi, here is the way in this example I change only the buttons text on page load (you didn't specify what property exactly want to access):Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load Login1.LoginButtonText = "test" CreateUserWizard1.CreateUserButtonText = "test2" End ...

"Error Creating Control" After Build
I am experiencing an annoyance I hope someone can help alleviate.  After I compile an assembly that contains a web control, the web forms designer gives an error creating the control and I have to restart Visual Studio to regain design-time support.  It is some versioning problem and I assume I have to clear some assembly cache in order to fix it.  This will avoid the constant restarts, which gets on my nerves fast. I have two projects...a web site using my local file system and a class library that contains a web control.  The web site references the control library usi...

Web resources about - "Error Creating Control" - Accordion.Panes - in design view. - asp.net.ajax_control_toolkit

Resources last updated: 12/15/2015 11:56:45 PM